summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-10-06 09:17:37 +0000
commit2e92514fb34e1f80047f1661e4193fa9a3d3a06c (patch)
treef15f05d59c776fb13bf637e65c070c72f7b65720 /kde-base/solid
parentFix libpng SLOT depend wrt #339796 by "MaratIK". (diff)
downloadgentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.gz
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.tar.bz2
gentoo-2-2e92514fb34e1f80047f1661e4193fa9a3d3a06c.zip
Add KDE SC 4.5.2 =)
(Portage version: 2.2_rc88_p115/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/solid')
-rw-r--r--kde-base/solid/ChangeLog7
-rw-r--r--kde-base/solid/solid-4.5.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/solid/ChangeLog b/kde-base/solid/ChangeLog
index 4c9f270de8ee..4d8b10605afe 100644
--- a/kde-base/solid/ChangeLog
+++ b/kde-base/solid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/solid
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.87 2010/09/06 02:03:40 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/ChangeLog,v 1.88 2010/10/06 09:17:21 alexxy Exp $
+
+*solid-4.5.2 (05 Oct 2010)
+
+ 05 Oct 2010; Alexey Shvetsov <alexxy@gentoo.org> +solid-4.5.2.ebuild:
+ Version bump KDE SC 4.5.2
*solid-4.5.1 (06 Sep 2010)
diff --git a/kde-base/solid/solid-4.5.2.ebuild b/kde-base/solid/solid-4.5.2.ebuild
new file mode 100644
index 000000000000..4f13a308ab5b
--- /dev/null
+++ b/kde-base/solid/solid-4.5.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/solid/solid-4.5.2.ebuild,v 1.1 2010/10/06 09:17:21 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebase-workspace"
+CPPUNIT_REQUIRED="test"
+inherit kde4-meta
+
+DESCRIPTION="Solid: the KDE hardware library"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="bluetooth debug +hal networkmanager wicd"
+
+# solid/CMakeLists.txt has an add_subdirectory statement that depends on
+# networkmanager-0.7, referring to a non-existant directory, restricted to =0.6*
+# for now.
+DEPEND="
+ bluetooth? ( net-wireless/bluez )
+ networkmanager? ( >=net-misc/networkmanager-0.7 )
+ wicd? ( net-misc/wicd )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep solid-runtime)
+ hal? ( sys-apps/hal )
+"
+
+KMEXTRA="
+ libs/solid/
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4.69-darwin-compile-powermanager.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with bluetooth BlueZ)
+ $(cmake-utils_use_with networkmanager NetworkManager)
+ $(cmake-utils_use_build wicd)
+ )
+
+ kde4-meta_src_configure
+}