summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:48:18 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:48:18 +0000
commit56f5cc8b4432353445da134a374d51e36a80a604 (patch)
treece0fa8ab2d264a1f8088513668532bcea29d0ea3 /kde-base/superkaramba
parentVersion bump to KDE 4.0.3. This is still not intended for mainstream so DO NO... (diff)
downloadgentoo-2-56f5cc8b4432353445da134a374d51e36a80a604.tar.gz
gentoo-2-56f5cc8b4432353445da134a374d51e36a80a604.tar.bz2
gentoo-2-56f5cc8b4432353445da134a374d51e36a80a604.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/superkaramba')
-rw-r--r--kde-base/superkaramba/ChangeLog9
-rw-r--r--kde-base/superkaramba/files/superkaramba-as-needed.patch19
-rw-r--r--kde-base/superkaramba/superkaramba-4.0.3.ebuild28
3 files changed, 55 insertions, 1 deletions
diff --git a/kde-base/superkaramba/ChangeLog b/kde-base/superkaramba/ChangeLog
index 6f4e4a70751c..1d3ddb44bdd5 100644
--- a/kde-base/superkaramba/ChangeLog
+++ b/kde-base/superkaramba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/superkaramba
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.70 2008/03/20 18:26:54 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/ChangeLog,v 1.71 2008/04/03 21:48:17 philantrop Exp $
+
+*superkaramba-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/superkaramba-as-needed.patch, +superkaramba-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/superkaramba-4.0.1-as-needed.patch, -superkaramba-4.0.1.ebuild:
diff --git a/kde-base/superkaramba/files/superkaramba-as-needed.patch b/kde-base/superkaramba/files/superkaramba-as-needed.patch
new file mode 100644
index 000000000000..85d6956048c7
--- /dev/null
+++ b/kde-base/superkaramba/files/superkaramba-as-needed.patch
@@ -0,0 +1,19 @@
+--- superkaramba-4.0.1/superkaramba/src/CMakeLists.txt 2008-02-07 18:45:04.000000000 +0100
++++ superkaramba-4.0.1.new/superkaramba/src/CMakeLists.txt 2008-02-07 18:46:52.000000000 +0100
+@@ -82,6 +82,16 @@
+ KDE4_ADD_LIBRARY(superkaramba SHARED ${superkaramba_LIB_SRCS})
+ set_target_properties(superkaramba PROPERTIES VERSION ${GENERIC_LIB_VERSION} SOVERSION ${GENERIC_LIB_SOVERSION} )
+
++FIND_LIBRARY(LIBDL dl)
++IF(LIBDL)
++ LIST(APPEND PYTHON_LIBRARIES ${LIBDL})
++ENDIF(LIBDL)
++
++FIND_LIBRARY(LIBUTIL util)
++IF(LIBUTIL)
++ LIST(APPEND PYTHON_LIBRARIES ${LIBUTIL})
++ENDIF(LIBUTIL)
++
+ TARGET_LINK_LIBRARIES(superkaramba
+ ${KDE4_KIO_LIBS}
+ ${KDE4_KPTY_LIBS}
diff --git a/kde-base/superkaramba/superkaramba-4.0.3.ebuild b/kde-base/superkaramba/superkaramba-4.0.3.ebuild
new file mode 100644
index 000000000000..31e4d4427a26
--- /dev/null
+++ b/kde-base/superkaramba/superkaramba-4.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/superkaramba/superkaramba-4.0.3.ebuild,v 1.1 2008/04/03 21:48:17 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeutils
+inherit kde4-meta
+
+DESCRIPTION="A tool to create interactive applets for the KDE desktop."
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook python"
+
+COMMONDEPEND="
+ kde-base/qimageblitz
+ >=kde-base/plasma-$PV:$SLOT
+ python? ( dev-lang/python )"
+DEPEND="${COMMONDEPEND}"
+RDEPEND="${COMMONDEPEND}"
+
+PATCHES="${FILESDIR}/${PN}-as-needed.patch"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with python PythonLibs)"
+
+ kde4-meta_src_compile
+}