summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:21:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:21:50 +0000
commit857947c8d9fc31f019c80a44d37b95736e299074 (patch)
tree5327edc62456b9db59681229201393f06e1ae905 /kde-base/systemsettings
parentVersion bump KDE 4.2.3 (diff)
downloadgentoo-2-857947c8d9fc31f019c80a44d37b95736e299074.tar.gz
gentoo-2-857947c8d9fc31f019c80a44d37b95736e299074.tar.bz2
gentoo-2-857947c8d9fc31f019c80a44d37b95736e299074.zip
Version bump KDE 4.2.3
(Portage version: 2.2_rc31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/systemsettings')
-rw-r--r--kde-base/systemsettings/ChangeLog8
-rw-r--r--kde-base/systemsettings/systemsettings-4.2.3.ebuild97
2 files changed, 104 insertions, 1 deletions
diff --git a/kde-base/systemsettings/ChangeLog b/kde-base/systemsettings/ChangeLog
index 1c9fd6ae4405..d2d863e0bb60 100644
--- a/kde-base/systemsettings/ChangeLog
+++ b/kde-base/systemsettings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/systemsettings
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.31 2009/05/05 16:22:08 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/ChangeLog,v 1.32 2009/05/07 00:21:50 scarabeus Exp $
+
+*systemsettings-4.2.3 (07 May 2009)
+
+ 07 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +systemsettings-4.2.3.ebuild:
+ Version bump
05 May 2009; Rémi Cardona <remi@gentoo.org> systemsettings-4.2.2.ebuild:
drop x11-misc/xkbdata support (see bug #196650)
diff --git a/kde-base/systemsettings/systemsettings-4.2.3.ebuild b/kde-base/systemsettings/systemsettings-4.2.3.ebuild
new file mode 100644
index 000000000000..0d24d85c10c9
--- /dev/null
+++ b/kde-base/systemsettings/systemsettings-4.2.3.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/systemsettings/systemsettings-4.2.3.ebuild,v 1.1 2009/05/07 00:21:50 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="System settings utility"
+IUSE="debug doc +usb xinerama"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+
+COMMONDEPEND="
+ >=dev-libs/glib-2
+ media-libs/fontconfig
+ >=media-libs/freetype-2
+ >=x11-libs/libxklavier-3.2
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ opengl? ( virtual/opengl )
+ usb? ( dev-libs/libusb )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/kbproto
+ x11-proto/xextproto
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}
+ >=kde-base/kcontrol-${PV}:${SLOT}[kdeprefix=]
+ x11-apps/setxkbmap
+ || (
+ x11-misc/xkbdata
+ x11-misc/xkeyboard-config
+ )
+"
+
+KMEXTRA="
+ kcontrol/
+"
+KMEXTRACTONLY="
+ krunner/dbus/org.kde.krunner.App.xml
+ krunner/dbus/org.kde.screensaver.xml
+ kwin/
+ libs/
+ plasma/
+"
+
+PATCHES=( "$FILESDIR/20_use_dejavu_as_default_font.patch" )
+
+src_unpack() {
+ if use doc; then
+ KMEXTRA="${KMEXTRA}
+ doc/kcontrol
+ "
+ fi
+
+ kde4-meta_src_unpack
+}
+
+src_prepare() {
+ sed -i -e 's/systemsettingsrc DESTINATION ${SYSCONF_INSTALL_DIR}/systemsettingsrc DESTINATION ${CONFIG_INSTALL_DIR}/' \
+ systemsettings/CMakeLists.txt \
+ || die "Failed to fix systemsettingsrc install location"
+
+ if ! version_is_at_least 4.1.2 "$(gcc-fullversion)" ; then
+ ewarn
+ ewarn "The kxkb module will be built without keyboard hot-plugging"
+ ewarn "support. GCC version 4.1.2 or greater is required to build"
+ ewarn "kxkb's keyboard hot-plugging code."
+ ewarn
+ ebeep 5
+ epatch "$FILESDIR/${PN}-4.2.1-kxkb-strip-hot_plugging-support.patch"
+ fi
+
+ kde4-meta_src_prepare
+}
+
+# FIXME: is have_openglxvisual found without screensaver
+src_configure() {
+ # Old keyboard-detection code is unmaintained,
+ # so we force the new stuff, using libxklavier.
+ mycmakeargs="${mycmakeargs}
+ -DUSE_XKLAVIER=ON -DWITH_LibXKlavier=ON
+ -DWITH_GLIB2=ON -DWITH_GObject=ON
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with usb USB)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}