summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-05-10 17:18:37 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-05-10 17:18:37 +0000
commit0c47a92ab5f9d5446d032da8edeff15155152c5f (patch)
tree1d94e2038796448a68197f4fe45f308a1235e168 /kde-base
parentAdd CPE for policycoreutils (diff)
downloadgentoo-2-0c47a92ab5f9d5446d032da8edeff15155152c5f.tar.gz
gentoo-2-0c47a92ab5f9d5446d032da8edeff15155152c5f.tar.bz2
gentoo-2-0c47a92ab5f9d5446d032da8edeff15155152c5f.zip
Backport patch from upstream to fix build with USE="v4l" and Linux 3.9, wrt bug #468844.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/files/kopete-4.10.3-v4l.patch25
-rw-r--r--kde-base/kopete/kopete-4.10.3.ebuild4
3 files changed, 34 insertions, 2 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 6f2b4e8aa85d..536a1913a12c 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.368 2013/05/08 20:46:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.369 2013/05/10 17:18:37 kensington Exp $
+
+ 10 May 2013; Michael Palimaka <kensington@gentoo.org>
+ +files/kopete-4.10.3-v4l.patch, kopete-4.10.3.ebuild:
+ Backport patch from upstream to fix build with USE="v4l" and Linux 3.9, wrt
+ bug #468844.
08 May 2013; Johannes Huber <johu@gentoo.org> metadata.xml:
Cleanup unused USE description.
diff --git a/kde-base/kopete/files/kopete-4.10.3-v4l.patch b/kde-base/kopete/files/kopete-4.10.3-v4l.patch
new file mode 100644
index 000000000000..d48cb4506bfc
--- /dev/null
+++ b/kde-base/kopete/files/kopete-4.10.3-v4l.patch
@@ -0,0 +1,25 @@
+Index: libkopete/avdevice/videodevice.cpp
+===================================================================
+--- kopete/libkopete/avdevice/videodevice.cpp (revision 1353128)
++++ kopete/libkopete/avdevice/videodevice.cpp (working copy)
+@@ -3050,7 +3050,9 @@
+ case V4L2_CID_AUDIO_TREBLE: return I18N_NOOP("Treble");
+ case V4L2_CID_AUDIO_MUTE: return I18N_NOOP("Mute");
+ case V4L2_CID_AUDIO_LOUDNESS: return I18N_NOOP("Loudness");
++#ifdef V4L2_CID_BLACK_LEVEL // deprecated, likely to be removed soon
+ case V4L2_CID_BLACK_LEVEL: return I18N_NOOP("Black Level");
++#endif
+ case V4L2_CID_AUTO_WHITE_BALANCE: return I18N_NOOP("Automatic White Balance");
+ case V4L2_CID_DO_WHITE_BALANCE: return I18N_NOOP("Do White Balance");
+ case V4L2_CID_RED_BALANCE: return I18N_NOOP("Red Balance");
+@@ -3061,8 +3063,10 @@
+ case V4L2_CID_GAIN: return I18N_NOOP("Gain");
+ case V4L2_CID_HFLIP: return I18N_NOOP("Horizontal Flip");
+ case V4L2_CID_VFLIP: return I18N_NOOP("Vertical Flip");
++#ifdef V4L2_CID_HCENTER // removed in kernel 3.9
+ case V4L2_CID_HCENTER: return I18N_NOOP("Horizontal Center");
+ case V4L2_CID_VCENTER: return I18N_NOOP("Vertical Center");
++#endif
+ #ifdef V4L2_CID_POWER_LINE_FREQUENCY // since kernel 2.6.25
+ case V4L2_CID_POWER_LINE_FREQUENCY: return I18N_NOOP("Power Line Frequency");
+ case V4L2_CID_HUE_AUTO: return I18N_NOOP("Automatic Hue");
diff --git a/kde-base/kopete/kopete-4.10.3.ebuild b/kde-base/kopete/kopete-4.10.3.ebuild
index be72edb52240..23bd00548941 100644
--- a/kde-base/kopete/kopete-4.10.3.ebuild
+++ b/kde-base/kopete/kopete-4.10.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.10.3.ebuild,v 1.1 2013/05/06 20:18:30 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.10.3.ebuild,v 1.2 2013/05/10 17:18:37 kensington Exp $
EAPI=5
@@ -109,6 +109,8 @@ DEPEND="${COMMONDEPEND}
!aqua? ( x11-proto/scrnsaverproto )
"
+PATCHES=( "${FILESDIR}/${P}-v4l.patch" )
+
src_prepare() {
sed -e "s:lib/mozilla:$(get_libdir)/mozilla:" \
-i kopete/protocols/skype/skypebuttons/CMakeLists.txt || die "sed failed"