summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-08-09 11:29:12 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-08-09 11:29:12 +0000
commit12e9eb6293fc5c6115dc0649f3e648d2978e2883 (patch)
treefaf4fbd071eb60778c50373c458ea87056ee29d1 /kde-base
parentEnable flac by default (acked by likewhoa). (diff)
downloadgentoo-2-12e9eb6293fc5c6115dc0649f3e648d2978e2883.tar.gz
gentoo-2-12e9eb6293fc5c6115dc0649f3e648d2978e2883.tar.bz2
gentoo-2-12e9eb6293fc5c6115dc0649f3e648d2978e2883.zip
Revision bump. Install pyuic4 on 4.2 too. Per bug #279697. Force due to unsynced tree.
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/pykde4/ChangeLog9
-rw-r--r--kde-base/pykde4/files/pykde4-installation-fix.patch4
-rw-r--r--kde-base/pykde4/pykde4-4.2.4-r3.ebuild (renamed from kde-base/pykde4/pykde4-4.2.4-r2.ebuild)3
-rw-r--r--kde-base/pykde4/pykde4-4.2.4.ebuild77
4 files changed, 12 insertions, 81 deletions
diff --git a/kde-base/pykde4/ChangeLog b/kde-base/pykde4/ChangeLog
index 49b23d6fcac8..f55c7f0161ba 100644
--- a/kde-base/pykde4/ChangeLog
+++ b/kde-base/pykde4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/pykde4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.25 2009/08/04 01:33:28 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/ChangeLog,v 1.26 2009/08/09 11:29:12 scarabeus Exp $
+
+*pykde4-4.2.4-r3 (09 Aug 2009)
+
+ 09 Aug 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ files/pykde4-installation-fix.patch, -pykde4-4.2.4.ebuild,
+ -pykde4-4.2.4-r2.ebuild, +pykde4-4.2.4-r3.ebuild:
+ Revision bump. Install pyuic4 on 4.2 too. Per bug #279697.
*pykde4-4.3.0 (04 Aug 2009)
diff --git a/kde-base/pykde4/files/pykde4-installation-fix.patch b/kde-base/pykde4/files/pykde4-installation-fix.patch
index a0a3e642d495..40ec5b5b24a9 100644
--- a/kde-base/pykde4/files/pykde4-installation-fix.patch
+++ b/kde-base/pykde4/files/pykde4-installation-fix.patch
@@ -3,8 +3,8 @@ Index: python/pykde4/tools/pykdeuic4/CMakeLists.txt
--- python/pykde4/tools/pykdeuic4/CMakeLists.txt (revision 1001414)
+++ python/pykde4/tools/pykdeuic4/CMakeLists.txt (working copy)
@@ -1,2 +1,4 @@
- PYTHON_INSTALL(kde4.py ${PYTHON_SITE_PACKAGES_DIR}/PyQt4/uic/widget-plugins/)
--PYTHON_INSTALL(pykdeuic4.py ${BIN_INSTALL_DIR}/pykdeuic4)
+ PYTHON_INSTALL(kde4.py ${DATA_INSTALL_DIR}/${PROJECT_NAME})
+-PYTHON_INSTALL(pykdeuic4.py ${DATA_INSTALL_DIR}/${PROJECT_NAME})
+PYTHON_INSTALL(pykdeuic4.py ${PYTHON_SITE_PACKAGES_DIR}/PyQt4/uic/)
+find_path(cmake_module_dir create_exe_symlink.cmake ${CMAKE_MODULE_PATH})
+INSTALL(CODE "EXECUTE_PROCESS(COMMAND ${CMAKE_COMMAND} -DTARGET=${PYTHON_SITE_PACKAGES_DIR}/PyQt4/uic/pykdeuic4.py -DLINK_NAME=${BIN_INSTALL_DIR}/pykdeuic4 -P ${cmake_module_dir}/create_exe_symlink.cmake)" )
diff --git a/kde-base/pykde4/pykde4-4.2.4-r2.ebuild b/kde-base/pykde4/pykde4-4.2.4-r3.ebuild
index e9face6a456a..470c616fd072 100644
--- a/kde-base/pykde4/pykde4-4.2.4-r2.ebuild
+++ b/kde-base/pykde4/pykde4-4.2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.2.4-r2.ebuild,v 1.1 2009/06/16 15:27:57 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.2.4-r3.ebuild,v 1.1 2009/08/09 11:29:12 scarabeus Exp $
EAPI="2"
@@ -24,6 +24,7 @@ RDEPEND="${DEPEND}
"
PATCHES=(
"${FILESDIR}"/pykde4_sip-4.8.patch
+ "${FILESDIR}"/pykde4-installation-fix.patch
)
src_prepare() {
diff --git a/kde-base/pykde4/pykde4-4.2.4.ebuild b/kde-base/pykde4/pykde4-4.2.4.ebuild
deleted file mode 100644
index 5e224285bc2e..000000000000
--- a/kde-base/pykde4/pykde4-4.2.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/pykde4/pykde4-4.2.4.ebuild,v 1.2 2009/06/04 14:16:56 alexxy Exp $
-
-EAPI="2"
-
-KMNAME="kdebindings"
-KMMODULE="python/${PN}"
-OPENGL_REQUIRED="always"
-inherit python kde4-meta
-
-DESCRIPTION="Python bindings for KDE4"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="akonadi debug examples semantic-desktop"
-
-DEPEND="
- >=dev-python/PyQt4-4.4.4-r1[dbus,qt3support,svg,webkit,X]
- >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,opengl,semantic-desktop?]
- akonadi? ( >=kde-base/kdepimlibs-${PV}:${SLOT}[kdeprefix=] )
-"
-# blocker added due to compatibility issues and error during compile time
-RDEPEND="${DEPEND}
- !dev-python/pykde
- !>=dev-python/PyQt4-4.5_pre1
-"
-
-src_prepare() {
- kde4-meta_src_prepare
-
- if ! use examples; then
- sed -e '/^ADD_SUBDIRECTORY(examples)/s/^/# DISABLED /' -i python/${PN}/CMakeLists.txt \
- || die "Failed to disable examples"
- fi
-}
-
-src_configure() {
- mycmakeargs="${mycmakeargs}
- -DWITH_QScintilla=OFF
- $(cmake-utils_use_with semantic-desktop Soprano)
- $(cmake-utils_use_with semantic-desktop Nepomuk)
- $(cmake-utils_use_with akonadi Akonadi)
- $(cmake-utils_use_with akonadi KdepimLibs)"
-
- kde4-meta_src_configure
-}
-
-src_install() {
- kde4-meta_src_install
-
- python_version
- rm -f \
- "${D}/usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4/*.py[co] \
- "${D}${PREFIX}"/share/apps/"${PN}"/*.py[co]
-}
-
-pkg_postinst() {
- kde4-meta_pkg_postinst
-
- python_mod_optimize "/usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4
- # Do not optimize examples
- python_mod_compile "${PREFIX}"/share/apps/"${PN}"/*.py
-
- if use examples; then
- echo
- elog "PyKDE4 examples have been installed to"
- elog "${PREFIX}/share/apps/${PN}/examples"
- echo
- fi
-}
-
-pkg_postrm() {
- kde4-meta_pkg_postrm
-
- python_mod_cleanup \
- "/usr/$(get_libdir)/python${PYVER}"/site-packages/PyKDE4 \
- "${PREFIX}"/share/apps/"${PN}"
-}