summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-08-11 20:12:08 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-08-11 20:12:08 +0000
commit33304e46982f0902bb5c4768ff917004e23a2388 (patch)
treea0bf365106c4297b1785d119d130337ef4fb953d /kde-base
parentRemoving Gnome 2.14 (diff)
downloadgentoo-2-33304e46982f0902bb5c4768ff917004e23a2388.tar.gz
gentoo-2-33304e46982f0902bb5c4768ff917004e23a2388.tar.bz2
gentoo-2-33304e46982f0902bb5c4768ff917004e23a2388.zip
Added an upstream patch to allow pwc-driven webcams to work again in Kopete. Second part of fixing bug 187400.
(Portage version: 2.1.3.3)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdenetwork/ChangeLog9
-rw-r--r--kde-base/kdenetwork/files/digest-kdenetwork-3.5.7-r16
-rw-r--r--kde-base/kdenetwork/files/kopete-3.5.7-videodevice.patch22
-rw-r--r--kde-base/kdenetwork/kdenetwork-3.5.7-r1.ebuild101
4 files changed, 137 insertions, 1 deletions
diff --git a/kde-base/kdenetwork/ChangeLog b/kde-base/kdenetwork/ChangeLog
index 8730471891a1..27d00bbd11d6 100644
--- a/kde-base/kdenetwork/ChangeLog
+++ b/kde-base/kdenetwork/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kdenetwork
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.273 2007/08/11 14:47:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/ChangeLog,v 1.274 2007/08/11 20:12:08 philantrop Exp $
+
+*kdenetwork-3.5.7-r1 (11 Aug 2007)
+
+ 11 Aug 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +files/kopete-3.5.7-videodevice.patch, +kdenetwork-3.5.7-r1.ebuild:
+ Added an upstream patch to allow pwc-driven webcams to work again in Kopete.
+ Fixes bug 187400.
11 Aug 2007; Raúl Porcel <armin76@gentoo.org> kdenetwork-3.5.7.ebuild:
x86 stable wrt #185823
diff --git a/kde-base/kdenetwork/files/digest-kdenetwork-3.5.7-r1 b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.7-r1
new file mode 100644
index 000000000000..ac045c99a7b9
--- /dev/null
+++ b/kde-base/kdenetwork/files/digest-kdenetwork-3.5.7-r1
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 d7f2a05a7e304b33128123c3f67ea636 kdenetwork-3.5.7.tar.bz2 9370098
+RMD160 85b2780b411f91afb7e2dd6670500c9046b8b591 kdenetwork-3.5.7.tar.bz2 9370098
+SHA256 979d93802693a76e2e4fc0f7bdd4c44bde48296f842619a2b59100d94346d596 kdenetwork-3.5.7.tar.bz2 9370098
diff --git a/kde-base/kdenetwork/files/kopete-3.5.7-videodevice.patch b/kde-base/kdenetwork/files/kopete-3.5.7-videodevice.patch
new file mode 100644
index 000000000000..50cb8a0f2d7b
--- /dev/null
+++ b/kde-base/kdenetwork/files/kopete-3.5.7-videodevice.patch
@@ -0,0 +1,22 @@
+--- branches/KDE/3.5/kdenetwork/kopete/libkopete/avdevice/videodevice.cpp 2006/08/17 13:37:13 573903
++++ branches/KDE/3.5/kdenetwork/kopete/libkopete/avdevice/videodevice.cpp 2007/06/09 01:27:58 673109
+@@ -1604,7 +1604,8 @@
+ case VIDEO_PALETTE_RGB32 : return PIXELFORMAT_RGB32; break;
+ case VIDEO_PALETTE_YUYV : return PIXELFORMAT_YUYV; break;
+ case VIDEO_PALETTE_UYVY : return PIXELFORMAT_UYVY; break;
+- case VIDEO_PALETTE_YUV420 : return PIXELFORMAT_YUV420P; break;
++ case VIDEO_PALETTE_YUV420 :
++ case VIDEO_PALETTE_YUV420P : return PIXELFORMAT_YUV420P; break;
+ case VIDEO_PALETTE_YUV422P : return PIXELFORMAT_YUV422P; break;
+ }
+ break;
+@@ -1758,7 +1759,8 @@
+ case VIDEO_PALETTE_RGB32 : returnvalue = pixelFormatName(PIXELFORMAT_RGB32); break;
+ case VIDEO_PALETTE_YUYV : returnvalue = pixelFormatName(PIXELFORMAT_YUYV); break;
+ case VIDEO_PALETTE_UYVY : returnvalue = pixelFormatName(PIXELFORMAT_UYVY); break;
+- case VIDEO_PALETTE_YUV420 : returnvalue = pixelFormatName(PIXELFORMAT_YUV420P); break;
++ case VIDEO_PALETTE_YUV420 :
++ case VIDEO_PALETTE_YUV420P : returnvalue = pixelFormatName(PIXELFORMAT_YUV420P); break;
+ case VIDEO_PALETTE_YUV422P : returnvalue = pixelFormatName(PIXELFORMAT_YUV422P); break;
+ }
+ break;
diff --git a/kde-base/kdenetwork/kdenetwork-3.5.7-r1.ebuild b/kde-base/kdenetwork/kdenetwork-3.5.7-r1.ebuild
new file mode 100644
index 000000000000..73b606e17240
--- /dev/null
+++ b/kde-base/kdenetwork/kdenetwork-3.5.7-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdenetwork/kdenetwork-3.5.7-r1.ebuild,v 1.1 2007/08/11 20:12:08 philantrop Exp $
+
+inherit kde-dist eutils flag-o-matic
+
+DESCRIPTION="KDE network applications: Kopete, KPPP, KGet,..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="jingle kdehiddenvisibility rdesktop sametime slp ssl wifi"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+BOTH_DEPEND="~kde-base/kdebase-${PV}
+ dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-1.0* )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ slp? ( net-libs/openslp )
+ wifi? ( net-wireless/wireless-tools )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ kernel_linux? ( virtual/opengl )"
+
+RDEPEND="${BOTH_DEPEND}
+ rdesktop? ( >=net-misc/rdesktop-1.4.1 )
+ dev-lang/perl
+ ssl? ( dev-perl/IO-Socket-SSL
+ app-crypt/qca-tls )
+ net-dialup/ppp
+ || ( net-misc/netkit-talk net-misc/ytalk sys-freebsd/freebsd-ubin )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ x11-proto/videoproto
+ x11-proto/xproto
+ kernel_linux? ( x11-libs/libXv )
+ x11-proto/scrnsaverproto"
+
+PATCHES="${FILESDIR}/kopete-3.5.5-icqfix.patch
+ ${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch
+ ${FILESDIR}/kopete-3.5.7-videodevice.patch"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+src_compile() {
+ export BINDNOW_FLAGS="$(bindnow-flags)"
+
+ local myconf="--with-libidn
+ $(use_enable sametime sametime-plugin)
+ $(use_enable slp) $(use_with wifi) $(use_enable jingle)
+ --without-xmms --without-external-libgadu"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ chmod u+s "${D}/${KDEDIR}/bin/reslisa"
+
+ # empty config file needed for lisa to work with default settings
+ dodir /etc
+ touch "${D}/etc/lisarc"
+
+ # lisa, reslisa initscripts
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" "${WORKDIR}/patches/lisa" > "${T}/lisa"
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" "${WORKDIR}/patches/reslisa" > "${T}/reslisa"
+ doinitd "${T}/lisa" "${T}/reslisa"
+
+ newconfd "${WORKDIR}/patches/lisa.conf" lisa
+ newconfd "${WORKDIR}/patches/reslisa.conf" reslisa
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ elog "If you would like to use Off-The-Record encryption with Kopete, emerge net-im/kopete-otr."
+
+ if has_version net-misc/ytalk ; then
+ elog "To use net-misc/ytalk as your local network chat program, please"
+ elog "configure your system accordingly, either via the KDE control center"
+ elog "or by calling \"kcmshell kcmktalkd\" on the command line."
+ fi
+}