summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-03-15 15:25:28 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-03-15 15:25:28 +0000
commit50e42733d1e3b48d2ec9d4b77a1fe277f11f53e9 (patch)
treebe842827e2060b4d109f49bf16c48c4829b7495a /kde-base
parentfix m4 depend (diff)
downloadgentoo-2-50e42733d1e3b48d2ec9d4b77a1fe277f11f53e9.tar.gz
gentoo-2-50e42733d1e3b48d2ec9d4b77a1fe277f11f53e9.tar.bz2
gentoo-2-50e42733d1e3b48d2ec9d4b77a1fe277f11f53e9.zip
removed crusty ebuild
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdelibs/files/digest-kdelibs-3.0.5a1
-rw-r--r--kde-base/kdelibs/files/kdelibs-3.0.3-ynet.diff14
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild5
-rw-r--r--kde-base/kdelibs/kdelibs-3.0.5a.ebuild77
4 files changed, 3 insertions, 94 deletions
diff --git a/kde-base/kdelibs/files/digest-kdelibs-3.0.5a b/kde-base/kdelibs/files/digest-kdelibs-3.0.5a
deleted file mode 100644
index d05d48bfa85c..000000000000
--- a/kde-base/kdelibs/files/digest-kdelibs-3.0.5a
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a3c714c7727ddc70e7c9ea6acf5e42dc kdelibs-3.0.5a.tar.bz2 7647507
diff --git a/kde-base/kdelibs/files/kdelibs-3.0.3-ynet.diff b/kde-base/kdelibs/files/kdelibs-3.0.3-ynet.diff
deleted file mode 100644
index 56f1d0e2ac24..000000000000
--- a/kde-base/kdelibs/files/kdelibs-3.0.3-ynet.diff
+++ /dev/null
@@ -1,14 +0,0 @@
---- khtml/xml/dom_docimpl.cpp 2002/08/07 13:22:09 1.191
-+++ khtml/xml/dom_docimpl.cpp 2002/08/16 00:41:19 1.192
-@@ -1412,8 +1412,9 @@ void DocumentImpl::processHttpEquiv(cons
- if(str.find("url", 0, false ) == 0) str = str.mid(3);
- str = str.stripWhiteSpace();
- if ( str.length() && str[0] == '=' ) str = str.mid( 1 ).stripWhiteSpace();
-- if ( (pos = str.findRev(';')) > 0) str.setLength(pos);
-- if ( (pos = str.findRev(',')) > 0) str.setLength(pos);
-+ while(str.length() &&
-+ (str[str.length()-1] == ';' || str[str.length()-1] == ','))
-+ str.setLength(str.length()-1);
- str = parseURL( DOMString(str) ).string();
- if ( ok )
- v->part()->scheduleRedirection(delay, getDocument()->completeURL( str ));
diff --git a/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild b/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild
index fda461bd5932..6e3aceab7de5 100644
--- a/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild
+++ b/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild,v 1.8 2003/03/14 21:33:14 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.5a-r1.ebuild,v 1.9 2003/03/15 15:25:27 hannes Exp $
inherit kde kde.org eutils
#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
@@ -53,11 +53,12 @@ need-qt $selected_version
set-kdedir $PV
src_unpack() {
- unpack ${P}.tar.bz2
+ unpack ${A}
cd ${S}
# fixes crash if kdelibs is compiled with debug and you
# click on "Home" button in konqueror
epatch ${FILESDIR}/${P}-dontcrash.diff
+ epatch ${FILESDIR}/${P}-libxml2-2.5.2.diff
kde_sandbox_patch ${S}/kio/misc/kpac
}
diff --git a/kde-base/kdelibs/kdelibs-3.0.5a.ebuild b/kde-base/kdelibs/kdelibs-3.0.5a.ebuild
deleted file mode 100644
index c30dd418bc01..000000000000
--- a/kde-base/kdelibs/kdelibs-3.0.5a.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdelibs/kdelibs-3.0.5a.ebuild,v 1.9 2003/03/11 21:11:46 seemant Exp $
-inherit kde kde.org eutils
-#don't inherit kde-base or kde-dist! it calls need-kde which adds kdelibs to depend!
-
-IUSE="alsa ipv6 cups ssl"
-DESCRIPTION="KDE $PV - base libraries needed by all kde programs"
-KEYWORDS="x86 ~ppc ~alpha sparc"
-HOMEPAGE="http//www.kde.org/"
-
-SLOT="3.0"
-LICENSE="GPL-2 LGPL-2"
-
-# kde.eclass has kdelibs in DEPEND, and we can't have that in here. so we recreate the entire
-# DEPEND from scratch.
-DEPEND=""
-RDEPEND=""
-newdepend "dev-lang/perl
- >=media-libs/audiofile-0.1.9
- >=sys-apps/bzip2-1.0.1
- >=dev-libs/libxslt-1.0.7
- >=dev-libs/libpcre-3.5
- >=dev-libs/libxml2-2.4.10
- ssl? ( >=dev-libs/openssl-0.9.6 )
- alsa? ( >=media-libs/alsa-lib-0.5.9 >=media-sound/alsa-driver-0.5.9 )
- cups? ( >=net-print/cups-1.1.14 )
- >=media-libs/tiff-3.5.5
- app-admin/fam-oss
- ~kde-base/arts-1.0.5a
- app-text/ghostscript"
-
-newdepend "/c"
-newdepend "/autotools"
-
-RDEPEND="$RDEPEND
- app-text/sgml-common
- cups? ( net-print/cups )
- dev-lang/python
- >=sys-apps/portage-2.0.36" # for bug #7359
-
-myconf="$myconf --with-distribution=Gentoo"
-use ipv6 || myconf="$myconf --with-ipv6-lookup=no"
-use ssl && myconf="$myconf --with-ssl-dir=/usr" || myconf="$myconf --without-ssl"
-use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
-use cups && myconf="$myconf --enable-cups" || myconf="$myconf --disable-cups"
-
-[ "$ARCH" == "x86" ] && myconf="$myconf --enable-fast-malloc=full"
-
-qtver-from-kdever ${PV}
-need-qt $selected_version
-
-set-kdedir $PV
-
-src_unpack() {
- unpack ${P}.tar.bz2
- cd ${S}
- # fixes crash if kdelibs is compiled with debug and you
- # click on "Home" button in konqueror
- epatch ${FILESDIR}/${P}-dontcrash.diff
- kde_sandbox_patch ${S}/kio/misc/kpac
-}
-
-
-src_install() {
- kde_src_install
- dohtml *.html
-
- dodir /etc/env.d
- echo "PATH=${PREFIX}/bin
-ROOTPATH=${PREFIX}/bin
-LDPATH=${PREFIX}/lib
-KDEDIRS=$PREFIX
-CONFIG_PROTECT=${PREFIX}/share/config" > ${D}/etc/env.d/65kdelibs-${PV} # number goes down with version upgrade
-
- echo "KDEDIR=$PREFIX" > ${D}/etc/env.d/50kdedir-${PV} # number goes up with version upgrade
-}