summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-07-15 02:46:54 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2010-07-15 02:46:54 +0000
commit551970f1632d0a2775720499fb2428a6dff4c353 (patch)
treec2764c90c8eb07a2c05eceffb8c4d089aaa5f420 /kde-base
parentremove seamonkey-bin from p.mask (diff)
downloadgentoo-2-551970f1632d0a2775720499fb2428a6dff4c353.tar.gz
gentoo-2-551970f1632d0a2775720499fb2428a6dff4c353.tar.bz2
gentoo-2-551970f1632d0a2775720499fb2428a6dff4c353.zip
Bumped kopete-4.4.4-r2 and kopete-4.4.5 to add fix for building wlm protocol support. Thanks to Alin Nastac <mrness@gentoo.org> - fixes bug 328229.
Added patch to allow kopete-4.4.5 to build against openssl-1 based on Samuli Suominen's patch for libmsn-4.1. (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kopete/ChangeLog14
-rw-r--r--kde-base/kopete/files/kopete-4.4.5-openssl-1.patch18
-rw-r--r--kde-base/kopete/kopete-4.4.4-r3.ebuild158
-rw-r--r--kde-base/kopete/kopete-4.4.5-r1.ebuild160
4 files changed, 349 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 9aca4bc419c3..558ce03dc883 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.259 2010/06/30 15:36:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.260 2010/07/15 02:46:53 jmbsvicetto Exp $
+
+*kopete-4.4.5-r1 (15 Jul 2010)
+*kopete-4.4.4-r3 (15 Jul 2010)
+
+ 15 Jul 2010; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
+ +kopete-4.4.4-r3.ebuild, +kopete-4.4.5-r1.ebuild,
+ +files/kopete-4.4.5-openssl-1.patch:
+ Bumped kopete-4.4.4-r2 and kopete-4.4.5 to add fix for building wlm
+ protocol support. Thanks to Alin Năstac <mrness@gentoo.org> - fixes bug
+ 328229.
+ Added patch to allow kopete-4.4.5 to build against openssl-1 based on
+ Samuli Suominen's patch for libmsn-4.1.
*kopete-4.4.5 (30 Jun 2010)
diff --git a/kde-base/kopete/files/kopete-4.4.5-openssl-1.patch b/kde-base/kopete/files/kopete-4.4.5-openssl-1.patch
new file mode 100644
index 000000000000..a4d99c91bd26
--- /dev/null
+++ b/kde-base/kopete/files/kopete-4.4.5-openssl-1.patch
@@ -0,0 +1,18 @@
+diff -urN kopete-4.4.5/kopete/protocols/jabber/googletalk/libjingle/talk/base/openssladapter.cc kopete-4.4.5-new/kopete/protocols/jabber/googletalk/libjingle/talk/base/openssladapter.cc
+--- kopete-4.4.5/kopete/protocols/jabber/googletalk/libjingle/talk/base/openssladapter.cc 2009-11-30 23:34:11.000000000 -0100
++++ kopete-4.4.5-new/kopete/protocols/jabber/googletalk/libjingle/talk/base/openssladapter.cc 2010-07-15 02:12:06.000000000 +0000
+@@ -648,7 +648,13 @@
+ int extension_nid = OBJ_obj2nid(X509_EXTENSION_get_object(extension));
+
+ if (extension_nid == NID_subject_alt_name) {
+- X509V3_EXT_METHOD* meth = X509V3_EXT_get(extension);
++
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const X509V3_EXT_METHOD* meth = X509V3_EXT_get(extension);
++ #else
++ X509V3_EXT_METHOD* meth = X509V3_EXT_get(extension);
++ #endif
++
+ if (!meth)
+ break;
+
diff --git a/kde-base/kopete/kopete-4.4.4-r3.ebuild b/kde-base/kopete/kopete-4.4.4-r3.ebuild
new file mode 100644
index 000000000000..55e2104d11c5
--- /dev/null
+++ b/kde-base/kopete/kopete-4.4.4-r3.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.4.4-r3.ebuild,v 1.1 2010/07/15 02:46:53 jmbsvicetto Exp $
+
+EAPI="3"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook ssl v4l2"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: NO DEPS
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise +jabber jingle meanwhile msn oscar qq skype
+sms testbed winpopup yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ $(add_kdebase_dep kdepimlibs)
+ media-libs/qimageblitz
+ >=x11-libs/qt-gui-4.4.0:4[mng]
+ !aqua? ( x11-libs/libXScrnSaver )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ )
+ jingle? (
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/ortp
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( >=net-libs/libmsn-4.1 )
+ otr? ( >=net-libs/libotr-3.2.0 )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+ v4l2? ( media-libs/libv4l )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+ sms? ( app-mobilephone/smssend )
+ ssl? ( app-crypt/qca-ossl )
+ winpopup? ( net-fs/samba )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+src_prepare() {
+ sed -e "s:lib/mozilla:$(get_libdir)/mozilla:" \
+ -i kopete/protocols/skype/skypebuttons/CMakeLists.txt || die "sed failed"
+ sed -e '/set (LIBV4L2_REQUIRED TRUE)/s/TRUE/FALSE/' \
+ -i kopete/CMakeLists.txt || die 'failed to make v4l2 optional'
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ mycmakeargs=(
+ $(cmake-utils_use_with jingle GOOGLETALK)
+ $(cmake-utils_use_with jingle LiboRTP)
+ $(cmake-utils_use_with jingle Mediastreamer)
+ $(cmake-utils_use_with jingle Speex)
+ $(cmake-utils_use_with v4l2 LibV4L2)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ msn) x2=wlm ;;
+ zeroconf) x2=bonjour ;;
+ *) x2='' ;;
+ esac
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/} ${x2}))
+ done
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/}))
+ done
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH='${EPREFIX}/usr/share/telepathy/managers/'"
+ #fi
+
+ if ! use ssl; then
+ if use jabber || use msn; then # || use irc; then
+ echo
+ #elog "In order to use ssl in jabber, msn and irc you'll need to"
+ elog "In order to use ssl in jabber and msn you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}
diff --git a/kde-base/kopete/kopete-4.4.5-r1.ebuild b/kde-base/kopete/kopete-4.4.5-r1.ebuild
new file mode 100644
index 000000000000..7cf7ff27879a
--- /dev/null
+++ b/kde-base/kopete/kopete-4.4.5-r1.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.4.5-r1.ebuild,v 1.1 2010/07/15 02:46:53 jmbsvicetto Exp $
+
+EAPI="3"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook ssl v4l2"
+
+# tests hang, last checked for 4.2.96
+RESTRICT=test
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS (disabled upstream)
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator
++urlpicpreview webpresence"
+
+# Available protocols
+#
+# gadu: net-libs/libgadu @since 4.3
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp DISABLED BY UPSTREAM
+# meanwhile: net-libs/meanwhile
+# msn: libmsn == this is wlm plugin, we disable msn one
+# oscar: NO DEPS
+# qq: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS (we're adding samba as RDEPEND so it works)
+# yahoo: NO DEPS
+# zeroconf (bonjour): NO DEPS
+PROTOCOLS="gadu groupwise +jabber jingle meanwhile msn oscar qq skype
+sms testbed winpopup yahoo zeroconf"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ $(add_kdebase_dep kdepimlibs)
+ media-libs/qimageblitz
+ >=x11-libs/qt-gui-4.4.0:4[mng]
+ !aqua? ( x11-libs/libXScrnSaver )
+ gadu? ( >=net-libs/libgadu-1.8.0[threads] )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ )
+ jingle? (
+ >=media-libs/mediastreamer-2.3.0
+ media-libs/speex
+ net-libs/ortp
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( >=net-libs/libmsn-4.1 )
+ otr? ( >=net-libs/libotr-3.2.0 )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+ v4l2? ( media-libs/libv4l )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+ sms? ( app-mobilephone/smssend )
+ ssl? ( app-crypt/qca-ossl )
+ winpopup? ( net-fs/samba )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ !aqua? ( x11-proto/scrnsaverproto )
+"
+
+PATCHES=( "${FILESDIR}/${P}-openssl-1.patch" )
+
+src_prepare() {
+ sed -e "s:lib/mozilla:$(get_libdir)/mozilla:" \
+ -i kopete/protocols/skype/skypebuttons/CMakeLists.txt || die "sed failed"
+ sed -e '/set (LIBV4L2_REQUIRED TRUE)/s/TRUE/FALSE/' \
+ -i kopete/CMakeLists.txt || die 'failed to make v4l2 optional'
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ local x x2
+ # Handle common stuff
+ mycmakeargs=(
+ $(cmake-utils_use_with jingle GOOGLETALK)
+ $(cmake-utils_use_with jingle LiboRTP)
+ $(cmake-utils_use_with jingle Mediastreamer)
+ $(cmake-utils_use_with jingle Speex)
+ $(cmake-utils_use_with v4l2 LibV4L2)
+ )
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ case ${x/+/} in
+ msn) x2=wlm ;;
+ zeroconf) x2=bonjour ;;
+ *) x2='' ;;
+ esac
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/} ${x2}))
+ done
+
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs+=($(cmake-utils_use_with ${x/+/}))
+ done
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH='${EPREFIX}/usr/share/telepathy/managers/'"
+ #fi
+
+ if ! use ssl; then
+ if use jabber || use msn; then # || use irc; then
+ echo
+ #elog "In order to use ssl in jabber, msn and irc you'll need to"
+ elog "In order to use ssl in jabber and msn you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}