summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:17:25 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-02-09 00:17:25 +0000
commitcc93f2726923bdee661cb629b7e9878a5b2ea153 (patch)
tree7aec63e4efaeabdc74b270f082ddd4109eeaad5c /kde-base
parent[kde-base/granatier] Version bump to KDE SC 4.4.0 (diff)
downloadgentoo-2-cc93f2726923bdee661cb629b7e9878a5b2ea153.tar.gz
gentoo-2-cc93f2726923bdee661cb629b7e9878a5b2ea153.tar.bz2
gentoo-2-cc93f2726923bdee661cb629b7e9878a5b2ea153.zip
[kde-base/kdepim-wizards] Version bump to KDE SC 4.4.0
(Portage version: 2.2_rc62/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdepim-wizards/ChangeLog8
-rw-r--r--kde-base/kdepim-wizards/files/fix-broken-gpgme-cmake-guard.diff21
-rw-r--r--kde-base/kdepim-wizards/kdepim-wizards-4.4.0.ebuild40
3 files changed, 68 insertions, 1 deletions
diff --git a/kde-base/kdepim-wizards/ChangeLog b/kde-base/kdepim-wizards/ChangeLog
index eef50c484992..a26bd447f54e 100644
--- a/kde-base/kdepim-wizards/ChangeLog
+++ b/kde-base/kdepim-wizards/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-wizards
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-wizards/ChangeLog,v 1.134 2010/01/25 15:30:32 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-wizards/ChangeLog,v 1.135 2010/02/09 00:17:22 alexxy Exp $
+
+*kdepim-wizards-4.4.0 (08 Feb 2010)
+
+ 08 Feb 2010; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdepim-wizards-4.4.0.ebuild, +files/fix-broken-gpgme-cmake-guard.diff:
+ Version bump to KDE SC 4.4.0
*kdepim-wizards-4.3.5 (25 Jan 2010)
diff --git a/kde-base/kdepim-wizards/files/fix-broken-gpgme-cmake-guard.diff b/kde-base/kdepim-wizards/files/fix-broken-gpgme-cmake-guard.diff
new file mode 100644
index 000000000000..084113a5b2d7
--- /dev/null
+++ b/kde-base/kdepim-wizards/files/fix-broken-gpgme-cmake-guard.diff
@@ -0,0 +1,21 @@
+Index: CMakeLists.txt
+===================================================================
+--- CMakeLists.txt (revision 1073383)
++++ CMakeLists.txt (working copy)
+@@ -185,7 +185,6 @@
+ add_subdirectory(messagecore)
+ add_subdirectory(messagelist)
+
+- if(QGPGME_FOUND)
+ if (Boost_TOPOLOGICAL_SORT_DIR)
+ macro_optional_add_subdirectory(kleopatra)
+ endif(Boost_TOPOLOGICAL_SORT_DIR)
+@@ -211,7 +210,6 @@
+ include( SopranoAddOntology )
+ add_subdirectory( ontologies )
+ add_subdirectory( nepomuk_email_feeder )
+- endif(QGPGME_FOUND)
+
+ if(KDEPIM_BUILD_EVERYTHING)
+ macro_optional_add_subdirectory(knode)
+ \ No newline at end of file
diff --git a/kde-base/kdepim-wizards/kdepim-wizards-4.4.0.ebuild b/kde-base/kdepim-wizards/kdepim-wizards-4.4.0.ebuild
new file mode 100644
index 000000000000..af9fffd95813
--- /dev/null
+++ b/kde-base/kdepim-wizards/kdepim-wizards-4.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-wizards/kdepim-wizards-4.4.0.ebuild,v 1.1 2010/02/09 00:17:22 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+KMMODULE="wizards"
+inherit kde4-meta
+
+DESCRIPTION="KDE PIM wizards"
+IUSE="debug"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-kresources)
+ $(add_kdebase_dep libkdepim)
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ kmail/
+ knotes/
+ kresources/groupwise/
+ kresources/kolab/
+ kresources/slox/
+"
+
+src_prepare() {
+ ln -s "${EKDEDIR}"/include/kdepim-kresources/{kabcsloxprefs.h,kcalsloxprefs.h} \
+ kresources/slox/ \
+ || die "Failed to link extra_headers."
+ ln -s "${EKDEDIR}"/include/kdepim-kresources/{kabc_groupwiseprefs,kcal_groupwiseprefsbase}.h \
+ kresources/groupwise/ \
+ || die "Failed to link extra_headers."
+ epatch "${FILESDIR}/fix-broken-gpgme-cmake-guard.diff"
+
+ kde4-meta_src_prepare
+}