summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-03 13:06:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-03 13:06:48 +0000
commitded52ef1e523c24a46f860145107561c4fc3c4d2 (patch)
treec79f8ebd31e219e2f84bee19f338ee897722d4d9 /kde-base
parentDEPEND on bison instead of yacc #59191 (Manifest recommit) (diff)
downloadgentoo-2-ded52ef1e523c24a46f860145107561c4fc3c4d2.tar.gz
gentoo-2-ded52ef1e523c24a46f860145107561c4fc3c4d2.tar.bz2
gentoo-2-ded52ef1e523c24a46f860145107561c4fc3c4d2.zip
goodbye $COMPILER
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/arts/arts-1.1.5.ebuild46
-rw-r--r--kde-base/arts/arts-1.2.0.ebuild8
-rw-r--r--kde-base/arts/arts-1.2.1.ebuild8
-rw-r--r--kde-base/arts/arts-1.2.2.ebuild8
-rw-r--r--kde-base/arts/arts-1.2.3.ebuild8
-rw-r--r--kde-base/arts/arts-1.3.0_beta1.ebuild3
-rw-r--r--kde-base/arts/arts-1.3.0_beta2.ebuild3
7 files changed, 30 insertions, 54 deletions
diff --git a/kde-base/arts/arts-1.1.5.ebuild b/kde-base/arts/arts-1.1.5.ebuild
index 21f159886ce9..99851f738eca 100644
--- a/kde-base/arts/arts-1.1.5.ebuild
+++ b/kde-base/arts/arts-1.1.5.ebuild
@@ -1,17 +1,18 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.5.ebuild,v 1.7 2004/06/24 22:11:32 agriffis Exp $
-inherit kde flag-o-matic
-
-IUSE="alsa oggvorbis artswrappersuid mad"
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.1.5.ebuild,v 1.8 2004/08/03 13:06:48 vapier Exp $
+inherit kde flag-o-matic gcc
set-kdedir 3.1
-SRC_URI="mirror://kde/stable/3.1.5/src/${P}.tar.bz2"
-HOMEPAGE="http://multimedia.kde.org"
DESCRIPTION="aRts, the KDE sound (and all-around multimedia) server/output manager"
+HOMEPAGE="http://multimedia.kde.org"
+SRC_URI="mirror://kde/stable/3.1.5/src/${P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.1"
KEYWORDS="x86 ~ppc sparc alpha hppa amd64 ia64"
+IUSE="alsa oggvorbis artswrappersuid mad"
DEPEND="alsa? ( media-libs/alsa-lib )
oggvorbis? ( media-libs/libvorbis media-libs/libogg )
@@ -20,22 +21,6 @@ DEPEND="alsa? ( media-libs/alsa-lib )
>=dev-libs/glib-2
>=x11-libs/qt-3.1.0"
-if [ "${COMPILER}" == "gcc3" ]; then
- # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
- # these.. Even starting a compile shuts down the arts server
- filter-flags "-fomit-frame-pointer -fstrength-reduce"
-fi
-
-#fix bug 13453
-filter-flags "-foptimize-sibling-calls"
-
-SLOT="3.1"
-LICENSE="GPL-2 LGPL-2"
-
-use alsa && myconf="$myconf --with-alsa" || myconf="$myconf --without-alsa"
-use oggvorbis || myconf="$myconf --disable-vorbis"
-use mad || myconf="$myconf --disable-libmad"
-
# patch to configure.in.in that makes the vorbis, libmad deps optional
# has no version number in its filename because it's the same for all
# arts versions - the patched file hasn't changed in a year's time
@@ -50,6 +35,23 @@ src_unpack() {
cd ${S}
}
+src_compile() {
+ if [ "`gcc-major-version`" == "3" ] ; then
+ # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
+ # these.. Even starting a compile shuts down the arts server
+ filter-flags -fomit-frame-pointer -fstrength-reduce
+ fi
+
+ #fix bug 13453
+ filter-flags "-foptimize-sibling-calls"
+
+ myconf="$myconf `use_with alsa`"
+ use oggvorbis || myconf="$myconf --disable-vorbis"
+ use mad || myconf="$myconf --disable-libmad"
+
+ kde_src_compile
+}
+
src_install() {
kde_src_install
dodoc ${S}/doc/{NEWS,README,TODO}
diff --git a/kde-base/arts/arts-1.2.0.ebuild b/kde-base/arts/arts-1.2.0.ebuild
index b2c00f678fc8..c93feb5a638c 100644
--- a/kde-base/arts/arts-1.2.0.ebuild
+++ b/kde-base/arts/arts-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.0.ebuild,v 1.15 2004/06/24 22:11:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.0.ebuild,v 1.16 2004/08/03 13:06:48 vapier Exp $
inherit kde flag-o-matic
set-kdedir 3.2
@@ -36,12 +36,6 @@ src_unpack() {
}
src_compile() {
-# if [ "${COMPILER}" == "gcc3" ]; then
-# # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
-# # these.. Even starting a compile shuts down the arts server
-# filter-flags -fomit-frame-pointer -fstrength-reduce
-# fi
-
#fix bug 13453
filter-flags -foptimize-sibling-calls
diff --git a/kde-base/arts/arts-1.2.1.ebuild b/kde-base/arts/arts-1.2.1.ebuild
index dd21b01b0cdb..23f66bad7745 100644
--- a/kde-base/arts/arts-1.2.1.ebuild
+++ b/kde-base/arts/arts-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.1.ebuild,v 1.13 2004/06/24 22:11:32 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.1.ebuild,v 1.14 2004/08/03 13:06:48 vapier Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.2
@@ -41,12 +41,6 @@ src_unpack() {
}
src_compile() {
-# if [ "${COMPILER}" == "gcc3" ]; then
-# # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
-# # these.. Even starting a compile shuts down the arts server
-# filter-flags -fomit-frame-pointer -fstrength-reduce
-# fi
-
#fix bug 13453
filter-flags -foptimize-sibling-calls
diff --git a/kde-base/arts/arts-1.2.2.ebuild b/kde-base/arts/arts-1.2.2.ebuild
index 248d64cb3184..12edb7548371 100644
--- a/kde-base/arts/arts-1.2.2.ebuild
+++ b/kde-base/arts/arts-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.2.ebuild,v 1.13 2004/07/07 00:36:26 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.2.ebuild,v 1.14 2004/08/03 13:06:48 vapier Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.2
@@ -41,12 +41,6 @@ src_unpack() {
}
src_compile() {
-# if [ "${COMPILER}" == "gcc3" ]; then
-# # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
-# # these.. Even starting a compile shuts down the arts server
-# filter-flags -fomit-frame-pointer -fstrength-reduce
-# fi
-
#fix bug 13453
filter-flags -foptimize-sibling-calls
diff --git a/kde-base/arts/arts-1.2.3.ebuild b/kde-base/arts/arts-1.2.3.ebuild
index 153980edffea..d09ad03b1ccd 100644
--- a/kde-base/arts/arts-1.2.3.ebuild
+++ b/kde-base/arts/arts-1.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.3.ebuild,v 1.8 2004/07/29 03:28:36 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.2.3.ebuild,v 1.9 2004/08/03 13:06:48 vapier Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.2
@@ -41,12 +41,6 @@ src_unpack() {
}
src_compile() {
-# if [ "${COMPILER}" == "gcc3" ]; then
-# # GCC 3.1 kinda makes arts buggy and prone to crashes when compiled with
-# # these.. Even starting a compile shuts down the arts server
-# filter-flags -fomit-frame-pointer -fstrength-reduce
-# fi
-
#fix bug 13453
filter-flags -foptimize-sibling-calls
diff --git a/kde-base/arts/arts-1.3.0_beta1.ebuild b/kde-base/arts/arts-1.3.0_beta1.ebuild
index e83f0807e2ea..15d847a185d9 100644
--- a/kde-base/arts/arts-1.3.0_beta1.ebuild
+++ b/kde-base/arts/arts-1.3.0_beta1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.0_beta1.ebuild,v 1.1 2004/07/08 22:22:05 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.0_beta1.ebuild,v 1.2 2004/08/03 13:06:48 vapier Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.3
@@ -44,7 +44,6 @@ src_unpack() {
}
src_compile() {
-
#fix bug 13453
filter-flags -foptimize-sibling-calls
diff --git a/kde-base/arts/arts-1.3.0_beta2.ebuild b/kde-base/arts/arts-1.3.0_beta2.ebuild
index bf58d353bc6c..f39056d341fe 100644
--- a/kde-base/arts/arts-1.3.0_beta2.ebuild
+++ b/kde-base/arts/arts-1.3.0_beta2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.0_beta2.ebuild,v 1.1 2004/07/23 11:55:36 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/arts/arts-1.3.0_beta2.ebuild,v 1.2 2004/08/03 13:06:48 vapier Exp $
inherit kde flag-o-matic eutils
set-kdedir 3.3
@@ -44,7 +44,6 @@ src_unpack() {
}
src_compile() {
-
#fix bug 13453
filter-flags -foptimize-sibling-calls