summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-17 21:55:01 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-17 21:55:01 +0000
commitee27fd816c515a5f985c0367d2a0fff7abb03f9f (patch)
tree9d2aff1e834136fb74117e8265b31310fb3d4e90 /kde-base
parentVersion bump (diff)
downloadgentoo-2-ee27fd816c515a5f985c0367d2a0fff7abb03f9f.tar.gz
gentoo-2-ee27fd816c515a5f985c0367d2a0fff7abb03f9f.tar.bz2
gentoo-2-ee27fd816c515a5f985c0367d2a0fff7abb03f9f.zip
Build additional dir with Outlook/Exchange appointment code, bug 372039
(Portage version: 2.1.10.1/cvs/Linux x86_64)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmail/ChangeLog8
-rw-r--r--kde-base/kmail/kmail-4.6.0-r1.ebuild83
2 files changed, 90 insertions, 1 deletions
diff --git a/kde-base/kmail/ChangeLog b/kde-base/kmail/ChangeLog
index fc9235327019..085848e421cb 100644
--- a/kde-base/kmail/ChangeLog
+++ b/kde-base/kmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kmail
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.252 2011/06/09 22:52:46 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/ChangeLog,v 1.253 2011/06/17 21:55:01 dilfridge Exp $
+
+*kmail-4.6.0-r1 (17 Jun 2011)
+
+ 17 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kmail-4.6.0-r1.ebuild:
+ Build additional dir with Outlook/Exchange appointment code, bug 372039
09 Jun 2011; Theo Chatzimichos <tampakrap@gentoo.org> -kmail-4.5.95.ebuild:
Remove KDEPIM 4.5.95
diff --git a/kde-base/kmail/kmail-4.6.0-r1.ebuild b/kde-base/kmail/kmail-4.6.0-r1.ebuild
new file mode 100644
index 000000000000..278e73f195e5
--- /dev/null
+++ b/kde-base/kmail/kmail-4.6.0-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmail/kmail-4.6.0-r1.ebuild,v 1.1 2011/06/17 21:55:01 dilfridge Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+KDE_SCM="git"
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KMail is the email component of Kontact, the integrated personal information manager of KDE."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep korganizer)
+ $(add_kdebase_dep kdepim-common-libs)
+"
+RDEPEND="${DEPEND}"
+
+add_blocker kmailcvt
+add_blocker libksieve
+add_blocker mimelib
+
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ korganizer/
+ kresources/
+ libkleo/
+ libkpgp/
+ libkdepimdbusinterfaces/
+ kdgantt2/
+"
+KMCOMPILEONLY="
+ messagecomposer/
+ messagecore/
+ messagelist/
+ messageviewer/
+ templateparser/
+ incidenceeditor-ng/
+ calendarsupport/
+"
+KMEXTRA="
+ kmailcvt/
+ ksendemail/
+ libksieve/
+ mailcommon/
+ ontologies/
+ plugins/messageviewer/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+src_configure() {
+ # Bug 308903
+ use ppc64 && append-flags -mminimal-toc
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ kde4-meta_src_compile kmail_xml
+ kde4-meta_src_compile
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+ if ! has_version kde-base/kleopatra:${SLOT}; then
+ echo
+ elog "For certificate management and the gnupg log viewer, please install kde-base/kleopatra:${SLOT}"
+ echo
+ fi
+}