summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-15 11:32:02 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-02-15 11:32:02 +0000
commitef207d6c670882249a7c312893f796a2751783dd (patch)
tree76c2769af4bf7037be07bcfb80df5c6b3ea19fa6 /kde-base
parentFix wrong xinerama useflag (should have been xext). Bug #122886. (diff)
downloadgentoo-2-ef207d6c670882249a7c312893f796a2751783dd.tar.gz
gentoo-2-ef207d6c670882249a7c312893f796a2751783dd.tar.bz2
gentoo-2-ef207d6c670882249a7c312893f796a2751783dd.zip
Add ssl to IUSE and fix src_compile so that the flag is really honoured. Also make a bit more clear the comment about kfile-cert. Closes bug #122895.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdeaddons-kfile-plugins/ChangeLog9
-rw-r--r--kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild13
2 files changed, 16 insertions, 6 deletions
diff --git a/kde-base/kdeaddons-kfile-plugins/ChangeLog b/kde-base/kdeaddons-kfile-plugins/ChangeLog
index 4a530fa0e4c5..2544ad923c40 100644
--- a/kde-base/kdeaddons-kfile-plugins/ChangeLog
+++ b/kde-base/kdeaddons-kfile-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeaddons-kfile-plugins
-# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons-kfile-plugins/ChangeLog,v 1.24 2006/01/22 22:52:54 danarmak Exp $
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons-kfile-plugins/ChangeLog,v 1.25 2006/02/15 11:32:02 flameeyes Exp $
+
+ 15 Feb 2006; Diego Pettenò <flameeyes@gentoo.org>
+ kdeaddons-kfile-plugins-3.5.0.ebuild:
+ Add ssl to IUSE and fix src_compile so that the flag is really honoured.
+ Also make a bit more clear the comment about kfile-cert. Closes bug #122895.
*kdeaddons-kfile-plugins-3.5.1 (23 Jan 2006)
diff --git a/kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild b/kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild
index 6a59674dc591..1b6977f08a77 100644
--- a/kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild
+++ b/kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild,v 1.6 2006/01/22 22:52:54 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaddons-kfile-plugins/kdeaddons-kfile-plugins-3.5.0.ebuild,v 1.7 2006/02/15 11:32:02 flameeyes Exp $
KMNAME=kdeaddons
KMNOMODULE=true
KMEXTRA="kfile-plugins/"
@@ -10,8 +10,13 @@ inherit kde-meta
DESCRIPTION="kdeaddons kfile plugins"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="ssl"
DEPEND="ssl? ( dev-libs/openssl )"
-# kfile-cert requires ssl
+# ssl is needed by kfile-cert, not an hard-dep
+
+src_compile() {
+ myconf="$(use_with ssl)"
+ kde_src_compile
+}