summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-07-30 09:54:46 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-07-30 09:54:46 +0000
commitfc5789f18ed815f3616e627d07225f207dc5a6c3 (patch)
tree3372b861a3036be299f1cad91307e7533348f116 /kde-base
parentversion bump. +3.242 x86 stable (diff)
downloadgentoo-2-fc5789f18ed815f3616e627d07225f207dc5a6c3.tar.gz
gentoo-2-fc5789f18ed815f3616e627d07225f207dc5a6c3.tar.bz2
gentoo-2-fc5789f18ed815f3616e627d07225f207dc5a6c3.zip
Add configure patch for pbbuttonsd detection (#94731).
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kmilo/ChangeLog6
-rw-r--r--kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch31
-rw-r--r--kde-base/kmilo/kmilo-3.4.2.ebuild6
3 files changed, 40 insertions, 3 deletions
diff --git a/kde-base/kmilo/ChangeLog b/kde-base/kmilo/ChangeLog
index 27101b608e64..93afbbabfdc2 100644
--- a/kde-base/kmilo/ChangeLog
+++ b/kde-base/kmilo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for kde-base/kmilo
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/ChangeLog,v 1.13 2005/07/28 21:16:19 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/ChangeLog,v 1.14 2005/07/30 09:54:46 greg_g Exp $
+
+ 30 Jul 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +files/configure-fix-kdeutils-powerbook.patch, kmilo-3.4.2.ebuild:
+ Add configure patch for pbbuttonsd detection (#94731).
*kmilo-3.4.2 (28 Jul 2005)
diff --git a/kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch b/kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch
new file mode 100644
index 000000000000..a54c727876ea
--- /dev/null
+++ b/kde-base/kmilo/files/configure-fix-kdeutils-powerbook.patch
@@ -0,0 +1,31 @@
+Index: kmilo/configure.in.in
+===================================================================
+--- kmilo/configure.in.in (revision 433553)
++++ kmilo/configure.in.in (working copy)
+@@ -9,6 +9,15 @@
+ dnl ---------------------------------------------------------------------
+ dnl PowerBook IPC Library
+
++AC_ARG_WITH(powerbook,
++ [AS_HELP_STRING(--with-powerbook,
++ [enable support for PPC PowerBook @<:@default=check@:>@])],
++ [], with_powerbook=check)
++
++have_pbbipc=""
++have_pbb=""
++if test "x$with_powerbook" != xno; then
++
+ KDE_CHECK_LIB(pbbipc, create_msgport,
+ [
+ KEYBOARD_LIBS="-lpbbipc $KEYBOARD_LIBS"
+@@ -23,6 +32,10 @@
+ have_pbb=true
+ ])
+
++if test "x$with_powerbook" != xcheck && test -z "$have_pbbipc$have_pbb"; then
++ AC_MSG_FAILURE([--with-powerbook was given, but test for libpbb failed])
++fi
++fi
+
+ AM_CONDITIONAL(include_kmilo_powerbook, test x$have_pbbipc = xtrue)
+ AM_CONDITIONAL(include_kmilo_pbb, test x$have_pbb = xtrue)
diff --git a/kde-base/kmilo/kmilo-3.4.2.ebuild b/kde-base/kmilo/kmilo-3.4.2.ebuild
index 0db03d7b59b8..7d31cfe465b4 100644
--- a/kde-base/kmilo/kmilo-3.4.2.ebuild
+++ b/kde-base/kmilo/kmilo-3.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/kmilo-3.4.2.ebuild,v 1.1 2005/07/28 21:16:19 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kmilo/kmilo-3.4.2.ebuild,v 1.2 2005/07/30 09:54:46 greg_g Exp $
KMNAME=kdeutils
MAXKDEVER=$PV
@@ -10,4 +10,6 @@ inherit kde-meta eutils
DESCRIPTION="kmilo - a kded module that can be extended to support various types of hardware
input devices that exist, such as those on keyboards."
KEYWORDS=" ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="" \ No newline at end of file
+IUSE=""
+
+PATCHES="$FILESDIR/configure-fix-kdeutils-powerbook.patch"