summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-04-11 17:09:51 +0000
committerMichael Palimaka <kensington@gentoo.org>2015-04-11 17:09:51 +0000
commit9df6c8a497c96584acdc81d881eda9e1d566f72e (patch)
tree91844a0c0f8fcd9a071e6624108f6637cc34ec2d /kde-frameworks/kdesu
parentAdd ruby22. (diff)
downloadgentoo-2-9df6c8a497c96584acdc81d881eda9e1d566f72e.tar.gz
gentoo-2-9df6c8a497c96584acdc81d881eda9e1d566f72e.tar.bz2
gentoo-2-9df6c8a497c96584acdc81d881eda9e1d566f72e.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'kde-frameworks/kdesu')
-rw-r--r--kde-frameworks/kdesu/ChangeLog7
-rw-r--r--kde-frameworks/kdesu/kdesu-5.9.0.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-frameworks/kdesu/ChangeLog b/kde-frameworks/kdesu/ChangeLog
index 78fa5db61fe2..b749091ec354 100644
--- a/kde-frameworks/kdesu/ChangeLog
+++ b/kde-frameworks/kdesu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-frameworks/kdesu
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kdesu/ChangeLog,v 1.10 2015/04/03 21:32:45 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kdesu/ChangeLog,v 1.11 2015/04/11 17:09:49 kensington Exp $
+
+*kdesu-5.9.0 (11 Apr 2015)
+
+ 11 Apr 2015; Michael Palimaka <kensington@gentoo.org> +kdesu-5.9.0.ebuild:
+ Version bump.
03 Apr 2015; Johannes Huber <johu@gentoo.org> -kdesu-5.7.0.ebuild:
Remove KDE Frameworks 5.7.0
diff --git a/kde-frameworks/kdesu/kdesu-5.9.0.ebuild b/kde-frameworks/kdesu/kdesu-5.9.0.ebuild
new file mode 100644
index 000000000000..a41949403c1f
--- /dev/null
+++ b/kde-frameworks/kdesu/kdesu-5.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-frameworks/kdesu/kdesu-5.9.0.ebuild,v 1.1 2015/04/11 17:09:49 kensington Exp $
+
+EAPI=5
+
+KDE_TEST="false"
+inherit kde5
+
+DESCRIPTION="Framework to handle super user actions"
+LICENSE="LGPL-2"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep kservice)
+ X? ( x11-libs/libX11 )
+"
+DEPEND="${RDEPEND}
+ X? ( x11-proto/xproto )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}