summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-09-21 18:28:36 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-09-21 18:28:36 +0000
commit5599fa272e8c741af680728ee3edc0d215791e61 (patch)
treefc04a150d18e3e53ad78850a2c530ce1a4f11377 /kde-misc
parentChange references from /boot/grub2 to /boot/grub. (diff)
downloadgentoo-2-5599fa272e8c741af680728ee3edc0d215791e61.tar.gz
gentoo-2-5599fa272e8c741af680728ee3edc0d215791e61.tar.bz2
gentoo-2-5599fa272e8c741af680728ee3edc0d215791e61.zip
Version bump
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key C2BA7F3C!)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kanyremote/ChangeLog7
-rw-r--r--kde-misc/kanyremote/kanyremote-6.3.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 701e08d33e82..5fb6a0c17592 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.38 2013/09/11 15:46:19 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.39 2013/09/21 18:28:36 hwoarang Exp $
+
+*kanyremote-6.3.1 (21 Sep 2013)
+
+ 21 Sep 2013; Markos Chandras <hwoarang@gentoo.org> +kanyremote-6.3.1.ebuild:
+ Version bump
11 Sep 2013; Michael Palimaka <kensington@gentoo.org> kanyremote-6.2.ebuild:
Fix failing patch wrt bug #484092. Tidy ebuild.
diff --git a/kde-misc/kanyremote/kanyremote-6.3.1.ebuild b/kde-misc/kanyremote/kanyremote-6.3.1.ebuild
new file mode 100644
index 000000000000..ea734801b90f
--- /dev/null
+++ b/kde-misc/kanyremote/kanyremote-6.3.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.3.1.ebuild,v 1.1 2013/09/21 18:28:36 hwoarang Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+inherit autotools python-r1 base
+
+DESCRIPTION="KDE frontend to Anyremote"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/anyremote/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-mobilephone/anyremote-6.0[bluetooth?]
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ kde-base/pykde4:4[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ # using gettextize no-interactive example from dev-util/bless package
+ cp $(type -p gettextize) "${T}"/
+ sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
+ "${T}"/gettextize -f --no-changelog > /dev/null
+
+ # remove deprecated entry
+ sed -e "/Encoding=UTF-8/d" \
+ -i kanyremote.desktop || die "fixing .desktop file failed"
+
+ # fix documentation directory wrt bug #316087
+ sed -i "s/doc\/${PN}/doc\/${PF}/g" Makefile.am
+ eautoreconf
+
+ # disable bluetooth check to avoid errors
+ if ! use bluetooth ; then
+ sed -e "s/usepybluez = True/usepybluez = False/" -i kanyremote || die
+ fi
+}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}