summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-06-04 10:01:56 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-06-04 10:01:56 +0000
commit6110161e5a8c4a1d10ec3595ea7b84c575f11f52 (patch)
tree6ff41345e874bc2755fe570142c01d599f5d7a43 /kde-misc
parentStable for amd64, wrt bug #419205 (diff)
downloadgentoo-2-6110161e5a8c4a1d10ec3595ea7b84c575f11f52.tar.gz
gentoo-2-6110161e5a8c4a1d10ec3595ea7b84c575f11f52.tar.bz2
gentoo-2-6110161e5a8c4a1d10ec3595ea7b84c575f11f52.zip
Bump to EAPI=4, add missing dependencies, and respect LINGUAS. Fix build with GCC-4.7 thanks to Nikos Chantziaras <realnc@gmail.com> in bug #419565.
(Portage version: 2.1.10.64/cvs/Linux x86_64)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kdocker/ChangeLog11
-rw-r--r--kde-misc/kdocker/files/kdocker-4.6-gcc-4.7.patch10
-rw-r--r--kde-misc/kdocker/kdocker-4.6-r2.ebuild40
3 files changed, 59 insertions, 2 deletions
diff --git a/kde-misc/kdocker/ChangeLog b/kde-misc/kdocker/ChangeLog
index b6f8ed3ecea4..255b1be2ba5d 100644
--- a/kde-misc/kdocker/ChangeLog
+++ b/kde-misc/kdocker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-misc/kdocker
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kdocker/ChangeLog,v 1.10 2011/08/27 21:58:24 dilfridge Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kdocker/ChangeLog,v 1.11 2012/06/04 10:01:56 kensington Exp $
+
+*kdocker-4.6-r2 (04 Jun 2012)
+
+ 04 Jun 2012; Michael Palimaka <kensington@gentoo.org>
+ +files/kdocker-4.6-gcc-4.7.patch, +kdocker-4.6-r2.ebuild:
+ Bump to EAPI=4, add missing dependencies, and respect LINGUAS. Fix build with
+ GCC-4.7 thanks to Nikos Chantziaras <realnc@gmail.com> in bug #419565.
27 Aug 2011; Andreas K. Huettel <dilfridge@gentoo.org> -kdocker-4.5.ebuild,
-kdocker-4.6.ebuild, kdocker-4.6-r1.ebuild:
diff --git a/kde-misc/kdocker/files/kdocker-4.6-gcc-4.7.patch b/kde-misc/kdocker/files/kdocker-4.6-gcc-4.7.patch
new file mode 100644
index 000000000000..50253e359e51
--- /dev/null
+++ b/kde-misc/kdocker/files/kdocker-4.6-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- solutions/qtsingleapplication/qtlocalpeer.cpp
++++ solutions/qtsingleapplication/qtlocalpeer.cpp
+@@ -48,6 +48,7 @@
+ #include "qtlocalpeer.h"
+ #include <QtCore/QCoreApplication>
+ #include <QtCore/QTime>
++#include <unistd.h>
+
+ #if defined(Q_OS_WIN)
+ #include <QtCore/QLibrary>
diff --git a/kde-misc/kdocker/kdocker-4.6-r2.ebuild b/kde-misc/kdocker/kdocker-4.6-r2.ebuild
new file mode 100644
index 000000000000..c6b3ad8d8f65
--- /dev/null
+++ b/kde-misc/kdocker/kdocker-4.6-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kdocker/kdocker-4.6-r2.ebuild,v 1.1 2012/06/04 10:01:55 kensington Exp $
+
+EAPI=4
+LANGS="it"
+inherit qt4-r2
+
+DESCRIPTION="Helper to dock any application into the system tray"
+HOMEPAGE="https://launchpad.net/kdocker/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV:0:3}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/qt-core
+ x11-libs/qt-gui
+"
+RDEPEND="${DEPEND}"
+
+DOCS="AUTHORS BUGS ChangeLog CREDITS README TODO"
+
+PATCHES=(
+ "${FILESDIR}/${P}-icon.patch"
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ if ! use linguas_it ; then
+ sed -e '/^INSTALLS +=/s/translations//' -i kdocker.pro || die "sed failed"
+ fi
+}