summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-09-11 15:21:14 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-09-11 15:21:14 +0000
commit90908c956b6df84b2b0d1ccd55ed1353f07cbf32 (patch)
treeb6d02f31bab956d515af7c57287d0775aae42f3b /kde-misc
parentPatch to address a regression on preview mode on 0.8.8b - http://forums.cacti... (diff)
downloadgentoo-2-90908c956b6df84b2b0d1ccd55ed1353f07cbf32.tar.gz
gentoo-2-90908c956b6df84b2b0d1ccd55ed1353f07cbf32.tar.bz2
gentoo-2-90908c956b6df84b2b0d1ccd55ed1353f07cbf32.zip
Improve python support - enforce USE dependencies, allow the package to work with all supported python implementations, and do not fail when an unsupported implementation is selected.
(Portage version: 2.2.2/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kanyremote/ChangeLog7
-rw-r--r--kde-misc/kanyremote/kanyremote-6.2.ebuild20
2 files changed, 19 insertions, 8 deletions
diff --git a/kde-misc/kanyremote/ChangeLog b/kde-misc/kanyremote/ChangeLog
index 87b014cf6385..f822cc741b24 100644
--- a/kde-misc/kanyremote/ChangeLog
+++ b/kde-misc/kanyremote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-misc/kanyremote
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.36 2013/09/05 18:45:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/ChangeLog,v 1.37 2013/09/11 15:21:14 kensington Exp $
+
+ 11 Sep 2013; Michael Palimaka <kensington@gentoo.org> kanyremote-6.2.ebuild:
+ Improve python support - enforce USE dependencies, allow the package to work
+ with all supported python implementations, and do not fail when an unsupported
+ implementation is selected.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> kanyremote-6.2.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/kde-misc/kanyremote/kanyremote-6.2.ebuild b/kde-misc/kanyremote/kanyremote-6.2.ebuild
index ae4087f6547e..5211c7b08e5b 100644
--- a/kde-misc/kanyremote/kanyremote-6.2.ebuild
+++ b/kde-misc/kanyremote/kanyremote-6.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.2.ebuild,v 1.2 2013/09/05 18:45:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-misc/kanyremote/kanyremote-6.2.ebuild,v 1.3 2013/09/11 15:21:14 kensington Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
-inherit autotools python-single-r1 base
+inherit autotools python-r1 base
DESCRIPTION="KDE frontend to Anyremote"
HOMEPAGE="http://anyremote.sourceforge.net/"
@@ -16,18 +16,18 @@ SLOT="4"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
RDEPEND="${PYTHON_DEPS}
>=app-mobilephone/anyremote-6.0[bluetooth?]
- dev-python/PyQt4[X]
- kde-base/pykde4
- bluetooth? ( dev-python/pybluez )
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+ kde-base/pykde4:4[${PYTHON_USEDEP}]
+ bluetooth? ( dev-python/pybluez[${PYTHON_USEDEP}] )
"
DEPEND="${RDEPEND}
sys-devel/gettext
"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
src_prepare() {
# using gettextize no-interactive example from dev-util/bless package
cp $(type -p gettextize) "${T}"/
@@ -41,3 +41,9 @@ src_prepare() {
# workaround to bluetooth check when bluetooth use flag is disabled
! use bluetooth && epatch "${FILESDIR}/disable_bluetooth.patch"
}
+
+src_install() {
+ default
+
+ python_replicate_script "${D}"/usr/bin/kanyremote
+}