summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-01-24 19:08:19 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-01-24 19:08:19 +0000
commite860281c9d025c1ce3110fcddc0c09df7d15bb69 (patch)
tree98fe52e1780bf9c9987d30dedebae996b20b3904 /lxde-base/lxdm
parentDrop xcb USE dep on phonon. Bug 352611 (diff)
downloadgentoo-2-e860281c9d025c1ce3110fcddc0c09df7d15bb69.tar.gz
gentoo-2-e860281c9d025c1ce3110fcddc0c09df7d15bb69.tar.bz2
gentoo-2-e860281c9d025c1ce3110fcddc0c09df7d15bb69.zip
new ebuild, close bug #346833
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base/lxdm')
-rw-r--r--lxde-base/lxdm/ChangeLog11
-rw-r--r--lxde-base/lxdm/files/lxdm-0.3.0-consolekit-disable.patch14
-rw-r--r--lxde-base/lxdm/files/lxdm-0.3.0-pam_console-disable.patch8
-rw-r--r--lxde-base/lxdm/lxdm-0.3.0.ebuild56
-rw-r--r--lxde-base/lxdm/metadata.xml8
5 files changed, 97 insertions, 0 deletions
diff --git a/lxde-base/lxdm/ChangeLog b/lxde-base/lxdm/ChangeLog
new file mode 100644
index 000000000000..ffb551169d5b
--- /dev/null
+++ b/lxde-base/lxdm/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for lxde-base/lxdm
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.1 2011/01/24 19:08:19 lxnay Exp $
+
+*lxdm-0.3.0 (24 Jan 2011)
+
+ 24 Jan 2011; Fabio Erculiani <lxnay@gentoo.org> +lxdm-0.3.0.ebuild,
+ +files/lxdm-0.3.0-consolekit-disable.patch,
+ +files/lxdm-0.3.0-pam_console-disable.patch, +metadata.xml:
+ new ebuild, close bug #346833
+
diff --git a/lxde-base/lxdm/files/lxdm-0.3.0-consolekit-disable.patch b/lxde-base/lxdm/files/lxdm-0.3.0-consolekit-disable.patch
new file mode 100644
index 000000000000..3d02d32b17cf
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.3.0-consolekit-disable.patch
@@ -0,0 +1,14 @@
+--- lxdm-0.3.0-old/src/lxdm.c
++++ lxdm-0.3.0/src/lxdm.c
+@@ -1332,4 +1332,5 @@
+ if(option)
+ s->option=g_strdup(option);
++#if HAVE_LIBCK_CONNECTOR
+ if(s->ckc)
+ {
+@@ -1337,4 +1338,5 @@
+ s->ckc=NULL;
+ }
++#endif
+ #if HAVE_LIBPAM
+ setup_pam_session(s,pw,session_name);
diff --git a/lxde-base/lxdm/files/lxdm-0.3.0-pam_console-disable.patch b/lxde-base/lxdm/files/lxdm-0.3.0-pam_console-disable.patch
new file mode 100644
index 000000000000..c920bc85c3e6
--- /dev/null
+++ b/lxde-base/lxdm/files/lxdm-0.3.0-pam_console-disable.patch
@@ -0,0 +1,8 @@
+--- lxdm-0.2.0.a/pam/lxdm
++++ lxdm-0.2.0.b/pam/lxdm
+@@ -4,4 +4,4 @@
+ session optional pam_keyinit.so force revoke
+ session include system-auth
+ session required pam_loginuid.so
+-session optional pam_console.so
++# session optional pam_console.so
diff --git a/lxde-base/lxdm/lxdm-0.3.0.ebuild b/lxde-base/lxdm/lxdm-0.3.0.ebuild
new file mode 100644
index 000000000000..7be0fb1fad30
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.3.0.ebuild,v 1.1 2011/01/24 19:08:19 lxnay Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+consolekit nls"
+
+RDEPEND="sys-libs/pam
+ x11-libs/gtk+:2
+ consolekit? ( sys-auth/consolekit )
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf --with-x $(use_enable nls) || die "econf failed"
+}
+
+src_prepare() {
+ # There is consolekit
+ epatch "${FILESDIR}/${P}-pam_console-disable.patch"
+ use consolekit || epatch "${FILESDIR}/${P}-consolekit-disable.patch"
+
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README TODO || die
+}
+
+pkg_postinst() {
+ echo
+ elog "LXDM in the early stages of development!"
+ echo
+}
diff --git a/lxde-base/lxdm/metadata.xml b/lxde-base/lxdm/metadata.xml
new file mode 100644
index 000000000000..84b9f1702367
--- /dev/null
+++ b/lxde-base/lxdm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>lxde</herd>
+ <use>
+ <flag name="consolekit">Enables support for authorization using consolekit</flag>
+ </use>
+</pkgmetadata>