summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-02-18 08:01:01 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-02-18 08:01:01 +0000
commit13a9d461bd9ec7ed1dd32f85f9a94eaf1fb6372b (patch)
tree54e68ada7e021426d025f8af3132a7b1a181bbd3 /lxde-base
parentFix bug 345515 (diff)
downloadgentoo-2-13a9d461bd9ec7ed1dd32f85f9a94eaf1fb6372b.tar.gz
gentoo-2-13a9d461bd9ec7ed1dd32f85f9a94eaf1fb6372b.tar.bz2
gentoo-2-13a9d461bd9ec7ed1dd32f85f9a94eaf1fb6372b.zip
also provide xinitrc
(Portage version: 2.2.0_alpha13/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxdm/ChangeLog8
-rw-r--r--lxde-base/lxdm/files/xinitrc52
-rw-r--r--lxde-base/lxdm/lxdm-0.3.0-r2.ebuild61
3 files changed, 120 insertions, 1 deletions
diff --git a/lxde-base/lxdm/ChangeLog b/lxde-base/lxdm/ChangeLog
index 86c333f10be9..910d5d9c6f59 100644
--- a/lxde-base/lxdm/ChangeLog
+++ b/lxde-base/lxdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for lxde-base/lxdm
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.3 2011/01/25 09:44:16 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/ChangeLog,v 1.4 2011/02/18 08:01:01 lxnay Exp $
+
+*lxdm-0.3.0-r2 (18 Feb 2011)
+
+ 18 Feb 2011; Fabio Erculiani <lxnay@gentoo.org> +lxdm-0.3.0-r2.ebuild,
+ +files/xinitrc:
+ also provide xinitrc
25 Jan 2011; Fabio Erculiani <lxnay@gentoo.org> lxdm-0.3.0-r1.ebuild:
some trivial fixes
diff --git a/lxde-base/lxdm/files/xinitrc b/lxde-base/lxdm/files/xinitrc
new file mode 100644
index 000000000000..013b8164dcf8
--- /dev/null
+++ b/lxde-base/lxdm/files/xinitrc
@@ -0,0 +1,52 @@
+# Source for this script borrowed from portions of kdm's Xsession.
+
+case $SHELL in
+ */bash)
+ [ -z "$BASH" ] && exec $SHELL $0 "$@"
+ set +o posix
+ [ -f /etc/profile ] && . /etc/profile
+ if [ -f $HOME/.bash_profile ]; then
+ . $HOME/.bash_profile
+ elif [ -f $HOME/.bash_login ]; then
+ . $HOME/.bash_login
+ elif [ -f $HOME/.profile ]; then
+ . $HOME/.profile
+ fi
+ ;;
+ */zsh)
+ [ -z "$ZSH_NAME" ] && exec $SHELL $0 "$@"
+ emulate -R zsh
+ [ -d /etc/zsh ] && zdir=/etc/zsh || zdir=/etc
+ zhome=${ZDOTDIR:-$HOME}
+ # zshenv is always sourced automatically.
+ [ -f $zdir/zprofile ] && . $zdir/zprofile
+ [ -f $zhome/.zprofile ] && . $zhome/.zprofile
+ [ -f $zdir/zlogin ] && . $zdir/zlogin
+ [ -f $zhome/.zlogin ] && . $zhome/.zlogin
+ ;;
+ */csh|*/tcsh)
+ # [t]cshrc is always sourced automatically.
+ # Note that sourcing csh.login after .cshrc is non-standard.
+ xsess_tmp=`mktemp /tmp/xsess-env-XXXXXX`
+ $SHELL -c "if (-f /etc/csh.login) source /etc/csh.login; if (-f ~/.login) source ~/.login; /bin/sh -c export -p >! $xsess_tmp"
+ . $xsess_tmp
+ rm -f $xsess_tmp
+ ;;
+ *) # Plain sh, ksh, and anything we do not know.
+ [ -f /etc/profile ] && . /etc/profile
+ [ -f $HOME/.profile ] && . $HOME/.profile
+ ;;
+esac
+
+[ -f /etc/xprofile ] && . /etc/xprofile
+[ -f $HOME/.xprofile ] && . $HOME/.xprofile
+
+# run all system xinitrc shell scripts.
+if [ -d /etc/X11/xinit/xinitrc.d ]; then
+ for i in /etc/X11/xinit/xinitrc.d/* ; do
+ if [ -x "$i" ]; then
+ . "$i"
+ fi
+ done
+fi
+
diff --git a/lxde-base/lxdm/lxdm-0.3.0-r2.ebuild b/lxde-base/lxdm/lxdm-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..aa4e4472089b
--- /dev/null
+++ b/lxde-base/lxdm/lxdm-0.3.0-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxdm/lxdm-0.3.0-r2.ebuild,v 1.1 2011/02/18 08:01:01 lxnay Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="LXDE Display Manager"
+HOMEPAGE="http://lxde.org"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="+consolekit nls"
+
+COMMON_DEPEND="sys-libs/pam
+ x11-libs/gtk+:2
+ consolekit? ( sys-auth/consolekit )
+ nls? ( sys-devel/gettext )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg"
+
+src_configure() {
+ econf --with-x $(use_enable nls) || die "econf failed"
+}
+
+src_prepare() {
+ # There is consolekit
+ epatch "${FILESDIR}/${P}-pam_console-disable.patch"
+ use consolekit || epatch "${FILESDIR}/${P}-consolekit-disable.patch"
+
+ # this replaces the bootstrap/autogen script in most packages
+ eautoreconf
+
+ # process LINGUAS
+ if use nls; then
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po" || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README TODO || die
+ # install xinitrc
+ exeinto /etc/lxdm
+ doexe "${FILESDIR}"/xinitrc || die
+}
+
+pkg_postinst() {
+ echo
+ elog "LXDM is in early stage of development."
+ echo
+}