summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-02-18 02:06:44 +0000
committerBen de Groot <yngwin@gentoo.org>2010-02-18 02:06:44 +0000
commit9b1c87fb472a1bacf2fb4e5419794edb7cf8108b (patch)
tree0ae1a8e1ffaa8d3a904c10e3e050e3fdfd741681 /lxde-base
parentVersion bump (diff)
downloadgentoo-2-9b1c87fb472a1bacf2fb4e5419794edb7cf8108b.tar.gz
gentoo-2-9b1c87fb472a1bacf2fb4e5419794edb7cf8108b.tar.bz2
gentoo-2-9b1c87fb472a1bacf2fb4e5419794edb7cf8108b.zip
Version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'lxde-base')
-rw-r--r--lxde-base/lxpanel/ChangeLog7
-rw-r--r--lxde-base/lxpanel/lxpanel-0.5.5.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/lxde-base/lxpanel/ChangeLog b/lxde-base/lxpanel/ChangeLog
index bf1f8526e08a..242a688bbc4e 100644
--- a/lxde-base/lxpanel/ChangeLog
+++ b/lxde-base/lxpanel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for lxde-base/lxpanel
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.15 2010/01/24 18:35:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/ChangeLog,v 1.16 2010/02/18 02:06:44 yngwin Exp $
+
+*lxpanel-0.5.5 (18 Feb 2010)
+
+ 18 Feb 2010; Ben de Groot <yngwin@gentoo.org> +lxpanel-0.5.5.ebuild:
+ Version bump
24 Jan 2010; Raúl Porcel <armin76@gentoo.org> lxpanel-0.5.4.1.ebuild:
Add ~arm
diff --git a/lxde-base/lxpanel/lxpanel-0.5.5.ebuild b/lxde-base/lxpanel/lxpanel-0.5.5.ebuild
new file mode 100644
index 000000000000..0f9b8dc85d0d
--- /dev/null
+++ b/lxde-base/lxpanel/lxpanel-0.5.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpanel/lxpanel-0.5.5.ebuild,v 1.1 2010/02/18 02:06:44 yngwin Exp $
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="http://lxde.org/"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+alsa"
+RESTRICT="test" # bug 249598
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libXmu
+ x11-libs/libXpm
+ lxde-base/lxmenu-data
+ lxde-base/menu-cache
+ alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.5.1-sandbox.patch
+ eautoreconf
+}
+
+src_configure() {
+ local plugins=all
+ [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+ econf $(use_enable alsa) --with-x --with-plugins=${plugins}
+ # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README || die "dodoc failed"
+}