summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-01-15 16:15:27 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-01-15 16:15:27 +0000
commit4b610015a3dc8ffc2de6365546ab5908d770b466 (patch)
treeea8a1365543612b2eb835a1cf758be792818633f /mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild
parentInital ebuild for virtual box, live one as there is no snapshot file currently (diff)
downloadgentoo-2-4b610015a3dc8ffc2de6365546ab5908d770b466.tar.gz
gentoo-2-4b610015a3dc8ffc2de6365546ab5908d770b466.tar.bz2
gentoo-2-4b610015a3dc8ffc2de6365546ab5908d770b466.zip
Version bump.
(Portage version: 2.1.2_rc4-r8)
Diffstat (limited to 'mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild')
-rw-r--r--mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild b/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild
new file mode 100644
index 000000000000..755f90c0b221
--- /dev/null
+++ b/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-acpi-notifier/claws-mail-acpi-notifier-1.0.7.ebuild,v 1.1 2007/01/15 16:15:27 ticho Exp $
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+MY_P="${MY_P/-/_}"
+
+DESCRIPTION="This plugin enables mail notification via LEDs on some laptops."
+HOMEPAGE="http://www.claws-mail.org"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND=">=mail-client/claws-mail-2.7.0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f ${D}usr/lib*/claws-mail/plugins/*.{a,la}
+}
+
+pkg_postinst() {
+ PROC_IFACES="$(echo /proc/acpi/{asus/mled,ibm/led,acer/mailled}) /proc/driver/acerhk/led"
+
+ local procfile
+ local message_shown=false
+
+ for procfile in ${PROC_IFACES}; do
+ if [[ -f ${procfile} ]]; then
+ elog "Make sure ${procfile} is writable by users of this plugin."
+ message_shown=true
+ fi
+ done
+}