summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-01-31 18:00:59 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-01-31 18:00:59 +0000
commit097ed91ee15d587d3acd3b7611c349f604f0ac28 (patch)
tree7d1d1e2ea8a96471d74e7186a18b56d39526cf1c /mail-client/claws-mail-notification
parentVersion bump, remove old version and patch. Thanks to Christian (idl0r) in bu... (diff)
downloadgentoo-2-097ed91ee15d587d3acd3b7611c349f604f0ac28.tar.gz
gentoo-2-097ed91ee15d587d3acd3b7611c349f604f0ac28.tar.bz2
gentoo-2-097ed91ee15d587d3acd3b7611c349f604f0ac28.zip
Fix building with x11-libs/libnotify >= 0.7.
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/claws-mail-notification')
-rw-r--r--mail-client/claws-mail-notification/ChangeLog7
-rw-r--r--mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild32
-rw-r--r--mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch50
3 files changed, 77 insertions, 12 deletions
diff --git a/mail-client/claws-mail-notification/ChangeLog b/mail-client/claws-mail-notification/ChangeLog
index f3cb045d4d23..2e131fa08aa9 100644
--- a/mail-client/claws-mail-notification/ChangeLog
+++ b/mail-client/claws-mail-notification/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/claws-mail-notification
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.56 2011/01/15 14:37:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/ChangeLog,v 1.57 2011/01/31 18:00:59 ssuominen Exp $
+
+ 31 Jan 2011; Samuli Suominen <ssuominen@gentoo.org>
+ claws-mail-notification-0.26.ebuild,
+ +files/claws-mail-notification-0.26-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7.
15 Jan 2011; Markus Meier <maekke@gentoo.org>
claws-mail-notification-0.26.ebuild:
diff --git a/mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild b/mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild
index 2b30962422cb..d6fb0c795f3b 100644
--- a/mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild
+++ b/mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild
@@ -1,33 +1,43 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild,v 1.4 2011/01/15 14:37:39 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-notification/claws-mail-notification-0.26.ebuild,v 1.5 2011/01/31 18:00:59 ssuominen Exp $
-MY_P="${PN#claws-mail-}_plugin-${PV}"
+EAPI=2
+inherit eutils multilib
+
+MY_P=${PN#claws-mail-}_plugin-${PV}
DESCRIPTION="Plugin providing various ways to notify user of new and unread mail"
HOMEPAGE="http://www.claws-mail.org/"
SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="libnotify"
+
RDEPEND=">=mail-client/claws-mail-3.7.7
- >=x11-libs/gtk+-2.10
- libnotify? ( x11-libs/libnotify )"
+ >=x11-libs/gtk+-2.10
+ libnotify? ( x11-libs/libnotify )"
DEPEND="${RDEPEND}
- dev-util/pkgconfig"
+ dev-util/pkgconfig"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+}
-src_compile() {
- econf $(use_enable libnotify) || die
- emake || die
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-static \
+ $(use_enable libnotify)
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README
- # kill useless files
- rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+ rm -f "${D}"/usr/$(get_libdir)/claws-mail/plugins/*.la
}
diff --git a/mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch b/mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch
new file mode 100644
index 000000000000..6159d139cdb5
--- /dev/null
+++ b/mail-client/claws-mail-notification/files/claws-mail-notification-0.26-libnotify-0.7.patch
@@ -0,0 +1,50 @@
+--- src/notification_popup.c
++++ src/notification_popup.c
+@@ -339,7 +339,16 @@
+ break;
+ }
+
++#ifdef NOTIFY_CHECK_VERSION
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ ppopup->notification = notify_notification_new(summary, utf8_str, NULL);
++#else
+ ppopup->notification = notify_notification_new(summary, utf8_str, NULL, NULL);
++#endif
++#else
++ ppopup->notification = notify_notification_new(summary, utf8_str, NULL, NULL);
++#endif
++
+ g_free(utf8_str);
+ if(ppopup->notification == NULL) {
+ debug_print("Notification Plugin: Failed to create a new "
+--- src/notification_trayicon.c
++++ src/notification_trayicon.c
+@@ -61,6 +61,10 @@
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ typedef struct {
+ gint count;
+ gint num_mail;
+@@ -601,8 +605,17 @@
+ summary = notification_trayicon_popup_assemble_summary();
+ utf8_str = notification_trayicon_popup_assemble_body(msginfo);
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ popup.notification = notify_notification_new(summary, utf8_str, NULL);
++#else
+ popup.notification = notify_notification_new(summary, utf8_str, NULL, NULL);
++#endif
++
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ /* notify_notification_attach_to_status_icon function was removed */
++#else
+ notify_notification_attach_to_status_icon(popup.notification, trayicon);
++#endif
+
+ g_free(summary);
+ g_free(utf8_str);