summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <fauli@gentoo.org>2009-07-06 12:37:42 +0000
committerChristian Faulhammer <fauli@gentoo.org>2009-07-06 12:37:42 +0000
commit4960fb8f1e1c5541d1ac1e234df7ba4ffff5405a (patch)
treea8b5ac99305be299715d7af2b3dd9d62696872f5 /mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild
parentversion bump (diff)
downloadgentoo-2-4960fb8f1e1c5541d1ac1e234df7ba4ffff5405a.tar.gz
gentoo-2-4960fb8f1e1c5541d1ac1e234df7ba4ffff5405a.tar.bz2
gentoo-2-4960fb8f1e1c5541d1ac1e234df7ba4ffff5405a.zip
version bump and clean up
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild')
-rw-r--r--mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild b/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild
new file mode 100644
index 000000000000..0a1f0cdafee9
--- /dev/null
+++ b/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/claws-mail-spam_report/claws-mail-spam_report-0.3.9.ebuild,v 1.1 2009/07/06 12:37:42 fauli Exp $
+
+inherit eutils
+
+MY_P="${P#claws-mail-}"
+
+DESCRIPTION="Plugin for Claws to report spam to various places"
+HOMEPAGE="http://www.claws-mail.org/"
+SRC_URI="http://www.claws-mail.org/downloads/plugins/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=mail-client/claws-mail-3.7.1
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # kill useless files
+ rm -f "${D}"/usr/lib*/claws-mail/plugins/*.{a,la}
+}