summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-04-26 22:07:42 +0000
committerTorsten Veller <tove@gentoo.org>2009-04-26 22:07:42 +0000
commitacf524932c609decaca8b0d57846a263b8702268 (patch)
treefdc7f3b7bab9628957ae06993d6dbf1970c33eb0 /mail-client/hap
parentAdded qt-xmlpatterns as dependency. Apply patch from but #267012 (diff)
downloadgentoo-2-acf524932c609decaca8b0d57846a263b8702268.tar.gz
gentoo-2-acf524932c609decaca8b0d57846a263b8702268.tar.bz2
gentoo-2-acf524932c609decaca8b0d57846a263b8702268.zip
Fix bugs: 221553, 226579, 241358, 244130
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'mail-client/hap')
-rw-r--r--mail-client/hap/ChangeLog8
-rw-r--r--mail-client/hap/hap-3.7-r1.ebuild38
-rw-r--r--mail-client/hap/hap-3.7.ebuild32
3 files changed, 24 insertions, 54 deletions
diff --git a/mail-client/hap/ChangeLog b/mail-client/hap/ChangeLog
index d05dd6931f03..221e815f7223 100644
--- a/mail-client/hap/ChangeLog
+++ b/mail-client/hap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/hap
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/ChangeLog,v 1.11 2007/04/24 18:40:58 dertobi123 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/ChangeLog,v 1.12 2009/04/26 22:07:42 tove Exp $
+
+ 26 Apr 2009; Torsten Veller <tove@gentoo.org> -hap-3.7.ebuild,
+ hap-3.7-r1.ebuild:
+ Fix bugs: 221553, 226579, 241358, 244130
24 Apr 2007; Tobias Scherbaum <dertobi123@gentoo.org> hap-3.7-r1.ebuild:
ppc stable, bug #173771
diff --git a/mail-client/hap/hap-3.7-r1.ebuild b/mail-client/hap/hap-3.7-r1.ebuild
index 58382bf7e986..7cb57757a1ad 100644
--- a/mail-client/hap/hap-3.7-r1.ebuild
+++ b/mail-client/hap/hap-3.7-r1.ebuild
@@ -1,41 +1,39 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/hap-3.7-r1.ebuild,v 1.4 2007/04/24 18:40:58 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/hap-3.7-r1.ebuild,v 1.5 2009/04/26 22:07:42 tove Exp $
-IUSE=""
+EAPI=2
+
+inherit autotools
DESCRIPTION="A terminal mail notification program (replacement for biff)"
HOMEPAGE="http://www.transbay.net/~enf/sw.html"
-SRC_URI="http://www.transbay.net/~enf/hap-3.7.tar"
+SRC_URI="http://www.transbay.net/~enf/${P}.tar"
-DEPEND="sys-libs/ncurses
- sys-devel/autoconf"
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="alpha ppc x86"
+IUSE=""
-# untars to 'hap/'
S="${WORKDIR}/${PN}"
-src_compile() {
+src_prepare() {
# Fix configure to use ncurses instead of termcap (bug #103105)
sed -i -e '/AC_CHECK_LIB/s~termcap~ncurses~' configure.in
- # Fix Makefile.in to use our CFLAGS
- sed -i -e "/^CFLAGS=-O/s//CFLAGS=${CFLAGS}/" Makefile.in
+ # Fix Makefile.in to use our CFLAGS and LDFLAGS
+ sed -i -e "s/^CFLAGS=-O/CFLAGS=${CFLAGS}/" \
+ -e "s/^LDFLAGS=.*/LDFLAGS=${LDFLAGS}/" Makefile.in
# Rebuild the compilation framework
- autoconf || die "autoconf failed"
-
- # The configure script doesn't like --mandir etc., so we call it directly
- # rather than via econf
- ./configure || die "configure failed"
-
- emake || die "emake failed"
+ eautoreconf || die "autoconf failed"
}
src_install() {
- dobin hap
- doman hap.1
+ dobin hap || die
+ doman hap.1 || die
+ dodoc README HISTORY || die
}
diff --git a/mail-client/hap/hap-3.7.ebuild b/mail-client/hap/hap-3.7.ebuild
deleted file mode 100644
index 7deca1f405ca..000000000000
--- a/mail-client/hap/hap-3.7.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/hap/hap-3.7.ebuild,v 1.6 2005/10/18 00:27:33 agriffis Exp $
-
-IUSE=""
-
-DESCRIPTION="A terminal mail notification program (replacement for biff)"
-HOMEPAGE="http://www.transbay.net/~enf/sw.html"
-SRC_URI="http://www.transbay.net/~enf/hap-3.7.tar"
-
-DEPEND="sys-libs/libtermcap-compat"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha ppc x86"
-
-# untars to 'hap/'
-S="${WORKDIR}/${PN}"
-
-src_compile() {
-
- # The configure script doesn't like --mandir etc., so we call it directly
- # rather than via econf
- ./configure || die "configure failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- dobin hap
- doman hap.1
-}