summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-04 11:46:10 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-04 11:46:10 +0000
commitbded11d87e55f4255db49ed14a9ba1e72e23694b (patch)
treebfe8a251500bbf3df180072c8262b24de8bfac0f /mail-client/mail-notification
parentStable on amd64 wrt bug #391641 (diff)
downloadgentoo-2-bded11d87e55f4255db49ed14a9ba1e72e23694b.tar.gz
gentoo-2-bded11d87e55f4255db49ed14a9ba1e72e23694b.tar.bz2
gentoo-2-bded11d87e55f4255db49ed14a9ba1e72e23694b.zip
Make markup in notifications compatible with newer notification-daemon implementations. Thansk to Ian Abbott in bug 392599 for finding and preparing the patch.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/mail-notification')
-rw-r--r--mail-client/mail-notification/ChangeLog11
-rw-r--r--mail-client/mail-notification/files/mail-notification-5.4-fix-markup.patch34
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r5.ebuild110
3 files changed, 154 insertions, 1 deletions
diff --git a/mail-client/mail-notification/ChangeLog b/mail-client/mail-notification/ChangeLog
index 3485b0e4f433..2151d7e598e4 100644
--- a/mail-client/mail-notification/ChangeLog
+++ b/mail-client/mail-notification/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for mail-client/mail-notification
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.107 2011/03/06 07:37:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/ChangeLog,v 1.108 2011/12/04 11:46:10 graaff Exp $
+
+*mail-notification-5.4-r5 (04 Dec 2011)
+
+ 04 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ +mail-notification-5.4-r5.ebuild,
+ +files/mail-notification-5.4-fix-markup.patch:
+ Make markup in notifications compatible with newer notification-daemon
+ implementations. Thansk to Ian Abbott in bug 392599 for finding and preparing
+ the patch.
06 Mar 2011; Hans de Graaff <graaff@gentoo.org>
mail-notification-5.4-r4.ebuild:
diff --git a/mail-client/mail-notification/files/mail-notification-5.4-fix-markup.patch b/mail-client/mail-notification/files/mail-notification-5.4-fix-markup.patch
new file mode 100644
index 000000000000..b5d826eb2808
--- /dev/null
+++ b/mail-client/mail-notification/files/mail-notification-5.4-fix-markup.patch
@@ -0,0 +1,34 @@
+Fix markup to a format that is also supported by newer
+notification-daemon versions, e.g. the one used in Gnome 3.
+
+https://bugs.gentoo.org/show_bug.cgi?id=392599
+
+diff -urp mail-notification-5.4.orig/src/mn-popup.gob mail-notification-5.4/src/mn-popup.gob
+--- mail-notification-5.4.orig/src/mn-popup.gob 2008-05-22 16:45:36.000000000 +0100
++++ mail-notification-5.4/src/mn-popup.gob 2011-11-30 13:34:40.000000000 +0000
+@@ -136,7 +136,7 @@ class MN:Popup from Notify:Notification
+ if (*body->str)
+ g_string_append_c(body, '\n');
+
+- g_string_append_printf(body, "<span weight=\"bold\">%s</span>", name);
++ g_string_append_printf(body, "<b>%s</b>", name);
+
+ escaped = g_markup_escape_text(value, -1);
+ g_string_append_printf(body, " %s", escaped);
+diff -urp mail-notification-5.4.orig/build/src/mn-popup.c mail-notification-5.4/build/src/mn-popup.c
+--- mail-notification-5.4.orig/build/src/mn-popup.c 2008-05-22 16:47:49.000000000 +0100
++++ mail-notification-5.4/build/src/mn-popup.c 2011-11-30 13:35:37.000000000 +0000
+@@ -434,7 +434,7 @@ mn_popup_append_row (GString * body, con
+ if (*body->str)
+ g_string_append_c(body, '\n');
+
+- g_string_append_printf(body, "<span weight=\"bold\">%s</span>", name);
++ g_string_append_printf(body, "<b>%s</b>", name);
+
+ escaped = g_markup_escape_text(value, -1);
+ g_string_append_printf(body, " %s", escaped);
+diff -urp mail-notification-5.4.orig/build/src/mn-popup.gob.stamp mail-notification-5.4/build/src/mn-popup.gob.stamp
+--- mail-notification-5.4.orig/build/src/mn-popup.gob.stamp 2008-05-22 16:47:49.000000000 +0100
++++ mail-notification-5.4/build/src/mn-popup.gob.stamp 2011-11-30 13:38:09.000000000 +0000
+@@ -0,0 +1 @@
++
diff --git a/mail-client/mail-notification/mail-notification-5.4-r5.ebuild b/mail-client/mail-notification/mail-notification-5.4-r5.ebuild
new file mode 100644
index 000000000000..cfbb9c067532
--- /dev/null
+++ b/mail-client/mail-notification/mail-notification-5.4-r5.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/mail-notification/mail-notification-5.4-r5.ebuild,v 1.1 2011/12/04 11:46:10 graaff Exp $
+
+EAPI=2
+
+inherit gnome2 multilib flag-o-matic toolchain-funcs
+
+DESCRIPTION="A GNOME trayicon which checks for email, with support for many online and offline mailbox formats."
+HOMEPAGE="http://www.nongnu.org/mailnotify/"
+SRC_URI="http://savannah.nongnu.org/download/mailnotify/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="GPL-3"
+
+IUSE="evo gmail imap ipv6 maildir mbox mh mozilla pop sasl ssl sylpheed"
+
+# gmime is actually optional, but it's used by so much of the package
+# it's pointless making it optional. gnome-keyring is required for
+# several specific access methods, and thus linked to those USE flags
+# instead of adding a keyring USE flag.
+RDEPEND=">=x11-libs/gtk+-2.12:2
+ >=dev-libs/glib-2.14
+ >=gnome-base/gconf-2.4.0
+ >=gnome-base/gconf-2.6
+ >=gnome-base/libgnomeui-2.14
+ >=gnome-base/libglade-2.0
+ dev-libs/dbus-glib
+ dev-libs/gmime:2.4
+ >=x11-libs/libnotify-0.4.1
+ pop? ( gnome-base/gnome-keyring )
+ imap? ( gnome-base/gnome-keyring )
+ gmail? ( gnome-base/gnome-keyring )
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ sasl? ( >=dev-libs/cyrus-sasl-2 )
+ evo? ( >=mail-client/evolution-2.24 )
+ sylpheed? ( mail-client/sylpheed )"
+
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ dev-util/pkgconfig
+ >=dev-util/intltool-0.35.0"
+
+# this now uses JB (the Jean-Yves Lefort's Build System) as a build system
+# instead of autotools, this is a little helper function that basically does
+# the same thing as use_enable
+use_var() {
+ echo -n "${2:-$1}="
+ use "${1}" && echo "yes" || echo "no"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-dont-update-cache.patch"
+
+ # We are not Ubuntu, and I suspect that this is the cause of #215281
+ epatch "${FILESDIR}/${P}-remove-ubuntu-special-case.patch"
+
+ # Make it work ok with eds-2.24 and 2.29
+ epatch "${FILESDIR}/${P}-e-d-s.patch"
+
+ # Fix gtkhtml depend to solve building against evo-2.28, see bug #293374
+ epatch "${FILESDIR}/${P}-evolution-gtkhtml.patch"
+
+ # Add patch for new cyrus-sasl's ABI, see:
+ # https://bugzilla.redhat.com/501456
+ epatch "${FILESDIR}/${P}-sasl_encode64.patch"
+
+ # Fedora patch to build against dev-libs/gmime:2.4
+ epatch "${FILESDIR}/${P}-gmime.patch"
+
+ # Fix forced --as-needed, bug 317905
+ epatch "${FILESDIR}/${P}-asneeded.patch"
+
+ # Fix icons for gnome 2.30+
+ epatch "${FILESDIR}/${P}-icons.patch"
+
+ epatch "${FILESDIR}/${P}-fix-markup.patch"
+}
+
+src_configure() {
+ ./jb configure destdir="${D}" prefix="/usr" libdir=/usr/$(get_libdir) \
+ sysconfdir="/etc" localstatedir="/var" cc="$(tc-getCC)" \
+ cflags="${CFLAGS}" cppflags="${CXXFLAGS}" ldflags="${LDFLAGS}" \
+ scrollkeeper-dir="/var/lib/scrollkeeper" \
+ $(use_var evo evolution) \
+ $(use_var gmail) \
+ $(use_var imap) \
+ $(use_var ipv6) \
+ $(use_var maildir) \
+ $(use_var mbox) \
+ $(use_var mh) \
+ $(use_var mozilla) \
+ $(use_var pop pop3) \
+ $(use_var sasl) \
+ $(use_var ssl) \
+ $(use_var sylpheed) || die
+}
+
+src_compile() {
+ ./jb build || die
+}
+
+src_install() {
+ GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1" ./jb install || die
+
+ dodoc NEWS README AUTHORS TODO TRANSLATING
+
+ rm -rf "${D}/var/lib/scrollkeeper"
+}