summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2004-07-31 02:41:24 +0000
committerTuan Van <langthang@gentoo.org>2004-07-31 02:41:24 +0000
commit3514c8c0ae468d2a957a5eac7981f3de602b1108 (patch)
treeae3636a4b67bbf76ef05386ba51f98ab168c5d0a /mail-client/nmh/nmh-1.1.ebuild
parentstable on ppc64, bug #57127 (Manifest recommit) (diff)
downloadgentoo-2-3514c8c0ae468d2a957a5eac7981f3de602b1108.tar.gz
gentoo-2-3514c8c0ae468d2a957a5eac7981f3de602b1108.tar.bz2
gentoo-2-3514c8c0ae468d2a957a5eac7981f3de602b1108.zip
Version bump, bug #22173.
Diffstat (limited to 'mail-client/nmh/nmh-1.1.ebuild')
-rw-r--r--mail-client/nmh/nmh-1.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/mail-client/nmh/nmh-1.1.ebuild b/mail-client/nmh/nmh-1.1.ebuild
new file mode 100644
index 000000000000..6dc8862441f4
--- /dev/null
+++ b/mail-client/nmh/nmh-1.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/nmh-1.1.ebuild,v 1.1 2004/07/31 02:41:24 langthang Exp $
+
+inherit eutils
+DESCRIPTION="New MH mail reader"
+SRC_URI="ftp://ftp.mhost.com/pub/nmh/${P}.tar.gz"
+HOMEPAGE="http://www.mhost.com/nmh/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+
+DEPEND="virtual/libc
+ =sys-libs/db-1.85*
+ >=sys-libs/ncurses-5.2"
+
+S=${WORKDIR}/${PN}
+
+src_compile() {
+
+ [ -z "${EDITOR}" ] && export EDITOR="prompter"
+ [ -z "${PAGER}" ] && export PAGER="/usr/bin/more"
+
+ # Patches from bug #22173.
+ epatch ${FILESDIR}/${P}-inc-login.patch
+ epatch ${FILESDIR}/${P}-install.patch
+ # vi test access violation patch
+ epatch ${FILESDIR}/${P}-configure-vitest.patch || die "patch failed."
+ # bug #57886
+ epatch ${FILESDIR}/${P}-m_getfld.patch || die "patch failed."
+
+ # Redifining libdir to be bindir so the support binaries get installed
+ # correctly. Since no libraries are installed with nmh, this does not
+ # pose a problem at this time.
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-editor=${EDITOR} \
+ --with-pager=${PAGER} \
+ --enable-nmh-pop \
+ --sysconfdir=/etc/nmh \
+ --libdir=/usr/bin || die
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/bin \
+ etcdir=${D}/etc/nmh install || die
+ dodoc COMPLETION-TCSH COMPLETION-ZSH TODO FAQ DIFFERENCES \
+ MAIL.FILTERING Changelog* COPYRIGHT
+}