summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-12-29 11:18:49 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-12-29 11:18:49 +0000
commitf053764cb4fb6d9c384c7e7824d597c70b427160 (patch)
tree71145512e9493130450af4c7717b44a2f89b1e1b /mail-client/nmh
parentx86 stable per bug 349891 (diff)
downloadgentoo-2-f053764cb4fb6d9c384c7e7824d597c70b427160.tar.gz
gentoo-2-f053764cb4fb6d9c384c7e7824d597c70b427160.tar.bz2
gentoo-2-f053764cb4fb6d9c384c7e7824d597c70b427160.zip
Revbump. Addresses bugs #348816 and bug #341741. Thanks to Seth Robertson <in-gentoo@baka.org> for the ebuild
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/nmh')
-rw-r--r--mail-client/nmh/ChangeLog10
-rw-r--r--mail-client/nmh/nmh-1.3-r3.ebuild76
2 files changed, 84 insertions, 2 deletions
diff --git a/mail-client/nmh/ChangeLog b/mail-client/nmh/ChangeLog
index 9b17559dd2a0..7a7a9d486989 100644
--- a/mail-client/nmh/ChangeLog
+++ b/mail-client/nmh/ChangeLog
@@ -1,6 +1,12 @@
-# ChangeLog for net-mail/nmh
+# ChangeLog for mail-client/nmh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/ChangeLog,v 1.26 2010/09/27 17:37:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/ChangeLog,v 1.27 2010/12/29 11:18:49 hwoarang Exp $
+
+*nmh-1.3-r3 (29 Dec 2010)
+
+ 29 Dec 2010; Markos Chandras <hwoarang@gentoo.org> +nmh-1.3-r3.ebuild:
+ Revbump. Addresses bugs #348816 and bug #341741. Thanks to Seth Robertson
+ <in-gentoo@baka.org> for the ebuild
*nmh-1.3-r2 (27 Sep 2010)
diff --git a/mail-client/nmh/nmh-1.3-r3.ebuild b/mail-client/nmh/nmh-1.3-r3.ebuild
new file mode 100644
index 000000000000..fc37ec8050ba
--- /dev/null
+++ b/mail-client/nmh/nmh-1.3-r3.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/nmh/nmh-1.3-r3.ebuild,v 1.1 2010/12/29 11:18:49 hwoarang Exp $
+
+EAPI="2"
+
+inherit eutils base
+
+DESCRIPTION="New MH mail reader"
+HOMEPAGE="http://www.nongnu.org/nmh/"
+SRC_URI="http://savannah.nongnu.org/download/nmh/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gdbm"
+
+DEPEND="gdbm? ( sys-libs/gdbm )
+ !gdbm? ( sys-libs/db )
+ >=sys-libs/ncurses-5.2
+ net-libs/liblockfile
+ app-editors/gentoo-editor
+ !!media-gfx/pixie" # Bug #295996 media-gfx/pixie also uses show
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog DATE MACHINES README )
+
+src_prepare() {
+ # Patches from bug #22173.
+ epatch "${FILESDIR}"/${P}-inc-login.patch
+ epatch "${FILESDIR}"/${P}-install.patch
+ # bug #57886
+ epatch "${FILESDIR}"/${P}-m_getfld.patch
+ # bug #319937
+ epatch "${FILESDIR}"/${P}-db5.patch
+ # Allow parallel compiles/installs
+ epatch "${FILESDIR}"/${P}-parallelmake.patch
+}
+
+src_configure() {
+ [ -z "${PAGER}" ] && export PAGER="/usr/bin/more"
+
+ # strip options from ${PAGER} (quoting not good enough) (Bug #262150)
+ PAGER=${PAGER%% *}
+
+ # Bug 348816 & Bug 341741: The previous ebuild default of
+ # /usr/bin caused unnecessary conflicts with other
+ # packages. However, the default nmh libdir location causes
+ # problems with cross-compiling, so we use, eg., /usr/lib64.
+ # Users may use /usr/lib/nmh in scripts needing these support
+ # programs in normal environments.
+ local myconf="--libdir=/usr/$(get_libdir)/nmh"
+
+ # Have gdbm use flag actually control which version of db in use
+ if use gdbm; then
+ myconf="${myconf} --with-ndbmheader=gdbm/ndbm.h --with-ndbm=gdbm_compat"
+ else
+ if has_version ">=sys-libs/db-2"; then
+ myconf="${myconf} --with-ndbmheader=db.h --with-ndbm=db"
+ else
+ myconf="${myconf} --with-ndbmheader=db1/ndbm.h --with-ndbm=db1"
+ fi
+ fi
+
+ # use gentoo-editor to avoid implicit dependencies (Bug #294762)
+ EDITOR=/usr/libexec/gentoo-editor
+
+ econf \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-editor="${EDITOR}" \
+ --with-pager="${PAGER}" \
+ --enable-nmh-pop \
+ --sysconfdir=/etc/nmh \
+ ${myconf}
+} \ No newline at end of file