summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-05-18 21:18:54 +0000
committerTim Harder <radhermit@gentoo.org>2011-05-18 21:18:54 +0000
commited474c43192d5ab4c027b8ba01c6d96eef354c66 (patch)
treedb57fcccbfb0918cd1d8b9a24da2ba84ea23f2cd /mail-client/roundcube
parentFixing prefix-related bug #367461, thanks to Steven Trogdon <strogdon@d.umn.edu> (diff)
downloadgentoo-2-ed474c43192d5ab4c027b8ba01c6d96eef354c66.tar.gz
gentoo-2-ed474c43192d5ab4c027b8ba01c6d96eef354c66.tar.bz2
gentoo-2-ed474c43192d5ab4c027b8ba01c6d96eef354c66.zip
Revision bump and remove old. Apply upstream fix for bug #365851 by Stuart Shelton.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'mail-client/roundcube')
-rw-r--r--mail-client/roundcube/ChangeLog9
-rw-r--r--mail-client/roundcube/files/roundcube-0.5.2-fix-imap-disconnect.patch26
-rw-r--r--mail-client/roundcube/roundcube-0.5.2-r1.ebuild (renamed from mail-client/roundcube/roundcube-0.5.2.ebuild)6
3 files changed, 38 insertions, 3 deletions
diff --git a/mail-client/roundcube/ChangeLog b/mail-client/roundcube/ChangeLog
index ee4d7c844bc9..ef54360083f8 100644
--- a/mail-client/roundcube/ChangeLog
+++ b/mail-client/roundcube/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-client/roundcube
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.49 2011/04/21 19:11:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/ChangeLog,v 1.50 2011/05/18 21:18:54 radhermit Exp $
+
+*roundcube-0.5.2-r1 (18 May 2011)
+
+ 18 May 2011; Tim Harder <radhermit@gentoo.org> -roundcube-0.5.2.ebuild,
+ +roundcube-0.5.2-r1.ebuild, +files/roundcube-0.5.2-fix-imap-disconnect.patch:
+ Revision bump and remove old. Apply upstream fix for bug #365851 by Stuart
+ Shelton.
*roundcube-0.5.2 (21 Apr 2011)
diff --git a/mail-client/roundcube/files/roundcube-0.5.2-fix-imap-disconnect.patch b/mail-client/roundcube/files/roundcube-0.5.2-fix-imap-disconnect.patch
new file mode 100644
index 000000000000..4a03a01f2178
--- /dev/null
+++ b/mail-client/roundcube/files/roundcube-0.5.2-fix-imap-disconnect.patch
@@ -0,0 +1,26 @@
+--- CHANGELOG
++++ CHANGELOG
+@@ -2,4 +2,5 @@
+ ===========================
+
++- Fix issue which cases IMAP disconnection when encrypt() method was used (#1487900)
+ - Fix some CSS issues in Settings for Internet Explorer
+ - Fixed handling of folder with name "0" in folder selector
+--- program/include/rcmail.php
++++ program/include/rcmail.php
+@@ -1079,4 +1079,7 @@
+ $book->close();
+
++ if (is_object($this->imap))
++ $this->imap->close();
++
+ // before closing the database connection, write session data
+ if ($_SERVER['REMOTE_ADDR'])
+@@ -1194,7 +1197,4 @@
+ }
+
+- if (is_object($this->imap))
+- $this->imap->close();
+-
+ return $base64 ? base64_encode($cipher) : $cipher;
+ }
diff --git a/mail-client/roundcube/roundcube-0.5.2.ebuild b/mail-client/roundcube/roundcube-0.5.2-r1.ebuild
index 29b07da8dd9b..11f23b653b23 100644
--- a/mail-client/roundcube/roundcube-0.5.2.ebuild
+++ b/mail-client/roundcube/roundcube-0.5.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.5.2.ebuild,v 1.1 2011/04/21 19:11:40 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/roundcube/roundcube-0.5.2-r1.ebuild,v 1.1 2011/05/18 21:18:54 radhermit Exp $
EAPI="2"
-inherit webapp depend.php
+inherit eutils webapp depend.php
MY_PN="${PN}mail"
MY_P="${MY_PN}-${PV/_/-}"
@@ -45,6 +45,8 @@ pkg_setup() {
src_prepare() {
cp config/db.inc.php{.dist,}
cp config/main.inc.php{.dist,}
+
+ epatch "${FILESDIR}"/${P}-fix-imap-disconnect.patch
}
src_install() {