summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-02-26 20:56:40 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-02-26 20:56:40 +0000
commit964ed7f91540f03cd6e47327fe01dc9c2d867cb9 (patch)
tree769b176c0eea95da62c3e33eaddfc065ed524979 /mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild
parentBump 2.1_pre5 to 2.1_pre5-r1 in portage.py. (diff)
downloadgentoo-2-964ed7f91540f03cd6e47327fe01dc9c2d867cb9.tar.gz
gentoo-2-964ed7f91540f03cd6e47327fe01dc9c2d867cb9.tar.bz2
gentoo-2-964ed7f91540f03cd6e47327fe01dc9c2d867cb9.zip
Version bump.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild')
-rw-r--r--mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild b/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild
new file mode 100644
index 000000000000..94275afb1808
--- /dev/null
+++ b/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-rssyl/sylpheed-claws-rssyl-0.4.ebuild,v 1.1 2006/02/26 20:56:40 ticho Exp $
+
+MY_P="${P##sylpheed-claws-}"
+SC_BASE="2.0.0_rc1"
+
+DESCRIPTION="This plugin allows you to read your favorite newsfeeds in Claws. RSS 1.0, 2.0 and Atom feeds are currently supported."
+HOMEPAGE="http://claws.sylpheed.org"
+SRC_URI="http://ticho.yweb.sk/rssyl/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+DEPEND=">=mail-client/sylpheed-claws-${SC_BASE}
+ net-misc/curl
+ dev-libs/libxml2
+ nls? ( >=sys-devel/gettext-0.12.1 )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc ChangeLog README
+
+ # kill useless files
+ rm -f ${D}/usr/lib*/sylpheed-claws/plugins/*.{a,la}
+}