summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-10-08 23:07:44 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-10-08 23:07:44 +0000
commit49a62c4fc729904bbc36aba52ba27257be79baf3 (patch)
tree5e715e8b1be77103e64ac4b4432e44b59a711e16 /mail-client
parentversion bump (diff)
downloadgentoo-2-49a62c4fc729904bbc36aba52ba27257be79baf3.tar.gz
gentoo-2-49a62c4fc729904bbc36aba52ba27257be79baf3.tar.bz2
gentoo-2-49a62c4fc729904bbc36aba52ba27257be79baf3.zip
Bump to work with uw-mailutils. Also updated chappa-all patch.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/pine/ChangeLog7
-rw-r--r--mail-client/pine/files/digest-pine-4.64-r12
-rw-r--r--mail-client/pine/pine-4.64-r1.ebuild180
-rw-r--r--mail-client/pine/pine-4.64.ebuild4
4 files changed, 190 insertions, 3 deletions
diff --git a/mail-client/pine/ChangeLog b/mail-client/pine/ChangeLog
index 3fe5eafb2ed2..9a497a831d9b 100644
--- a/mail-client/pine/ChangeLog
+++ b/mail-client/pine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/pine
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.69 2005/10/02 17:12:51 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/ChangeLog,v 1.70 2005/10/08 23:07:44 ticho Exp $
+
+*pine-4.64-r1 (08 Oct 2005)
+
+ 08 Oct 2005; Andrej Kacian <ticho@gentoo.org> +pine-4.64-r1.ebuild:
+ Bump to work with uw-mailutils. Also updated chappa-all patch.
02 Oct 2005; Michael Hanselmann <hansmi@gentoo.org> pine-4.63-r3.ebuild:
Stable on ppc.
diff --git a/mail-client/pine/files/digest-pine-4.64-r1 b/mail-client/pine/files/digest-pine-4.64-r1
new file mode 100644
index 000000000000..92afc29cb26a
--- /dev/null
+++ b/mail-client/pine/files/digest-pine-4.64-r1
@@ -0,0 +1,2 @@
+MD5 39ca07b3d305b4cd0d6aaf4585123275 pine4.64.tar.bz2 3110790
+MD5 00abffc3fa1b2e2f0ded49ae9a017bb2 pine-4.64-r1-chappa-all.patch.gz 168825
diff --git a/mail-client/pine/pine-4.64-r1.ebuild b/mail-client/pine/pine-4.64-r1.ebuild
new file mode 100644
index 000000000000..eb1c1fcbc6db
--- /dev/null
+++ b/mail-client/pine/pine-4.64-r1.ebuild
@@ -0,0 +1,180 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.64-r1.ebuild,v 1.1 2005/10/08 23:07:44 ticho Exp $
+
+inherit eutils
+
+# Using this ugly hack, since we're making our own versioned copies of chappa
+# patch, as upstream doesn't version them, and patch revision number doesn't
+# always have to correspond to ebuild revision number. (see #59573)
+CHAPPA_PF="${P}-r1"
+
+DESCRIPTION="A tool for reading, sending and managing electronic messages."
+HOMEPAGE="http://www.washington.edu/pine/
+ http://www.math.washington.edu/~chappa/pine/patches/"
+SRC_URI="ftp://ftp.cac.washington.edu/pine/${P/-/}.tar.bz2
+ mirror://gentoo/${CHAPPA_PF}-chappa-all.patch.gz"
+# ipv6? (
+# http://www.ngn.euro6ix.org/IPv6/${PN}/${P}-v6-20031001.diff
+# http://www.ngn.euro6ix.org/IPv6/${PN}/readme.${P}-v6-20031001
+# )"
+
+LICENSE="PICO"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc x86"
+IUSE="ssl ldap kerberos largeterminal pam passfile debug"
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4
+ >=sys-libs/ncurses-5.1
+ pam? ( >=sys-libs/pam-0.72 )
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ kerberos? ( app-crypt/mit-krb5 )"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+ net-mail/uw-mailutils
+ !<=net-mail/uw-imap-2004g"
+
+S="${WORKDIR}/${P/-/}"
+
+maildir_warn() {
+ einfo
+ einfo "This build of Pine has Maildir support built in as"
+ einfo "part of the chappa-all patch."
+ einfo
+ einfo "If you have a maildir at ~/Maildir it will be your"
+ einfo "default INBOX. The path may be changed with the"
+ einfo "\"maildir-location\" setting in Pine."
+ einfo
+ einfo "To use /var/spool/mail INBOX again, set"
+ einfo "\"disable-these-drivers=md\" in your .pinerc file."
+ einfo
+ einfo "Alternately, you might want to read following webpage, which explains how to"
+ einfo "use multiple mailboxes simultaneously:"
+ echo
+ echo "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
+ echo
+}
+
+pkg_setup() {
+ maildir_warn
+}
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+ epatch "${FILESDIR}/pine-4.62-spooldir-permissions.patch" || die
+
+ # Various fixes and features.
+ epatch "${WORKDIR}/${CHAPPA_PF}-chappa-all.patch" || die
+ # Fix flock() emulation.
+ cp "${FILESDIR}/flock.c" "${S}/imap/src/osdep/unix" || die
+ # Build the flock() emulation.
+ epatch "${FILESDIR}/imap-4.7c2-flock_4.60.patch" || die
+ if use ldap ; then
+ # Link to shared ldap libs instead of static.
+ epatch "${FILESDIR}/pine-4.30-ldap.patch" || die
+ mkdir "${S}/ldap"
+ ln -s /usr/lib "${S}/ldap/libraries"
+ ln -s /usr/include "${S}/ldap/include"
+ fi
+# if use ipv6 ; then
+# epatch "${DISTDIR}/${P}-v6-20031001.diff" || die
+# fi
+ if use passfile ; then
+ #Is this really the correct place to define it?
+ epatch "${FILESDIR}/pine-4.56-passfile.patch" || die
+ fi
+ if use largeterminal ; then
+ # Add support for large terminals by doubling the size of pine's internal display buffer
+ epatch "${FILESDIR}/pine-4.61-largeterminal.patch" || die
+ fi
+
+ # Something from RedHat.
+ epatch "${FILESDIR}/pine-4.31-segfix.patch" || die
+ # Create lockfiles with a mode of 0600 instead of 0666.
+ epatch "${FILESDIR}/pine-4.40-lockfile-perm.patch" || die
+ # Add missing time.h includes.
+ epatch "${FILESDIR}/imap-2000-time.patch" || die
+ # Bug #23336 - makes pine transparent in terms that support it.
+ epatch "${FILESDIR}/transparency.patch" || die
+
+ # Bug #72861 - relaxes subject length for base64-encoded subjects
+ epatch "${FILESDIR}/pine-4.61-subjectlength.patch" || die
+
+ if use debug ; then
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS} -g -DDEBUG -DDEBUGJOURNAL:" \
+ -i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
+ sed -e "s:-g -DDEBUG:${CFLAGS} -g -DDEBUG:" \
+ -i "${S}/pico/makefile.lnx" || die "sed pico/makefile.lnx failed"
+ else
+ sed -e "s:-g -DDEBUG -DDEBUGJOURNAL:${CFLAGS}:" \
+ -i "${S}/pine/makefile.lnx" || die "sed pine/makefile.lnx failed"
+ sed -e "s:-g -DDEBUG:${CFLAGS}:" \
+ -i "${S}/pico/makefile.lnx" || die "sed pico/makefile.lnx failed"
+ fi
+
+ sed -e "s:/usr/local/lib/pine.conf:/etc/pine.conf:" \
+ -i "${S}/pine/osdep/os-lnx.h" || die "sed os-lnx.h failed"
+}
+
+src_compile() {
+ local myconf
+ if use ssl ; then
+ myconf="${myconf} SSLDIR=/usr SSLTYPE=unix SSLCERTS=/etc/ssl/certs"
+ sed -e "s:\$(SSLDIR)/certs:/etc/ssl/certs:" \
+ -e "s:\$(SSLCERTS):/etc/ssl/certs:" \
+ -e "s:-I\$(SSLINCLUDE) ::" \
+ -i "${S}/imap/src/osdep/unix/Makefile" || die "sed Makefile failed"
+ else
+ myconf="${myconf} NOSSL"
+ fi
+ if use ldap ; then
+ ./contrib/ldap-setup lnp lnp
+ myconf="${myconf} LDAPCFLAGS=-DENABLE_LDAP"
+ else
+ myconf="${myconf} NOLDAP"
+ fi
+ if use kerberos ; then
+ myconf="${myconf} EXTRAAUTHENTICATORS=gss"
+ fi
+
+ if use ppc-macos; then
+ target=osx
+ else
+ if use pam ; then
+ target=lnp
+ else
+ target=slx
+ fi
+ fi
+
+ ./build ${myconf} ${target} || die "compile problem"
+}
+
+src_install() {
+ dobin bin/pine bin/pico bin/pilot bin/rpdump bin/rpload
+
+ # Only mailbase should install /etc/mailcap
+# donewins doc/mailcap.unx mailcap
+
+ doman doc/pine.1 doc/pico.1 doc/pilot.1 doc/rpdump.1 doc/rpload.1
+ dodoc CPYRIGHT README doc/brochure.txt doc/tech-notes.txt
+# if use ipv6 ; then
+# dodoc "${DISTDIR}/readme.${P}-v6-20031001"
+# fi
+
+ docinto imap
+ dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
+
+ docinto imap/rfc
+ dodoc imap/docs/rfc/*.txt
+
+ docinto html/tech-notes
+ dohtml -r doc/tech-notes/
+}
+
+pkg_postinst() {
+ maildir_warn
+}
diff --git a/mail-client/pine/pine-4.64.ebuild b/mail-client/pine/pine-4.64.ebuild
index d3c0017c4445..425e3d4cf8c0 100644
--- a/mail-client/pine/pine-4.64.ebuild
+++ b/mail-client/pine/pine-4.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.64.ebuild,v 1.2 2005/09/29 23:08:29 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/pine/pine-4.64.ebuild,v 1.3 2005/10/08 23:07:44 ticho Exp $
inherit eutils
@@ -21,7 +21,7 @@ SRC_URI="ftp://ftp.cac.washington.edu/pine/${P/-/}.tar.bz2
LICENSE="PICO"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc-macos ~sparc x86"
IUSE="ssl ldap kerberos largeterminal pam passfile debug"
DEPEND="virtual/libc