summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-01-16 20:40:20 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-01-16 20:40:20 +0000
commit7b4d23e74a8bc5f49fbe180a5283e1d0d84ed1e2 (patch)
tree1454ddc8b3d8934f171bb0912b57a2a59b8faddd /mail-client
parentVersion bump; remove non-stable-candidate. (diff)
downloadgentoo-2-7b4d23e74a8bc5f49fbe180a5283e1d0d84ed1e2.tar.gz
gentoo-2-7b4d23e74a8bc5f49fbe180a5283e1d0d84ed1e2.tar.bz2
gentoo-2-7b4d23e74a8bc5f49fbe180a5283e1d0d84ed1e2.zip
Version bump. Bug #451328
(Portage version: 2.1.11.43/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/trojita/ChangeLog7
-rw-r--r--mail-client/trojita/trojita-0.3.91.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/mail-client/trojita/ChangeLog b/mail-client/trojita/ChangeLog
index 3e44a048cfd7..19722be2c833 100644
--- a/mail-client/trojita/ChangeLog
+++ b/mail-client/trojita/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/trojita
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/ChangeLog,v 1.18 2013/01/15 19:41:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/ChangeLog,v 1.19 2013/01/16 20:40:20 hwoarang Exp $
+
+*trojita-0.3.91 (16 Jan 2013)
+
+ 16 Jan 2013; Markos Chandras <hwoarang@gentoo.org> +trojita-0.3.91.ebuild:
+ Version bump. Bug #451328
15 Jan 2013; Markos Chandras <hwoarang@gentoo.org> trojita-9999.ebuild:
Update git repo. Add virtualx eclass for tests. Bug #451328. Thanks to Jan
diff --git a/mail-client/trojita/trojita-0.3.91.ebuild b/mail-client/trojita/trojita-0.3.91.ebuild
new file mode 100644
index 000000000000..4e9d2fc253ed
--- /dev/null
+++ b/mail-client/trojita/trojita-0.3.91.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/trojita/trojita-0.3.91.ebuild,v 1.1 2013/01/16 20:40:20 hwoarang Exp $
+
+EAPI=4
+
+QT_REQUIRED="4.6.0"
+EGIT_REPO_URI="git://gitorious.org/${PN}/${PN}.git"
+[[ ${PV} == "9999" ]] && GIT_ECLASS="git-2"
+inherit qt4-r2 ${GIT_ECLASS}
+
+DESCRIPTION="A Qt IMAP e-mail client"
+HOMEPAGE="http://trojita.flaska.net/"
+if [[ ${PV} == "9999" ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~x86"
+ MY_LANGS="bs cs de es et ga gl hu ia lt nl pt pt_BR sk sv uk zh_CN"
+fi
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+IUSE="debug test +zlib"
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+done
+
+RDEPEND="
+ >=x11-libs/qt-gui-${QT_REQUIRED}:4
+ >=x11-libs/qt-sql-${QT_REQUIRED}:4[sqlite]
+ >=x11-libs/qt-webkit-${QT_REQUIRED}:4
+"
+DEPEND="${RDEPEND}
+ test? ( >=x11-libs/qt-test-${QT_REQUIRED}:4 )
+ zlib? (
+ virtual/pkgconfig
+ sys-libs/zlib
+ )
+"
+
+src_configure() {
+ local myopts=""
+ use debug && myopts="$myopts CONFIG+=debug"
+ use test || myopts="$myopts CONFIG+=disable_tests"
+ use zlib || myopts="$myopts CONFIG+=disable_zlib"
+ if [[ ${MY_LANGS} ]]; then
+ rm po/trojita_common_x-test.po
+ for x in po/*.po; do
+ mylang=${x#po/trojita_common_}
+ mylang=${mylang%.po}
+ use linguas_$mylang || rm $x
+ done
+ fi
+
+ eqmake4 PREFIX=/usr $myopts
+}
+
+src_test() {
+ Xemake test
+}