summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2006-06-25 04:36:49 +0000
committerMarius Mauch <genone@gentoo.org>2006-06-25 04:36:49 +0000
commit97bfc1f4cb2ba4858a80992973ba73a39aaabc98 (patch)
tree5799393b6c9a2e0ca79f6d6a023bd906ef70d332 /mail-client
parentVersion bump (diff)
downloadgentoo-2-97bfc1f4cb2ba4858a80992973ba73a39aaabc98.tar.gz
gentoo-2-97bfc1f4cb2ba4858a80992973ba73a39aaabc98.tar.bz2
gentoo-2-97bfc1f4cb2ba4858a80992973ba73a39aaabc98.zip
Version bump
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed-claws/ChangeLog8
-rw-r--r--mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.13
-rw-r--r--mail-client/sylpheed-claws/sylpheed-claws-2.3.1.ebuild144
3 files changed, 154 insertions, 1 deletions
diff --git a/mail-client/sylpheed-claws/ChangeLog b/mail-client/sylpheed-claws/ChangeLog
index 7b42c9c789bc..283c0e6f81a8 100644
--- a/mail-client/sylpheed-claws/ChangeLog
+++ b/mail-client/sylpheed-claws/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-client/sylpheed-claws
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.99 2006/06/22 16:28:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/ChangeLog,v 1.100 2006/06/25 04:36:49 genone Exp $
+
+*sylpheed-claws-2.3.1 (25 Jun 2006)
+
+ 25 Jun 2006; Marius Mauch <genone@gentoo.org>
+ +sylpheed-claws-2.3.1.ebuild:
+ Version bump
22 Jun 2006; Chris Gianelloni <wolf31o2@gentoo.org>
sylpheed-claws-2.3.0.ebuild:
diff --git a/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.1 b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.1
new file mode 100644
index 000000000000..74c7c9ff3d5e
--- /dev/null
+++ b/mail-client/sylpheed-claws/files/digest-sylpheed-claws-2.3.1
@@ -0,0 +1,3 @@
+MD5 08e8fe1f3466d146b499d128f1445ba6 sylpheed-claws-2.3.1.tar.bz2 4432975
+RMD160 14743be45a22578ad54dba65ffb16d4066278033 sylpheed-claws-2.3.1.tar.bz2 4432975
+SHA256 8fc36593b7543083d51a2d30408ccd268b0e071784b69c472e31e7293676b4bf sylpheed-claws-2.3.1.tar.bz2 4432975
diff --git a/mail-client/sylpheed-claws/sylpheed-claws-2.3.1.ebuild b/mail-client/sylpheed-claws/sylpheed-claws-2.3.1.ebuild
new file mode 100644
index 000000000000..32100023912f
--- /dev/null
+++ b/mail-client/sylpheed-claws/sylpheed-claws-2.3.1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws/sylpheed-claws-2.3.1.ebuild,v 1.1 2006/06/25 04:36:49 genone Exp $
+
+IUSE="gnome dillo crypt spell ssl ldap ipv6 pda clamav xface kde imap spamassassin doc startup-notification"
+
+inherit eutils
+
+DESCRIPTION="Bleeding edge version of Sylpheed"
+HOMEPAGE="http://claws.sylpheed.org"
+
+if [ -n "${P/*_rc*/}" ]; then
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+else
+ MY_P="${P/_/-}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="http://claws.sylpheed.org/snapshots/${MY_P}.tar.bz2"
+fi
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+COMMONDEPEND=">=x11-libs/gtk+-2.4
+ pda? ( >=app-pda/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.7 )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.4 )
+ dillo? ( www-client/dillo )
+ spell? ( virtual/aspell-dict )
+ clamav? ( app-antivirus/clamav )
+ kde? ( kde-base/kdelibs )
+ imap? ( >=net-libs/libetpan-0.45 )
+ gnome? ( >=gnome-base/libgnomeprintui-2.2 )
+ startup-notification? ( x11-libs/startup-notification )
+ !mail-client/sylpheed-claws-pgpinline" # included in the main package now
+
+DEPEND="${COMMONDEPEND}
+ xface? ( >=media-libs/compface-1.4 )
+ >=sys-apps/sed-4"
+
+RDEPEND="${COMMONDEPEND}
+ app-misc/mime-types
+ net-mail/metamail
+ x11-misc/shared-mime-info"
+
+PROVIDE="virtual/sylpheed"
+
+PLUGIN_NAMES="acpi-notifier att-remover cachesaver etpan-privacy fetchinfo gtkhtml maildir mailmbox newmail notification perl rssyl smime synce vcalendar"
+
+src_compile() {
+ local myconf
+
+ # Optional features
+ myconf="${myconf} `use_enable gnome gnomeprint`"
+ myconf="${myconf} `use_enable imap libetpan`"
+ myconf="${myconf} `use_enable ipv6`"
+ myconf="${myconf} `use_enable ldap`"
+ myconf="${myconf} `use_enable pda jpilot`"
+ myconf="${myconf} `use_enable spell aspell`"
+ myconf="${myconf} `use_enable ssl openssl`"
+ myconf="${myconf} `use_enable xface compface`"
+ myconf="${myconf} `use_enable doc manual`"
+ myconf="${myconf} `use_enable startup-notification`"
+
+ # Optional plugins
+ myconf="${myconf} `use_enable clamav clamav-plugin`"
+ myconf="${myconf} `use_enable crypt pgpmime-plugin`"
+ myconf="${myconf} `use_enable crypt pgpinline-plugin`"
+ myconf="${myconf} `use_enable crypt pgpcore-plugin`"
+ myconf="${myconf} `use_enable dillo dillo-viewer-plugin`"
+ myconf="${myconf} `use_enable spamassassin spamassassin-plugin`"
+
+ econf \
+ --enable-trayicon-plugin \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ if [ -d ${D}/usr/share/gnome ]; then
+ dodir /usr/share/applications
+ mv ${D}/usr/share/{gnome/apps/Internet,applications}/sylpheed-claws.desktop
+ rm -rf ${D}/usr/share/gnome
+ fi
+
+ # Makefile install sylpheed-claws.png in /usr/share/icons/hicolor/48x48/apps
+ # => also install it in /usr/share/pixmaps for other desktop envs
+ # => also install higher resolution icons in /usr/share/icons/hicolor/...
+ insinto /usr/share/pixmaps
+ doins sylpheed-claws.png
+ local res resdir
+ for res in 64x64 128x128 ; do
+ resdir="/usr/share/icons/hicolor/${res}/apps"
+ insinto ${resdir}
+ newins sylpheed-claws-${res}.png sylpheed-claws.png
+ done
+
+ dodoc AUTHORS ChangeLog* INSTALL* NEWS README* TODO*
+ docinto tools
+ dodoc tools/README*
+
+ # install the extra tools
+ cd ${S}/tools
+ exeinto /usr/lib/${PN}/tools
+ doexe *.pl *.py *.rc *.conf *.sh
+ doexe tb2sylpheed update-po uudec
+
+ if use kde; then
+ local kdeprefix="$(kde-config --prefix)"
+ local servicescript="sylpheed-kdeservicemenu.pl"
+ cd ${S}/tools/kdeservicemenu
+ for f in sylpheed-attach-files.desktop sylpheed-compress-attach.desktop; do
+ sed -e "s:SCRIPT_PATH:${kdeprefix}/bin/${servicescript}:g" template_$f > $f
+ install -m 0644 $f ${D}/${kdeprefix}/share/apps/konqueror/servicemenus/$f
+ done
+ insinto ${kdeprefix}/bin
+ doexe ${servicescript}
+ fi
+
+ # kill useless plugin files
+ rm -f ${D}/usr/lib*/${PN}/plugins/*.{la,a}
+}
+
+pkg_postinst() {
+ UPDATE_PLUGINS=""
+ for x in ${PLUGIN_NAMES}; do
+ has_version mail-client/sylpheed-claws-$x && UPDATE_PLUGINS="${UPDATE_PLUGINS} $x"
+ done
+ if [ -n "${UPDATE_PLUGINS}" ]; then
+ ewarn
+ ewarn "You have to re-emerge or update the following plugins:"
+ ewarn
+ for x in ${UPDATE_PLUGINS}; do
+ ewarn " mail-client/sylpheed-claws-$x"
+ done
+ ewarn
+ epause 5
+ ebeep 3
+ fi
+}