summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2011-11-03 07:40:36 +0000
committerAkinori Hattori <hattya@gentoo.org>2011-11-03 07:40:36 +0000
commita7bf36f39b7fd5c97501e880f7e132fc29cf1678 (patch)
treef3f9025c5e54481e0fd7ff9055e8ec70247e898a /mail-client
parentVersion Bump, #389389; thanks Tim Harder for the updated ebuild (diff)
downloadgentoo-2-a7bf36f39b7fd5c97501e880f7e132fc29cf1678.tar.gz
gentoo-2-a7bf36f39b7fd5c97501e880f7e132fc29cf1678.tar.bz2
gentoo-2-a7bf36f39b7fd5c97501e880f7e132fc29cf1678.zip
new upstream release. fixes bug #382229.
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed/ChangeLog7
-rw-r--r--mail-client/sylpheed/sylpheed-3.1.2.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/mail-client/sylpheed/ChangeLog b/mail-client/sylpheed/ChangeLog
index b4552664c0ab..06d5fa48e47f 100644
--- a/mail-client/sylpheed/ChangeLog
+++ b/mail-client/sylpheed/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-client/sylpheed
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.294 2011/11/03 07:07:23 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/ChangeLog,v 1.295 2011/11/03 07:40:36 hattya Exp $
+
+*sylpheed-3.1.2 (03 Nov 2011)
+
+ 03 Nov 2011; Akinori Hattori <hattya@gentoo.org> +sylpheed-3.1.2.ebuild:
+ new upstream release. fixes bug #382229.
03 Nov 2011; Akinori Hattori <hattya@gentoo.org> sylpheed-3.1.1.ebuild:
remove dev-libs/dbus-glib from (R)DEPEND.
diff --git a/mail-client/sylpheed/sylpheed-3.1.2.ebuild b/mail-client/sylpheed/sylpheed-3.1.2.ebuild
new file mode 100644
index 000000000000..cd5299265f0d
--- /dev/null
+++ b/mail-client/sylpheed/sylpheed-3.1.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed/sylpheed-3.1.2.ebuild,v 1.1 2011/11/03 07:40:36 hattya Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="A lightweight email client and newsreader"
+HOMEPAGE="http://sylpheed.sraoss.jp/"
+SRC_URI="http://sylpheed.sraoss.jp/${PN}/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="crypt ipv6 ldap nls oniguruma pda spell ssl xface"
+
+CDEPEND="x11-libs/gtk+:2
+ nls? ( sys-devel/gettext )
+ crypt? ( app-crypt/gpgme )
+ ldap? ( net-nds/openldap )
+ oniguruma? ( dev-libs/oniguruma )
+ pda? ( app-pda/jpilot )
+ spell? ( app-text/gtkspell:2 )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${CDEPEND}
+ app-misc/mime-types
+ net-misc/curl"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ xface? ( media-libs/compface )"
+
+src_configure() {
+ local htmldir=/usr/share/doc/${PF}/html
+ econf \
+ $(use_enable crypt gpgme) \
+ $(use_enable ipv6) \
+ $(use_enable ldap) \
+ $(use_enable oniguruma) \
+ $(use_enable pda jpilot) \
+ $(use_enable spell gtkspell) \
+ $(use_enable ssl) \
+ $(use_enable xface compface) \
+ --with-manualdir=${htmldir}/manual \
+ --with-faqdir=${htmldir}/faq \
+ --disable-updatecheck
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* NEWS* README* TODO*
+
+ doicon *.png
+ domenu *.desktop
+}