summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2005-07-09 00:23:45 +0000
committerMarius Mauch <genone@gentoo.org>2005-07-09 00:23:45 +0000
commitb31d5db0a15dd6857a31752d7b4127475d8c44c3 (patch)
tree626e40ef3ab3a608fdc14de7a3c0afd1aede8f10 /mail-client
parentWe can use virtual/glut here, no need to get tied into media-libs/glut. (diff)
downloadgentoo-2-b31d5db0a15dd6857a31752d7b4127475d8c44c3.tar.gz
gentoo-2-b31d5db0a15dd6857a31752d7b4127475d8c44c3.tar.bz2
gentoo-2-b31d5db0a15dd6857a31752d7b4127475d8c44c3.zip
small header fix
(Portage version: 1.589-cvs)
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/sylpheed-claws-pgpinline/ChangeLog6
-rw-r--r--mail-client/sylpheed-claws-pgpinline/files/glib2-buildfix.patch18
-rw-r--r--mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild13
3 files changed, 34 insertions, 3 deletions
diff --git a/mail-client/sylpheed-claws-pgpinline/ChangeLog b/mail-client/sylpheed-claws-pgpinline/ChangeLog
index 80eb7a4cba1f..054244c6ec2b 100644
--- a/mail-client/sylpheed-claws-pgpinline/ChangeLog
+++ b/mail-client/sylpheed-claws-pgpinline/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for mail-client/sylpheed-claws-pgpinline
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-pgpinline/ChangeLog,v 1.15 2005/06/05 19:16:23 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-pgpinline/ChangeLog,v 1.16 2005/07/09 00:23:45 genone Exp $
+
+ 09 Jul 2005; Marius Mauch <genone@gentoo.org> +files/glib2-buildfix.patch,
+ sylpheed-claws-pgpinline-0.5-r1.ebuild:
+ Adding patch to reflect changed headers in recent sylpheed-claws releases.
05 Jun 2005; Marius Mauch <genone@gentoo.org>
sylpheed-claws-pgpinline-0.5-r1.ebuild:
diff --git a/mail-client/sylpheed-claws-pgpinline/files/glib2-buildfix.patch b/mail-client/sylpheed-claws-pgpinline/files/glib2-buildfix.patch
new file mode 100644
index 000000000000..18258547ea63
--- /dev/null
+++ b/mail-client/sylpheed-claws-pgpinline/files/glib2-buildfix.patch
@@ -0,0 +1,18 @@
+Index: src/plugin.c
+===================================================================
+RCS file: /cvsroot/sylpheed-claws/plugins/pgpinline/src/plugin.c,v
+retrieving revision 1.1.2.4
+retrieving revision 1.1.2.6
+diff -u -r1.1.2.4 -r1.1.2.6
+--- src/plugin.c 7 Nov 2004 10:20:39 -0000 1.1.2.4
++++ src/plugin.c 18 Feb 2005 16:14:53 -0000 1.1.2.6
+@@ -23,7 +23,8 @@
+
+ #include <stddef.h>
+
+-#include "intl.h"
++#include <glib.h>
++#include <glib/gi18n.h>
+
+ #include "version.h"
+ #include "pgpinline.h"
diff --git a/mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild b/mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild
index 424f23f3c1cb..5ed74f74240f 100644
--- a/mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild
+++ b/mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild,v 1.3 2005/06/05 19:16:23 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/sylpheed-claws-pgpinline/sylpheed-claws-pgpinline-0.5-r1.ebuild,v 1.4 2005/07/09 00:23:45 genone Exp $
+
+inherit eutils
MY_P="${P##sylpheed-claws-}"
@@ -11,11 +13,18 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha ~ppc64"
IUSE=""
-DEPEND=">=mail-client/sylpheed-claws-1.9
+DEPEND=">=mail-client/sylpheed-claws-1.9.12
=app-crypt/gpgme-0.3.14-r1"
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/glib2-buildfix.patch
+}
+
src_compile() {
export GPGME_CONFIG=${ROOT}/usr/bin/gpgme3-config