summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-11-08 10:13:51 +0000
committerTorsten Veller <tove@gentoo.org>2006-11-08 10:13:51 +0000
commit7f5c2302e0f61fc471f16f130e487c0635188c29 (patch)
tree5f57aebb86bb5a94fc257bc316441a805ed69496 /mail-filter/bogofilter
parentRemove obsolete version. Fix improper processing of the command line argument... (diff)
downloadgentoo-2-7f5c2302e0f61fc471f16f130e487c0635188c29.tar.gz
gentoo-2-7f5c2302e0f61fc471f16f130e487c0635188c29.tar.bz2
gentoo-2-7f5c2302e0f61fc471f16f130e487c0635188c29.zip
Bump to address bug #153939.
(Portage version: 2.1.2_rc1-r5)
Diffstat (limited to 'mail-filter/bogofilter')
-rw-r--r--mail-filter/bogofilter/ChangeLog8
-rw-r--r--mail-filter/bogofilter/bogofilter-1.1.1-r1.ebuild76
-rw-r--r--mail-filter/bogofilter/files/1.1.1-patch.1107.lexer_v3_l26
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-1.1.1-r13
4 files changed, 112 insertions, 1 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index 03373405f48f..9753a9a31793 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.67 2006/11/04 22:40:54 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.68 2006/11/08 10:13:51 tove Exp $
+
+*bogofilter-1.1.1-r1 (08 Nov 2006)
+
+ 08 Nov 2006; Torsten Veller <tove@gentoo.org>
+ +files/1.1.1-patch.1107.lexer_v3_l, +bogofilter-1.1.1-r1.ebuild:
+ Bump to address bug #153939.
04 Nov 2006; Alexander H. Færøy <eroyf@gentoo.org>
bogofilter-1.1.1.ebuild:
diff --git a/mail-filter/bogofilter/bogofilter-1.1.1-r1.ebuild b/mail-filter/bogofilter/bogofilter-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..355980e9c7e3
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-1.1.1-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-1.1.1-r1.ebuild,v 1.1 2006/11/08 10:13:51 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gsl berkdb sqlite"
+
+DEPEND="virtual/libiconv
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-patch.1107.lexer_v3_l
+}
+
+src_compile() {
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif use sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! use berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,parmtest,randomtrain}.sh \
+ contrib/{bfproxy,bogominitrain,mime.get.rfc822,printmaildir}.pl \
+ contrib/{spamitarium,stripsearch}.pl || die "doexec failed"
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,bogofilter-milter.pl,*.example} \
+ contrib/vm-bogofilter.el \
+ contrib/{trainbogo,scramble}.sh || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED \
+ doc/integrating-with-* doc/README.{db,sqlite} || die "dodoc failed"
+
+ dohtml doc/*.html
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/bogofilter.cf.example "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+}
+
+pkg_postinst() {
+ echo
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ echo
+}
diff --git a/mail-filter/bogofilter/files/1.1.1-patch.1107.lexer_v3_l b/mail-filter/bogofilter/files/1.1.1-patch.1107.lexer_v3_l
new file mode 100644
index 000000000000..d48c07df5d3f
--- /dev/null
+++ b/mail-filter/bogofilter/files/1.1.1-patch.1107.lexer_v3_l
@@ -0,0 +1,26 @@
+--- 111/src/lexer_v3.l 2006-07-03 23:47:37.000000000 -0400
++++ cvs/src/lexer_v3.l 2006-11-06 19:04:06.000000000 -0500
+@@ -1,4 +1,4 @@
+-/* $Id: 1.1.1-patch.1107.lexer_v3_l,v 1.1 2006/11/08 10:13:51 tove Exp $ */
++/* $Id: 1.1.1-patch.1107.lexer_v3_l,v 1.1 2006/11/08 10:13:51 tove Exp $ */
+
+ %{
+ /*
+@@ -137,7 +137,7 @@
+ BCHARS [[:alnum:]()+_,-./:=?#\' ]
+ MIME_BOUNDARY {BCHARS}*{BCHARSNOSPC}
+
+-ID <?[[:alnum:]\-\.]*>?
++ID <?[[:alnum:]\-\.]+>?
+ CHARSET [[:alnum:]-]+
+ VERPID [[:alnum:]#-]+[[:digit:]]+[[:alnum:]#-]+
+ MTYPE [[:blank:]]*[[:alnum:]/-]*
+@@ -252,7 +252,7 @@
+ <INITIAL>charset=\"?{CHARSET}\"? { got_charset(yytext); skip_to('='); return TOKEN; }
+
+ <INITIAL>(file)?name=\"? /* ignore */
+-<INITIAL>\n?[[:blank:]]id\ {ID} { return QUEUE_ID; }
++<INITIAL>\n?[[:blank:]]id{WHITESPACE}+{ID} { return QUEUE_ID; }
+
+ <INITIAL>\n[[:blank:]] { lineno += 1; }
+ <INITIAL>\n\n { enum mimetype type = get_content_type();
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-1.1.1-r1 b/mail-filter/bogofilter/files/digest-bogofilter-1.1.1-r1
new file mode 100644
index 000000000000..424c90ed7043
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-1.1.1-r1
@@ -0,0 +1,3 @@
+MD5 e7f236002daf22d732cad0433adac2ff bogofilter-1.1.1.tar.bz2 790929
+RMD160 0510317b5cac1197dc99e837b0fc67471422c9d3 bogofilter-1.1.1.tar.bz2 790929
+SHA256 98684dd687139af5c04ed73c3c64016f7ec9e951da8d435d9666a9a036099fa5 bogofilter-1.1.1.tar.bz2 790929