summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2014-09-02 08:47:19 +0000
committerFabian Groffen <grobian@gentoo.org>2014-09-02 08:47:19 +0000
commit45d35c3b06d76894a8f46f1b12fcca69dec6897a (patch)
tree79dbff0e72722129cdd439235b4ad852f7683382 /mail-filter/opendmarc
parentversion bump (diff)
downloadgentoo-2-45d35c3b06d76894a8f46f1b12fcca69dec6897a.tar.gz
gentoo-2-45d35c3b06d76894a8f46f1b12fcca69dec6897a.tar.bz2
gentoo-2-45d35c3b06d76894a8f46f1b12fcca69dec6897a.zip
Version bump to 1.3.0
(Portage version: 2.2.10.1-prefix/cvs/SunOS i386, signed Manifest commit with key 0x5F75F607C5C74E89)
Diffstat (limited to 'mail-filter/opendmarc')
-rw-r--r--mail-filter/opendmarc/ChangeLog7
-rw-r--r--mail-filter/opendmarc/opendmarc-1.3.0.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/mail-filter/opendmarc/ChangeLog b/mail-filter/opendmarc/ChangeLog
index df2576620392..4a8bc3dee3f8 100644
--- a/mail-filter/opendmarc/ChangeLog
+++ b/mail-filter/opendmarc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/opendmarc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendmarc/ChangeLog,v 1.10 2014/07/25 21:43:31 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendmarc/ChangeLog,v 1.11 2014/09/02 08:47:19 grobian Exp $
+
+*opendmarc-1.3.0 (02 Sep 2014)
+
+ 02 Sep 2014; Fabian Groffen <grobian@gentoo.org> +opendmarc-1.3.0.ebuild:
+ Version bump to 1.3.0
25 Jul 2014; Andreas K. Huettel <dilfridge@gentoo.org>
opendmarc-1.1.3.ebuild, opendmarc-1.2.0.ebuild:
diff --git a/mail-filter/opendmarc/opendmarc-1.3.0.ebuild b/mail-filter/opendmarc/opendmarc-1.3.0.ebuild
new file mode 100644
index 000000000000..a253826cc13f
--- /dev/null
+++ b/mail-filter/opendmarc/opendmarc-1.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/opendmarc/opendmarc-1.3.0.ebuild,v 1.1 2014/09/02 08:47:19 grobian Exp $
+
+EAPI=5
+
+inherit user
+
+DESCRIPTION="Open source DMARC implementation "
+HOMEPAGE="http://www.trusteddomain.org/opendmarc/"
+SRC_URI="mirror://sourceforge/opendmarc/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-perl/DBI
+ || ( mail-filter/libmilter mail-mta/sendmail )"
+RDEPEND="${DEPEND}
+ dev-perl/Switch"
+
+pkg_setup() {
+ enewgroup milter
+ enewuser milter -1 -1 /var/lib/milter milter
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/opendmarc.initd opendmarc
+ newconfd "${FILESDIR}"/opendmarc.confd opendmarc
+
+ dodir /etc/opendmarc
+ dodir /var/run/opendmarc
+ fowners milter:milter /var/run/opendmarc
+
+ # create config file
+ sed \
+ -e 's/^# UserID .*$/UserID milter/' \
+ -e 's/^# PidFile .*/PidFile \/var\/run\/opendmarc\/opendmarc.pid/' \
+ -e '/^# Socket /s/^# //' \
+ "${S}"/opendmarc/opendmarc.conf.sample \
+ > "${ED}"/etc/opendmarc/opendmarc.conf \
+ || die
+}