summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2005-09-25 18:49:12 +0000
committerTorsten Veller <tove@gentoo.org>2005-09-25 18:49:12 +0000
commitee536fbcbafe7659ad0fd8338b70486518c604af (patch)
tree765aa80aa5f30906dadcbb25bdb9fbb88c30f8d5 /mail-filter
parentAdded ~ppc64 (diff)
downloadgentoo-2-ee536fbcbafe7659ad0fd8338b70486518c604af.tar.gz
gentoo-2-ee536fbcbafe7659ad0fd8338b70486518c604af.tar.bz2
gentoo-2-ee536fbcbafe7659ad0fd8338b70486518c604af.zip
Latest version added.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'mail-filter')
-rw-r--r--mail-filter/bogofilter/ChangeLog7
-rw-r--r--mail-filter/bogofilter/Manifest10
-rw-r--r--mail-filter/bogofilter/bogofilter-0.96.2.ebuild85
-rw-r--r--mail-filter/bogofilter/files/digest-bogofilter-0.96.21
4 files changed, 98 insertions, 5 deletions
diff --git a/mail-filter/bogofilter/ChangeLog b/mail-filter/bogofilter/ChangeLog
index cba9c215cddc..0b63769dbff3 100644
--- a/mail-filter/bogofilter/ChangeLog
+++ b/mail-filter/bogofilter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for mail-filter/bogofilter
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.39 2005/09/13 15:49:29 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/ChangeLog,v 1.40 2005/09/25 18:49:12 tove Exp $
+
+*bogofilter-0.96.2 (25 Sep 2005)
+
+ 25 Sep 2005; Torsten Veller <tove@gentoo.org> +bogofilter-0.96.2.ebuild:
+ New version.
13 Sep 2005; Aron Griffis <agriffis@gentoo.org> bogofilter-0.92.8.ebuild:
Mark 0.92.8 stable on alpha
diff --git a/mail-filter/bogofilter/Manifest b/mail-filter/bogofilter/Manifest
index b1b4ab1db298..e3b44747879d 100644
--- a/mail-filter/bogofilter/Manifest
+++ b/mail-filter/bogofilter/Manifest
@@ -1,8 +1,10 @@
-MD5 5c37618a8b15dd2b250f78aaa0d20a54 bogofilter-0.95.2.ebuild 2482
-MD5 48bd0f185b30f8151e8da04a025e0373 metadata.xml 424
+MD5 ce98014bfca6cf1cac1c8322041a74c6 bogofilter-0.96.2.ebuild 2468
MD5 e4bfdf5d18231412651867d6506c9d53 bogofilter-0.94.14.ebuild 2446
-MD5 ce54b5404daf171a44c97e883d2a90b2 ChangeLog 12639
MD5 28717e3faee82dbca88d83de9c9afadc bogofilter-0.92.8.ebuild 1575
+MD5 590709fe3ae68525c5c0f9962dd8428c ChangeLog 12764
+MD5 48bd0f185b30f8151e8da04a025e0373 metadata.xml 424
+MD5 5c37618a8b15dd2b250f78aaa0d20a54 bogofilter-0.95.2.ebuild 2482
+MD5 5d294556f965d8a34f818dd691028d3a files/digest-bogofilter-0.94.14 71
MD5 1970df6e6d8dabe53d04a6f120d0b8bb files/digest-bogofilter-0.92.8 70
MD5 36abbe0564d3ec8d59dabd4c15f21f25 files/digest-bogofilter-0.95.2 70
-MD5 5d294556f965d8a34f818dd691028d3a files/digest-bogofilter-0.94.14 71
+MD5 596ada68a40992a781a00a8d84f5ca9d files/digest-bogofilter-0.96.2 70
diff --git a/mail-filter/bogofilter/bogofilter-0.96.2.ebuild b/mail-filter/bogofilter/bogofilter-0.96.2.ebuild
new file mode 100644
index 000000000000..395e9cf34e51
--- /dev/null
+++ b/mail-filter/bogofilter/bogofilter-0.96.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-filter/bogofilter/bogofilter-0.96.2.ebuild,v 1.1 2005/09/25 18:49:12 tove Exp $
+
+inherit eutils
+
+DESCRIPTION="Bayesian spam filter designed with fast algorithms, and tuned for speed."
+HOMEPAGE="http://bogofilter.sourceforge.net/"
+SRC_URI="mirror://sourceforge/bogofilter/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+#KEYWORDS="${KEYWORDS} ~arm ~mips" # missing, see bug #74046
+IUSE="doc gsl berkdb sqlite"
+
+DEPEND="
+ || ( sys-libs/glibc dev-libs/libiconv )
+ berkdb? ( >=sys-libs/db-3.2 )
+ !berkdb? (
+ sqlite? ( >=dev-db/sqlite-3.2.6 )
+ !sqlite? ( >=sys-libs/db-3.2 ) )
+ gsl? ( sci-libs/gsl )"
+# app-arch/pax" # only needed for bf_tar
+
+pkg_setup() {
+ einfo ""
+ einfo "Better safe than sorry:"
+ einfo "It is best to dump or backup your wordlists BEFORE upgrading!"
+ einfo ""
+ epause
+}
+
+src_compile() {
+ local myconf=""
+ myconf="$(use_with !gsl included-gsl)"
+
+ # determine backend: berkdb *is* default
+ if use berkdb && use sqlite ; then
+ einfo "Both berkdb and sqlite are in USE."
+ einfo "Choosing berkdb as default database backend."
+ elif useq sqlite ; then
+ myconf="${myconf} --with-database=sqlite"
+ elif ! useq berkdb ; then
+ einfo "Using berkdb as database backend."
+ fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed."
+
+ exeinto /usr/share/${PN}/contrib
+ doexe contrib/{bogofilter-qfe,bogogrep,mime.get.rfc822} \
+ contrib/{parmtest.sh,randomtrain,scramble,*.pl} || die "doexe failed."
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/{README.*,dot-qmail-bogofilter-default} \
+ contrib/{bogogrep.c,bogo.R,trainbogo.sh,*.example} || die "doins failed"
+
+ dodoc AUTHORS NEWS README RELEASE.NOTES* TODO GETTING.STARTED
+ dodoc doc/integrating-with-* doc/README.{db,sqlite}
+
+ dodir /usr/share/doc/${PF}/samples
+ mv "${D}"/etc/* "${D}"/usr/share/doc/${PF}/samples/
+ rmdir "${D}"/etc
+
+ if use doc; then
+ dohtml doc/*.html
+ else
+ dohtml doc/bogofilter-faq{,-fr}.html doc/bogofilter-tuning.HOWTO.html
+ fi
+}
+
+pkg_postinst() {
+ ewarn ""
+ ewarn "Incompatible changes in bogofilter-0.93 and -0.94:"
+ ewarn "Please read the documentation (RELEASE.NOTES)!"
+ ewarn ""
+ einfo ""
+ einfo "If you need ${ROOT}usr/bin/bf_tar please install app-arch/pax."
+ einfo ""
+}
diff --git a/mail-filter/bogofilter/files/digest-bogofilter-0.96.2 b/mail-filter/bogofilter/files/digest-bogofilter-0.96.2
new file mode 100644
index 000000000000..8b5f0fca5335
--- /dev/null
+++ b/mail-filter/bogofilter/files/digest-bogofilter-0.96.2
@@ -0,0 +1 @@
+MD5 30b66f7cf0abfb3dbd51ad07894e3505 bogofilter-0.96.2.tar.bz2 722557