summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-04-07 06:27:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-04-07 06:27:49 +0000
commit69b437013e8e706759c98f1a09382e762247e6f1 (patch)
treeb3a4ccee14830344edbc8b9082b01df58126f39d /mail-mta/msmtp
parentVersion bump (diff)
downloadgentoo-2-69b437013e8e706759c98f1a09382e762247e6f1.tar.gz
gentoo-2-69b437013e8e706759c98f1a09382e762247e6f1.tar.bz2
gentoo-2-69b437013e8e706759c98f1a09382e762247e6f1.zip
msmtp is extremely useful as a custom relaying tool for users despite the system MTA, to provide an option to disable acting as virtual/mta.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta/msmtp')
-rw-r--r--mail-mta/msmtp/ChangeLog9
-rw-r--r--mail-mta/msmtp/metadata.xml3
-rw-r--r--mail-mta/msmtp/msmtp-1.4.19-r1.ebuild112
3 files changed, 123 insertions, 1 deletions
diff --git a/mail-mta/msmtp/ChangeLog b/mail-mta/msmtp/ChangeLog
index 6c8bea78297c..6a73da834e8f 100644
--- a/mail-mta/msmtp/ChangeLog
+++ b/mail-mta/msmtp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/msmtp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/ChangeLog,v 1.78 2010/04/06 18:31:39 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/ChangeLog,v 1.79 2010/04/07 06:27:49 robbat2 Exp $
+
+*msmtp-1.4.19-r1 (07 Apr 2010)
+
+ 07 Apr 2010; Robin H. Johnson <robbat2@gentoo.org>
+ +msmtp-1.4.19-r1.ebuild, metadata.xml:
+ msmtp is extremely useful as a custom relaying tool for users despite the
+ system MTA, to provide an option to disable acting as virtual/mta.
06 Apr 2010; Brent Baude <ranger@gentoo.org> msmtp-1.4.19.ebuild:
Marking msmtp-1.4.19 ppc64 for bug 293647
diff --git a/mail-mta/msmtp/metadata.xml b/mail-mta/msmtp/metadata.xml
index 51f94e3fbe0e..859da605928a 100644
--- a/mail-mta/msmtp/metadata.xml
+++ b/mail-mta/msmtp/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>net-mail</herd>
+<use>
+ <flag name='mta'>Enable this to install as system-wide MTA</flag>
+</use>
</pkgmetadata>
diff --git a/mail-mta/msmtp/msmtp-1.4.19-r1.ebuild b/mail-mta/msmtp/msmtp-1.4.19-r1.ebuild
new file mode 100644
index 000000000000..fd01d4d4dc26
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.4.19-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/msmtp/msmtp-1.4.19-r1.ebuild,v 1.1 2010/04/07 06:27:49 robbat2 Exp $
+
+EAPI=2
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="http://msmtp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/msmtp/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc gnome-keyring gnutls idn mailwrapper nls sasl ssl +mta"
+
+DEPEND="idn? ( net-dns/libidn )
+ nls? ( virtual/libintl )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ !gnutls? ( ssl? ( >=dev-libs/openssl-0.9.6 ) )
+ sasl? ( >=virtual/gsasl-0.2.4 )"
+
+RDEPEND="${DEPEND}
+ mta? (
+ !mailwrapper? ( !virtual/mta )
+ mailwrapper? ( >=net-mail/mailwrapper-0.2 )
+ )"
+
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+PROVIDE="mta? ( virtual/mta )"
+
+src_configure () {
+ local myconf
+
+ if use gnutls ; then
+ myconf="--with-ssl=gnutls"
+ elif use ssl ; then
+ myconf="--with-ssl=openssl"
+ else
+ myconf="--with-ssl=no"
+ fi
+
+ econf \
+ $(use_with idn libidn) \
+ $(use_with sasl libgsasl) \
+ $(use_with gnome-keyring ) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ if use mta; then
+ if use mailwrapper ; then
+ insinto /etc/mail
+ doins "${FILESDIR}"/mailer.conf
+ else
+ dodir /usr/sbin
+ dosym /usr/bin/msmtp /usr/sbin/sendmail || die "dosym failed"
+ fi
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS \
+ doc/{Mutt+msmtp.txt,msmtprc*} || die "dodoc failed"
+
+ if use doc ; then
+ dohtml doc/msmtp.html || die "dohtml failed"
+ dodoc doc/msmtp.pdf
+ fi
+
+ #d=msmtpqueue
+ #local msmtpqueue=/usr/share/${PN}/$d
+ #insinto ${msmtpqueue}
+ #exeinto ${msmtpqueue}
+ #doexe scripts/msmtpqueue/*.sh || die "doexe failed"
+ #for i in ChangeLog README ; do
+ # newdoc scripts/msmtpqueue/$i msmtpqueue.$i \
+ # || die "dodoc scripts/msmtpqueue/$i failed"
+ #done
+
+ #d=msmtpq
+ #local msmtpq=/usr/share/${PN}/$d
+ #insinto ${msmtpqueue}
+ #exeinto ${msmtpqueue}
+ #i=README
+ #newdoc scripts/$d/$i $d.$i \
+ # || die "dodoc scripts/$d/$i failed"
+
+ src_install_contrib msmtpqueue "*.sh" "README ChangeLog"
+ src_install_contrib msmtpq "msmtpq msmtpQ" "README"
+
+}
+
+src_install_contrib() {
+ subdir="$1"
+ bins="$2"
+ docs="$3"
+ local dir=/usr/share/${PN}/$subdir
+ insinto ${dir}
+ exeinto ${dir}
+ for i in $bins ; do
+ doexe scripts/$subdir/$i || die "doexe $subdir/$i failed"
+ done
+ for i in $docs ; do
+ newdoc scripts/$subdir/$i $subdir.$i \
+ || die "dodoc $subdir/$i failed"
+ done
+}