summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-07-08 16:42:16 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-07-08 16:42:16 +0000
commit7f2fa32c72ddf40e5e094312c24b9d07043f0bd4 (patch)
tree2ba314d0e743eb98aa5fc139cee7866eb578cde1 /mail-mta/nbsmtp
parentVersion bumped. Added prelink USE flag. (diff)
downloadgentoo-2-7f2fa32c72ddf40e5e094312c24b9d07043f0bd4.tar.gz
gentoo-2-7f2fa32c72ddf40e5e094312c24b9d07043f0bd4.tar.bz2
gentoo-2-7f2fa32c72ddf40e5e094312c24b9d07043f0bd4.zip
Respect CC/LDFLAGS. Thanks to Kevin Pyle. Fixes bug #244152
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'mail-mta/nbsmtp')
-rw-r--r--mail-mta/nbsmtp/ChangeLog7
-rw-r--r--mail-mta/nbsmtp/nbsmtp-1.00-r3.ebuild53
2 files changed, 58 insertions, 2 deletions
diff --git a/mail-mta/nbsmtp/ChangeLog b/mail-mta/nbsmtp/ChangeLog
index 0206b96313c0..f0a3bdb20d84 100644
--- a/mail-mta/nbsmtp/ChangeLog
+++ b/mail-mta/nbsmtp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for mail-mta/nbsmtp
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/nbsmtp/ChangeLog,v 1.44 2009/09/23 18:06:28 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nbsmtp/ChangeLog,v 1.45 2010/07/08 16:42:16 hwoarang Exp $
+
+ 08 Jul 2010; Markos Chandras <hwoarang@gentoo.org> +nbsmtp-1.00-r3.ebuild:
+ Respect CC/LDFLAGS. Thanks to Kevin Pyle. Fixes bug #244152
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> nbsmtp-1.00.ebuild,
nbsmtp-1.00-r2.ebuild:
diff --git a/mail-mta/nbsmtp/nbsmtp-1.00-r3.ebuild b/mail-mta/nbsmtp/nbsmtp-1.00-r3.ebuild
new file mode 100644
index 000000000000..821666770c91
--- /dev/null
+++ b/mail-mta/nbsmtp/nbsmtp-1.00-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/nbsmtp/nbsmtp-1.00-r3.ebuild,v 1.5 2010/07/08 16:42:16 hwoarang Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a relayhost"
+SRC_URI="http://www.gentoo-es.org/~ferdy/${P}.tar.bz2"
+HOMEPAGE="http://nbsmtp.ferdyx.org"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="ssl ipv6 debug"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ !virtual/mta"
+
+PROVIDE="virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-openssl.patch
+ sed -i \
+ -e '/CFLAGS=/a\LDLIBS=@LIBS@' \
+ -e '/$(CC) -o/d' \
+ Makefile.in || die 'Failed to sed Makefile.in'
+}
+
+src_compile() {
+ tc-export CC
+ econf $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable ipv6) || die
+
+ emake || die
+}
+
+src_install() {
+ dodir /usr/{{s,}bin,lib}
+ dobin nbsmtp
+ dobin scripts/nbqueue
+ dobin scripts/wrapper-nbsmtp
+ doman nbsmtprc.5 nbsmtp.8
+ dodoc INSTALL DOCS Doxyfile
+
+ dohard /usr/bin/wrapper-nbsmtp /usr/bin/sendmail
+ dohard /usr/bin/wrapper-nbsmtp /usr/sbin/sendmail
+ dohard /usr/bin/wrapper-nbsmtp /usr/lib/sendmail
+ dohard /usr/bin/wrapper-nbsmtp /usr/bin/mailq
+ dohard /usr/bin/wrapper-nbsmtp /usr/bin/newaliases
+}