summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-05-18 14:07:11 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-05-18 14:07:11 +0000
commit93e0741b26ae1e98be54f18a71c82020a7c6cd92 (patch)
tree7eeea03e6941fcd08fa7e175297240c26c75ba76 /mail-mta/opensmtpd
parent>=dev-libs/json-c-0.10-r1 needed (#470200 by vax456), drop old (diff)
downloadgentoo-2-93e0741b26ae1e98be54f18a71c82020a7c6cd92.tar.gz
gentoo-2-93e0741b26ae1e98be54f18a71c82020a7c6cd92.tar.bz2
gentoo-2-93e0741b26ae1e98be54f18a71c82020a7c6cd92.zip
Latest snapshot that fixes SSL DoS.
(Portage version: 2.2.0_alpha175/cvs/Linux x86_64, signed Manifest commit with key A5DE03AE)
Diffstat (limited to 'mail-mta/opensmtpd')
-rw-r--r--mail-mta/opensmtpd/ChangeLog8
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild78
-rw-r--r--mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild8
3 files changed, 90 insertions, 4 deletions
diff --git a/mail-mta/opensmtpd/ChangeLog b/mail-mta/opensmtpd/ChangeLog
index 2d69519fc116..2074e032d4fa 100644
--- a/mail-mta/opensmtpd/ChangeLog
+++ b/mail-mta/opensmtpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/opensmtpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.7 2013/04/22 12:04:30 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/ChangeLog,v 1.8 2013/05/18 14:07:11 zx2c4 Exp $
+
+*opensmtpd-5.3.1.201305171950_p1 (18 May 2013)
+
+ 18 May 2013; Jason A. Donenfeld <zx2c4@gentoo.org>
+ +opensmtpd-5.3.1.201305171950_p1.ebuild, opensmtpd-5.3.1_p1.ebuild:
+ Latest snapshot that fixes SSL DoS.
*opensmtpd-5.3.1_p1 (22 Apr 2013)
diff --git a/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild
new file mode 100644
index 000000000000..cb718ad8a1c7
--- /dev/null
+++ b/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1.201305171950_p1.ebuild,v 1.1 2013/05/18 14:07:11 zx2c4 Exp $
+
+EAPI=5
+
+inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools versionator
+
+DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
+HOMEPAGE="http://www.opensmtpd.org/"
+MY_P="${P}"
+[ $(get_last_version_component_index) -eq 4 ] && MY_P="${PN}-$(get_version_component_range 4-)"
+SRC_URI="http://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
+
+LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam sqlite"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ pam? ( virtual/pam )
+ sys-libs/db
+ sqlite? ( dev-db/sqlite:3 )
+ dev-libs/libevent
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/mini-qmail
+ !mail-mta/msmtp[mta]
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/qmail-ldap
+ !mail-mta/sendmail
+ !mail-mta/ssmtp[mta]
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_}
+
+src_prepare() {
+ epatch "${FILESDIR}"/build-warnings.patch
+ eautoreconf
+}
+
+src_configure() {
+ tc-export AR
+ AR="$(which "$AR")" econf \
+ --with-privsep-user=smtpd \
+ --with-filter-user=smtpf \
+ --with-queue-user=smtpq \
+ --with-privsep-path=/var/empty \
+ --with-sock-dir=/var/run \
+ --sysconfdir=/etc/opensmtpd \
+ $(use_with sqlite experimental-sqlite) \
+ $(use_with pam)
+ #--with-lookup-user=smtpl will be available in the release after 5.3p1
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/smtpd.initd smtpd
+ use pam && newpamd "${FILESDIR}"/smtpd.pam smtpd
+}
+
+pkg_preinst() {
+ enewgroup smtpd 25
+ enewuser smtpd 25 -1 /var/empty smtpd
+ enewgroup smtpf 251
+ enewuser smtpf 251 -1 /var/empty smtpf
+ enewgroup smtpq 252
+ enewuser smtpq 252 -1 /var/empty smtpq
+
+ # For release after 5.3p1:
+ #enewgroup smtpl 253
+ #enewuser smtpl 253 -1 /var/empty smtpl
+}
diff --git a/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild b/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild
index 0593d63b641a..3287cdf50f56 100644
--- a/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild
+++ b/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild,v 1.1 2013/04/22 12:04:30 zx2c4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/opensmtpd/opensmtpd-5.3.1_p1.ebuild,v 1.2 2013/05/18 14:07:11 zx2c4 Exp $
EAPI=5
-inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools
+inherit multilib user flag-o-matic eutils pam toolchain-funcs autotools versionator
DESCRIPTION="Lightweight but featured SMTP daemon from OpenBSD"
HOMEPAGE="http://www.opensmtpd.org/"
-SRC_URI="http://www.opensmtpd.org/archives/${P/_}.tar.gz"
+MY_P="${P}"
+[ $(get_last_version_component_index) -eq 4 ] && MY_P="${PN}-$(get_version_component_range 4-)"
+SRC_URI="http://www.opensmtpd.org/archives/${MY_P/_}.tar.gz"
LICENSE="ISC BSD BSD-1 BSD-2 BSD-4"
SLOT="0"