summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Hanselmann <hansmi@gentoo.org>2005-01-02 22:16:06 +0000
committerMichael Hanselmann <hansmi@gentoo.org>2005-01-02 22:16:06 +0000
commitd47fb49f33590d9a81e4888b4eb676f7d92e59a2 (patch)
treea02f19441fa028c34d159917cee866f2a9355b71 /mail-mta/qmail/files
parentChange encoding to UTF-8 for GLEP 31 compliance (Manifest recommit) (diff)
downloadgentoo-2-d47fb49f33590d9a81e4888b4eb676f7d92e59a2.tar.gz
gentoo-2-d47fb49f33590d9a81e4888b4eb676f7d92e59a2.tar.bz2
gentoo-2-d47fb49f33590d9a81e4888b4eb676f7d92e59a2.zip
New, hardmasked ebuild
Diffstat (limited to 'mail-mta/qmail/files')
-rw-r--r--mail-mta/qmail/files/1.03-r16/Makefile-relaymxlookup.patch38
-rw-r--r--mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logging-with-smtpauth.patch18
-rw-r--r--mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logrelay.patch15
-rw-r--r--mail-mta/qmail/files/1.03-r16/smtpplugins27
-rw-r--r--mail-mta/qmail/files/digest-qmail-1.03-r1627
5 files changed, 125 insertions, 0 deletions
diff --git a/mail-mta/qmail/files/1.03-r16/Makefile-relaymxlookup.patch b/mail-mta/qmail/files/1.03-r16/Makefile-relaymxlookup.patch
new file mode 100644
index 000000000000..0a71a554bacc
--- /dev/null
+++ b/mail-mta/qmail/files/1.03-r16/Makefile-relaymxlookup.patch
@@ -0,0 +1,38 @@
+--- qmail-1.03/Makefile.orig 2005-01-02 22:50:46.939208400 +0100
++++ qmail-1.03/Makefile 2005-01-02 22:54:48.066551472 +0100
+@@ -1454,7 +1454,8 @@
+ ./load qmail-qmtpd rcpthosts.o control.o constmap.o \
+ received.o date822fmt.o now.o qmail.o cdb.a fd.a wait.a \
+ datetime.a open.a getln.a sig.a case.a env.a stralloc.a \
+- alloc.a substdio.a error.a str.a fs.a auto_qmail.o
++ alloc.a substdio.a error.a fs.a auto_qmail.o dns.o \
++ `cat dns.lib` ip.o ipalloc.o ipme.o byte_diff.o str.a
+
+ qmail-qmtpd.0: \
+ qmail-qmtpd.8
+@@ -1617,13 +1618,13 @@
+ timeoutwrite.o ip.o ipme.o ipalloc.o control.o constmap.o received.o \
+ date822fmt.o now.o qmail.o cdb.a fd.a wait.a datetime.a getln.a \
+ open.a sig.a case.a env.a stralloc.a alloc.a strerr.a substdio.a error.a str.a \
+-fs.a auto_qmail.o base64.o socket.lib dns.lib
++fs.a auto_qmail.o base64.o socket.lib dns.lib dns.o ip.h ipalloc.h
+ ./load qmail-smtpd qregex.o rcpthosts.o commands.o timeoutread.o \
+ timeoutwrite.o ip.o ipme.o ipalloc.o control.o constmap.o \
+ received.o date822fmt.o now.o qmail.o cdb.a fd.a wait.a \
+ datetime.a getln.a open.a sig.a case.a env.a stralloc.a \
+- alloc.a strerr.a substdio.a error.a str.a fs.a auto_qmail.o base64.o `cat \
+- socket.lib` dns.o `cat dns.lib` -lssl -lcrypto
++ alloc.a strerr.a substdio.a error.a fs.a auto_qmail.o base64.o `cat \
++ socket.lib` -lssl -lcrypto dns.o str.a `cat dns.lib`
+
+ qmail-smtpd.0: \
+ qmail-smtpd.8
+@@ -1760,7 +1761,7 @@
+
+ rcpthosts.o: \
+ compile rcpthosts.c cdb.h uint32.h byte.h open.h error.h control.h \
+-constmap.h stralloc.h gen_alloc.h rcpthosts.h
++constmap.h stralloc.h gen_alloc.h rcpthosts.h dns.h ipalloc.h ipme.h
+ ./compile rcpthosts.c
+
+ qregex.o: \
diff --git a/mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logging-with-smtpauth.patch b/mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logging-with-smtpauth.patch
new file mode 100644
index 000000000000..e141ddc1abf7
--- /dev/null
+++ b/mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logging-with-smtpauth.patch
@@ -0,0 +1,18 @@
+--- qmail-1.03.orig/qmail-smtpd.c 2004-11-19 09:00:53.000000000 +0100
++++ qmail-1.03/qmail-smtpd.c 2004-12-11 19:06:23.185045688 +0100
+@@ -1006,7 +1006,6 @@
+ if (!stralloc_0(&pass)) die_nomem();
+ if (!stralloc_0(&resp)) die_nomem();
+
+- if (fd_copy(2,1) == -1) return err_pipe();
+ //close(3);
+ if (pipe(pi) == -1) return err_pipe();
+ //if (pi[0] != 3) return err_pipe();
+@@ -1014,6 +1013,7 @@
+ case -1:
+ return err_fork();
+ case 0:
++ if (fd_copy(2,1) == -1) _exit(1);
+ close(pi[1]);
+ if (pi[0] != 3) {
+ close(3);
diff --git a/mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logrelay.patch b/mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logrelay.patch
new file mode 100644
index 000000000000..281b3df92727
--- /dev/null
+++ b/mail-mta/qmail/files/1.03-r16/gentoo-qmail-1.03-r16-logrelay.patch
@@ -0,0 +1,15 @@
+--- qmail-1.03.orig/qmail-smtpd.c 2004-11-14 00:55:37.069913288 +0100
++++ qmail-1.03/qmail-smtpd.c 2004-11-14 00:55:37.072912832 +0100
+@@ -728,7 +728,11 @@
+ }
+ else
+ #ifndef TLS
+- if (!addrallowed()) { err_nogateway(); return; }
++ if (!addrallowed()) {
++ strerr_warn6("qmail-smtpd: Attempted relay from ",mailfrom.s," at ",remoteip," to ",addr.s,0);
++ err_nogateway();
++ return;
++ }
+ #else
+ if (!addrallowed())
+ {
diff --git a/mail-mta/qmail/files/1.03-r16/smtpplugins b/mail-mta/qmail/files/1.03-r16/smtpplugins
new file mode 100644
index 000000000000..db9df2647515
--- /dev/null
+++ b/mail-mta/qmail/files/1.03-r16/smtpplugins
@@ -0,0 +1,27 @@
+# smtpplugins sample file
+# none of these plugins is installed by default
+# Paths are relative to the qmail home dir.
+# #f you want your plugin to be executed by system shell, add ':' just before
+# plugin path. this is slightly slower than normal mode.
+#
+# you may disable qmail-spp by setting NOSPP environmental variable - for
+# example using tcprules
+#
+# see http://qmail-spp.sourceforge.net/doc/
+
+[auth]
+#plugins/onlycrammd5
+
+[helo]
+#:plugins/badhelo example.com spammers.com
+
+[mail]
+#:plugins/rbl relays.ordb.org
+#plugins/blacklisted
+#plugins/spf
+#plugins/dnsmx-check
+
+[rcpt]
+#plugins/exists
+#plugins/tarpit
+
diff --git a/mail-mta/qmail/files/digest-qmail-1.03-r16 b/mail-mta/qmail/files/digest-qmail-1.03-r16
new file mode 100644
index 000000000000..b93bb6e46960
--- /dev/null
+++ b/mail-mta/qmail/files/digest-qmail-1.03-r16
@@ -0,0 +1,27 @@
+MD5 622f65f982e380dbe86e6574f3abcb7c qmail-1.03.tar.gz 220668
+MD5 5a8d7a5863b0c56236af945dedd45754 qmailqueue-patch 2510
+MD5 39b6f70f65056472ff97ab40c1dba7b4 big-todo.103.patch 5546
+MD5 1d5b0aafb651ce2ad02aac6af80758c0 qmail-link-sync.patch 1403
+MD5 2ff58c3570870a8ff9a1d9eb9aec05a6 big-concurrency.patch 9331
+MD5 999e360e4b1571663b995ce51f6e056e qmail-1.03-0.0.0.0-0.2.patch 734
+MD5 4e1f2d8315e7e2a5482798c9d19fac4d sendmail-flagf.patch 863
+MD5 122664c38338e5ec35fcac43f33d6927 qmail-1.03-qmtpc.patch 6197
+MD5 24fc1a33089faf12e00b127cd659f317 qmail-smtpd-relay-reject 1230
+MD5 ed5c0ddb6a5cc0386b1e04ced71d26ad qmail-local-tabs.patch 505
+MD5 413be7bb5b407c2964c3275c4d596947 qmail-maildir++.patch 43512
+MD5 d566e8bd99b33efee0194e855b8d6995 qmail-date-localtime.patch.txt 2603
+MD5 1c4518f780d231bde9745cdd0fa313b2 qmail-limit-bounce-size.patch.txt 1753
+MD5 9140ad2b03017145cd7963c84bb24f16 qmail-103.patch 2104
+MD5 83bf5c4a4aade3c6c15faa9665ccfb71 qregex-starttls-2way-auth.patch 63825
+MD5 1d8b89607d35bfa409f8cfe6d23bc554 qmail-remote-auth-patch-doc.txt 1287
+MD5 fc00be3edc2827f1c93112d7d5147122 qmail-gentoo-1.03-r12-badrcptto-morebadrcptto-accdias.diff.bz2 4524
+MD5 58d912de1ede57062fa8a3e2e0e75abf qmail-popupnofd2close.patch 401
+MD5 d7151dcbeb02eea1c24c1dedffe20e0b qmail-1.03-reread-concurrency.2.patch 1129
+MD5 ad597c93426c0938fdb36d853fbcf40d 08-capa.diff 1323
+MD5 00084ddd52a3665b65f2db20a773b382 qmail-hold-1.03.pat.gz 1596
+MD5 68e7697fd61d7cd9a5a7dc88ce2ecd47 netscape-progress.patch 1457
+MD5 598aca7a3a99426d1f49079172986b31 sendmail-ignore-N.patch 636
+MD5 2bd191cca4e640e87cca79bc0405f97a qmail-1.03-moreipme-0.6pre1-gentoo.patch 13942
+MD5 d96455aaed208e9cd450d8874564781b qmail-relaymxlookup-0.3.diff 3856
+MD5 d898fbb2b4cb259b208dbb8c9d8c47a9 gentoo-qmail-1.03-r16-mfcheck.3.patch 4223
+MD5 95692f3a7574f258489943ca9d09981a gentoo-qmail-1.03-r16-spp.034.patch 34568