summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Barisani <lcars@gentoo.org>2006-08-10 10:46:06 +0000
committerAndrea Barisani <lcars@gentoo.org>2006-08-10 10:46:06 +0000
commitf4cc38fd11d0f5af846eeae804a7b6239f25f96d (patch)
tree4aeab169100aeb11be374d8a3a88f674e27e5c1e /mail-mta/sendmail
parentStable on ppc64, bug #142936 (diff)
downloadgentoo-2-f4cc38fd11d0f5af846eeae804a7b6239f25f96d.tar.gz
gentoo-2-f4cc38fd11d0f5af846eeae804a7b6239f25f96d.tar.bz2
gentoo-2-f4cc38fd11d0f5af846eeae804a7b6239f25f96d.zip
version bump, security cleanup
(Portage version: 2.1-r1)
Diffstat (limited to 'mail-mta/sendmail')
-rw-r--r--mail-mta/sendmail/ChangeLog9
-rw-r--r--mail-mta/sendmail/files/digest-sendmail-8.13.83
-rw-r--r--mail-mta/sendmail/sendmail-8.13.8.ebuild197
3 files changed, 208 insertions, 1 deletions
diff --git a/mail-mta/sendmail/ChangeLog b/mail-mta/sendmail/ChangeLog
index d4e59fc7b6c0..2c812c3d0e5f 100644
--- a/mail-mta/sendmail/ChangeLog
+++ b/mail-mta/sendmail/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for mail-mta/sendmail
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/sendmail/ChangeLog,v 1.60 2006/06/25 06:42:11 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/sendmail/ChangeLog,v 1.61 2006/08/10 10:46:06 lcars Exp $
+
+*sendmail-8.13.8 (10 Aug 2006)
+
+ 10 Aug 2006; Andrea Barisani <lcars@gentoo.org> -sendmail-8.13.3.ebuild,
+ -sendmail-8.13.4.ebuild, -sendmail-8.13.4-r1.ebuild,
+ -sendmail-8.13.5.ebuild, -sendmail-8.13.6.ebuild, +sendmail-8.13.8.ebuild:
+ Security cleanup, bug #140514. Version bump with fixes for bugs #99030, #82825.
25 Jun 2006; Tobias Scherbaum <dertobi123@gentoo.org>
sendmail-8.13.7-r1.ebuild:
diff --git a/mail-mta/sendmail/files/digest-sendmail-8.13.8 b/mail-mta/sendmail/files/digest-sendmail-8.13.8
new file mode 100644
index 000000000000..b0bc784e181d
--- /dev/null
+++ b/mail-mta/sendmail/files/digest-sendmail-8.13.8
@@ -0,0 +1,3 @@
+MD5 5f29c94b42e0bb74d546b2ae84203a1e sendmail.8.13.8.tar.gz 2010975
+RMD160 a5d333b073d681f056421e836df4067f331a8ac8 sendmail.8.13.8.tar.gz 2010975
+SHA256 48262059aec2d2f1cbbb45dcd4eaf5eb3ba02bc29ebc25c15ae2e04b606f0123 sendmail.8.13.8.tar.gz 2010975
diff --git a/mail-mta/sendmail/sendmail-8.13.8.ebuild b/mail-mta/sendmail/sendmail-8.13.8.ebuild
new file mode 100644
index 000000000000..97fa54b21eb5
--- /dev/null
+++ b/mail-mta/sendmail/sendmail-8.13.8.ebuild
@@ -0,0 +1,197 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/sendmail/sendmail-8.13.8.ebuild,v 1.1 2006/08/10 10:46:06 lcars Exp $
+
+inherit eutils
+
+DESCRIPTION="Widely-used Mail Transport Agent (MTA)"
+HOMEPAGE="http://www.sendmail.org/"
+SRC_URI="ftp://ftp.sendmail.org/pub/${PN}/${PN}.${PV}.tar.gz"
+
+LICENSE="Sendmail"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ssl ldap sasl tcpd mbox mailwrapper ipv6 nis sockets"
+
+DEPEND="net-mail/mailbase
+ sys-devel/m4
+ sasl? ( >=dev-libs/cyrus-sasl-2.1.10 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ ssl? ( dev-libs/openssl )
+ ldap? ( net-nds/openldap )
+ >=sys-libs/db-3.2
+ !net-mail/vacation
+ "
+RDEPEND="${DEPEND}
+ >=net-mail/mailbase-0.00
+ !mailwrapper? ( !virtual/mta )
+ mailwrapper? ( >=net-mail/mailwrapper-0.2 )"
+PDEPEND="!mbox? ( mail-filter/procmail )"
+PROVIDE="virtual/mta"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/sendmail-delivered_hdr.patch || die
+
+ confCCOPTS="${CFLAGS}"
+ confMAPDEF="-DMAP_REGEX"
+ conf_sendmail_LIBS=""
+ use sasl && confLIBS="${confLIBS} -lsasl2" \
+ && confENVDEF="${confENVDEF} -DSASL=2" \
+ && confCCOPTS="${confCCOPTS} -I/usr/include/sasl" \
+ && conf_sendmail_LIBS="${conf_sendmail_LIBS} -lsasl2"
+ use tcpd && confENVDEF="${confENVDEF} -DTCPWRAPPERS" \
+ && confLIBS="${confLIBS} -lwrap"
+ use ssl && confENVDEF="${confENVDEF} -DSTARTTLS -D_FFR_DEAL_WITH_ERROR_SSL" \
+ && confLIBS="${confLIBS} -lssl -lcrypto" \
+ && conf_sendmail_LIBS="${conf_sendmail_LIBS} -lssl -lcrypto"
+ use ldap && confMAPDEF="${confMAPDEF} -DLDAPMAP" \
+ && confLIBS="${confLIBS} -lldap -llber"
+ use ipv6 && confENVDEF="${confENVDEF} -DNETINET6"
+ use nis && confENVDEF="${confENVDEF} -DNIS"
+ use sockets && confENVDEF="${confENVDEF} -DSOCKETMAP"
+ sed -e "s:@@confCCOPTS@@:${confCCOPTS}:" \
+ -e "s/@@confMAPDEF@@/${confMAPDEF}/" \
+ -e "s/@@confENVDEF@@/${confENVDEF}/" \
+ -e "s/@@confLIBS@@/${confLIBS}/" \
+ -e "s/@@conf_sendmail_LIBS@@/${conf_sendmail_LIBS}/" \
+ ${FILESDIR}/site.config.m4 > ${S}/devtools/Site/site.config.m4
+}
+
+src_compile() {
+ sh Build || die "compilation failed in main Build script"
+ pushd libmilter
+ sh Build || die "libmilter compilation failed"
+ popd
+}
+
+src_install () {
+ OBJDIR="obj.`uname -s`.`uname -r`.`arch`"
+ dodir /usr/bin /usr/lib
+ dodir /usr/share/man/man{1,5,8} /usr/sbin /var/log /usr/share/sendmail-cf
+ dodir /var/spool/{mqueue,clientmqueue} /etc/conf.d
+ keepdir /var/spool/{clientmqueue,mqueue}
+ for dir in libsmutil sendmail mailstats praliases smrsh makemap vacation editmap
+ do
+ make DESTDIR=${D} MANROOT=/usr/share/man/man \
+ SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
+ MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
+ LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
+ MSPQOWN=root CFOWN=root CFGRP=root \
+ install -C ${OBJDIR}/${dir} \
+ || die "install failed"
+ done
+ for dir in rmail mail.local
+ do
+ make DESTDIR=${D} MANROOT=/usr/share/man/man \
+ SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
+ MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
+ LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
+ MSPQOWN=root CFOWN=root CFGRP=root \
+ force-install -C ${OBJDIR}/${dir} \
+ || die "install failed"
+ done
+
+ dodir /usr/include/libmilter
+ make DESTDIR=${D} MANROOT=/usr/share/man/man \
+ SBINOWN=root SBINGRP=root UBINOWN=root UBINGRP=root \
+ MANOWN=root MANGRP=root INCOWN=root INCGRP=root \
+ LIBOWN=root LIBGRP=root GBINOWN=root GBINGRP=root \
+ MSPQOWN=root CFOWN=root CFGRP=root \
+ install -C ${OBJDIR}/libmilter \
+ || die "install failed"
+
+ fowners root:smmsp /usr/sbin/sendmail
+ fperms 2555 /usr/sbin/sendmail
+ fowners smmsp:smmsp /var/spool/clientmqueue
+ fperms 770 /var/spool/clientmqueue
+ fperms 700 /var/spool/mqueue
+ dosym /usr/sbin/makemap /usr/bin/makemap
+ dodoc FAQ LICENSE KNOWNBUGS README RELEASE_NOTES doc/op/op.ps
+ newdoc sendmail/README README.sendmail
+ newdoc sendmail/SECURITY SECURITY
+ newdoc sendmail/TUNING TUNING
+ newdoc smrsh/README README.smrsh
+ newdoc libmilter/README README.libmilter
+
+ newdoc cf/README README.cf
+ newdoc cf/cf/README README.install-cf
+ cp -pPR cf/* ${D}/usr/share/sendmail-cf
+ insinto /etc/mail
+ if use mbox
+ then
+ doins ${FILESDIR}/sendmail.mc
+ else
+ newins ${FILESDIR}/sendmail-procmail.mc sendmail.mc
+ fi
+ m4 ${D}/usr/share/sendmail-cf/m4/cf.m4 ${D}/etc/mail/sendmail.mc \
+ > ${D}/etc/mail/sendmail.cf
+ echo "include(\`/usr/share/sendmail-cf/m4/cf.m4')dnl" \
+ > ${D}/etc/mail/submit.mc
+ cat ${D}/usr/share/sendmail-cf/cf/submit.mc >> ${D}/etc/mail/submit.mc
+ echo "# local-host-names - include all aliases for your machine here" \
+ > ${D}/etc/mail/local-host-names
+ cat <<- EOF > ${D}/etc/mail/trusted-users
+ # trusted-users - users that can send mail as others without a warning
+ # apache, mailman, majordomo, uucp are good candidates
+ EOF
+ cat <<- EOF > ${D}/etc/mail/access
+ # Check the /usr/share/doc/sendmail/README.cf file for a description
+ # of the format of this file. (search for access_db in that file)
+ # The /usr/share/doc/sendmail/README.cf is part of the sendmail-doc
+ # package.
+ #
+
+ EOF
+ cat <<- EOF > ${D}/etc/conf.d/sendmail
+ # Config file for /etc/init.d/sendmail
+ # add start-up options here
+ SENDMAIL_OPTS="-bd -q30m -L sm-mta" # default daemon mode
+ CLIENTMQUEUE_OPTS="-Ac -q30m -L sm-cm" # clientmqueue
+ KILL_OPTS="" # add -9/-15/your favorite evil SIG level here
+
+ EOF
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/sendmail
+ keepdir /usr/adm/sm.bin
+
+ if use mailwrapper
+ then
+ mv ${D}/usr/sbin/sendmail ${D}/usr/sbin/sendmail.sendmail
+ insinto /etc/mail
+ doins ${FILESDIR}/mailer.conf
+ rm ${D}/usr/bin/mailq
+ rm ${D}/usr/bin/newaliases
+ mv ${D}/usr/share/man/man8/sendmail.8 \
+ ${D}/usr/share/man/man8/sendmail-sendmail.8
+ mv ${D}/usr/share/man/man1/mailq.1 \
+ ${D}/usr/share/man/man1/mailq-sendmail.1
+ mv ${D}/usr/share/man/man1/newaliases.1 \
+ ${D}/usr/share/man/man1/newaliases-sendmail.1
+ mv ${D}/usr/share/man/man5/aliases.5 \
+ ${D}/usr/share/man/man5/aliases-sendmail.5
+ dosed 's/} sendmail/} sendmail.sendmail/' /etc/init.d/sendmail
+ dosed 's/sbin\/sendmail/sbin\/sendmail.sendmail/' /etc/init.d/sendmail
+ fi
+
+}
+
+pkg_setup() {
+ einfo "checking for smmsp group... create if missing."
+ enewgroup smmsp 209 || die "problem adding group smmsp"
+ einfo "checking for smmsp user... create if missing."
+ enewuser smmsp 209 -1 /var/spool/mqueue smmsp \
+ || die "problem adding user smmsp"
+}
+
+pkg_postinst() {
+ if ! use mailwrapper && [[ -e /etc/mailer.conf ]]
+ then
+ einfo
+ einfo "Since you emerged sendmail without mailwrapper in USE,"
+ einfo "you probably want to 'emerge -C mailwrapper' now."
+ einfo
+ fi
+}