summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2007-10-21 11:15:08 +0000
committerNed Ludd <solar@gentoo.org>2007-10-21 11:15:08 +0000
commit6ec567711e4629ce657b2790980de592e61e6bbd (patch)
tree011a18ba03b1548806672b358e32769cc470e6a9 /mail-mta
parentVersion bump. (diff)
downloadgentoo-2-6ec567711e4629ce657b2790980de592e61e6bbd.tar.gz
gentoo-2-6ec567711e4629ce657b2790980de592e61e6bbd.tar.bz2
gentoo-2-6ec567711e4629ce657b2790980de592e61e6bbd.zip
- make postfix respect user defined LDFLAGS. 192885
(Portage version: 2.1.3.9)
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/postfix/ChangeLog8
-rw-r--r--mail-mta/postfix/postfix-2.1.5-r2.ebuild5
-rw-r--r--mail-mta/postfix/postfix-2.2.10-r1.ebuild7
-rw-r--r--mail-mta/postfix/postfix-2.2.10.ebuild5
-rw-r--r--mail-mta/postfix/postfix-2.2.11.ebuild7
-rw-r--r--mail-mta/postfix/postfix-2.3.6.ebuild5
-rw-r--r--mail-mta/postfix/postfix-2.3.8.ebuild5
-rw-r--r--mail-mta/postfix/postfix-2.4.1.ebuild5
-rw-r--r--mail-mta/postfix/postfix-2.4.3.ebuild5
-rw-r--r--mail-mta/postfix/postfix-2.4.5.ebuild5
10 files changed, 36 insertions, 21 deletions
diff --git a/mail-mta/postfix/ChangeLog b/mail-mta/postfix/ChangeLog
index 1cf5a2cea2bb..d265e31fcbdf 100644
--- a/mail-mta/postfix/ChangeLog
+++ b/mail-mta/postfix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for mail-mta/postfix
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.133 2007/09/19 16:09:35 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/ChangeLog,v 1.134 2007/10/21 11:15:08 solar Exp $
+
+ 21 Oct 2007; <solar@gentoo.org> postfix-2.1.5-r2.ebuild,
+ postfix-2.2.10.ebuild, postfix-2.2.10-r1.ebuild, postfix-2.2.11.ebuild,
+ postfix-2.3.6.ebuild, postfix-2.3.8.ebuild, postfix-2.4.1.ebuild,
+ postfix-2.4.3.ebuild, postfix-2.4.5.ebuild:
+ - make postfix respect user defined LDFLAGS. 192885
19 Sep 2007; Patrick McLean <chutzpah@gentoo.org> postfix-2.4.5.ebuild:
Change paths to binaries in default master.cf to standard gentoo paths
diff --git a/mail-mta/postfix/postfix-2.1.5-r2.ebuild b/mail-mta/postfix/postfix-2.1.5-r2.ebuild
index 0619f4fe04fc..d7bf2c910857 100644
--- a/mail-mta/postfix/postfix-2.1.5-r2.ebuild
+++ b/mail-mta/postfix/postfix-2.1.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.1.5-r2.ebuild,v 1.17 2007/07/15 07:06:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.1.5-r2.ebuild,v 1.18 2007/10/21 11:15:08 solar Exp $
inherit eutils ssl-cert toolchain-funcs
@@ -106,7 +106,8 @@ src_unpack() {
src_compile() {
# added -Wl,-z,now wrt 62674.
- local mycc="-DHAS_PCRE" mylibs="-Wl,-z,now -L/usr/lib -lpcre -ldl -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="-Wl,-z,now ${LDFLAGS} -lpcre -ldl -lcrypt -lpthread"
if use pam ; then
mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.2.10-r1.ebuild b/mail-mta/postfix/postfix-2.2.10-r1.ebuild
index e3b1d8fc2cad..864c3136c650 100644
--- a/mail-mta/postfix/postfix-2.2.10-r1.ebuild
+++ b/mail-mta/postfix/postfix-2.2.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.10-r1.ebuild,v 1.3 2006/11/23 20:28:34 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.10-r1.ebuild,v 1.4 2007/10/21 11:15:08 solar Exp $
inherit eutils ssl-cert toolchain-funcs flag-o-matic mailer pam
IUSE="ipv6 pam ldap mysql postgres ssl sasl mbox nis vda selinux hardened cdb"
@@ -151,7 +151,8 @@ src_compile() {
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/lib -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.2.10.ebuild b/mail-mta/postfix/postfix-2.2.10.ebuild
index a100ae4bc4dc..24252a3baa2c 100644
--- a/mail-mta/postfix/postfix-2.2.10.ebuild
+++ b/mail-mta/postfix/postfix-2.2.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.10.ebuild,v 1.11 2007/02/04 04:20:29 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.10.ebuild,v 1.12 2007/10/21 11:15:08 solar Exp $
inherit eutils ssl-cert toolchain-funcs flag-o-matic pam
IUSE="ipv6 pam ldap mysql postgres ssl sasl mailwrapper mbox nis vda selinux hardened cdb"
@@ -153,7 +153,8 @@ src_compile() {
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/lib -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.2.11.ebuild b/mail-mta/postfix/postfix-2.2.11.ebuild
index 8c477a538106..f523116c7e12 100644
--- a/mail-mta/postfix/postfix-2.2.11.ebuild
+++ b/mail-mta/postfix/postfix-2.2.11.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.11.ebuild,v 1.2 2006/11/23 20:28:34 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.2.11.ebuild,v 1.3 2007/10/21 11:15:08 solar Exp $
inherit eutils ssl-cert toolchain-funcs flag-o-matic pam
IUSE="ipv6 pam ldap mysql postgres ssl sasl mailwrapper mbox nis vda selinux hardened cdb"
@@ -152,7 +152,8 @@ src_compile() {
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/lib -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.3.6.ebuild b/mail-mta/postfix/postfix-2.3.6.ebuild
index 6a0e4d7f6a17..94efd502894f 100644
--- a/mail-mta/postfix/postfix-2.3.6.ebuild
+++ b/mail-mta/postfix/postfix-2.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.3.6.ebuild,v 1.10 2007/03/25 12:03:43 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.3.6.ebuild,v 1.11 2007/10/21 11:15:08 solar Exp $
# NOTE: this ebuild is regular ebuild without mailer-config support
# comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -181,7 +181,8 @@ src_compile() {
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/lib -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.3.8.ebuild b/mail-mta/postfix/postfix-2.3.8.ebuild
index 3bfb514a9b7d..d6baa9f63c43 100644
--- a/mail-mta/postfix/postfix-2.3.8.ebuild
+++ b/mail-mta/postfix/postfix-2.3.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.3.8.ebuild,v 1.2 2007/03/29 15:30:20 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.3.8.ebuild,v 1.3 2007/10/21 11:15:08 solar Exp $
# NOTE: this ebuild is regular ebuild without mailer-config support
# comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -181,7 +181,8 @@ src_compile() {
# added -Wl,-z,now wrt 62674.
# remove -ldl as it is not necessary, resolve bug #106446.
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/lib -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.4.1.ebuild b/mail-mta/postfix/postfix-2.4.1.ebuild
index 457d0b43152a..da50baa6b885 100644
--- a/mail-mta/postfix/postfix-2.4.1.ebuild
+++ b/mail-mta/postfix/postfix-2.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.1.ebuild,v 1.1 2007/05/01 16:00:34 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.1.ebuild,v 1.2 2007/10/21 11:15:08 solar Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -169,7 +169,8 @@ src_compile() {
# Added -Wl,-z,now wrt bug #62674
# Remove -ldl as it is not necessary, solves bug #106446
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/$(get_libdir) -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.4.3.ebuild b/mail-mta/postfix/postfix-2.4.3.ebuild
index 74698f00f93a..0156b593118d 100644
--- a/mail-mta/postfix/postfix-2.4.3.ebuild
+++ b/mail-mta/postfix/postfix-2.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.3.ebuild,v 1.1 2007/06/02 20:43:11 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.3.ebuild,v 1.2 2007/10/21 11:15:08 solar Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -169,7 +169,8 @@ src_compile() {
# Added -Wl,-z,now wrt bug #62674
# Remove -ldl as it is not necessary, solves bug #106446
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/$(get_libdir) -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"
diff --git a/mail-mta/postfix/postfix-2.4.5.ebuild b/mail-mta/postfix/postfix-2.4.5.ebuild
index 9d5c52d2e6bf..15162daef825 100644
--- a/mail-mta/postfix/postfix-2.4.5.ebuild
+++ b/mail-mta/postfix/postfix-2.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.5.ebuild,v 1.2 2007/09/19 16:09:35 chutzpah Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-mta/postfix/postfix-2.4.5.ebuild,v 1.3 2007/10/21 11:15:08 solar Exp $
# NOTE: this ebuild is a regular ebuild without mailer-config support!
# Comment lines below "regular ebuild" and uncomment lines below "mailer-config support"
@@ -172,7 +172,8 @@ src_compile() {
# Added -Wl,-z,now wrt bug #62674
# Remove -ldl as it is not necessary, solves bug #106446
# -Wl,-z,now replaced by $(bindnow-flags)
- local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) -L/usr/$(get_libdir) -lpcre -lcrypt -lpthread"
+ # make sure LDFLAGS get passed down to the executables.
+ local mycc="-DHAS_PCRE" mylibs="$(bindnow-flags) ${LDFLAGS} -lpcre -lcrypt -lpthread"
use pam && mylibs="${mylibs} -lpam"