summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-12-04 04:55:53 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-12-04 04:55:53 +0000
commitb8c811c77324d77b6d875600eb32e24e7a982d90 (patch)
tree196c08b1fb2742bfe2436f4db6990b26e37fad35 /media-gfx/blender/blender-2.31.ebuild
parentNew version (diff)
downloadgentoo-2-b8c811c77324d77b6d875600eb32e24e7a982d90.tar.gz
gentoo-2-b8c811c77324d77b6d875600eb32e24e7a982d90.tar.bz2
gentoo-2-b8c811c77324d77b6d875600eb32e24e7a982d90.zip
New version
Diffstat (limited to 'media-gfx/blender/blender-2.31.ebuild')
-rw-r--r--media-gfx/blender/blender-2.31.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/media-gfx/blender/blender-2.31.ebuild b/media-gfx/blender/blender-2.31.ebuild
new file mode 100644
index 000000000000..1e41b9f09969
--- /dev/null
+++ b/media-gfx/blender/blender-2.31.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/blender/blender-2.31.ebuild,v 1.1 2003/12/04 04:55:30 lu_zero Exp $
+
+inherit flag-o-matic
+replace-flags -march=pentium4 -march=pentium3
+
+IUSE="sdl jpeg png mozilla truetype static"
+#IUSE="${IUSE} blender-game blender-plugin"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="3D Creation/Animation/Publishing System"
+HOMEPAGE="http://www.blender.org/"
+SRC_URI="http://download.blender.org/source/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2 | BL"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+DEPEND="virtual/x11
+ blender-game? ( dev-games/ode )
+ sdl? ( media-libs/libsdl )
+ jpeg? ( media-libs/jpeg )
+ png? ( media-libs/libpng )
+ mozilla? ( net-www/mozilla )
+ truetype? ( >=freetype-2.0 )
+ fmod? ( media-libs/fmod )
+ >=media-libs/openal-20020127
+ >=media-libs/libsdl-1.2
+ >=media-libs/libvorbis-1.0
+ >=dev-libs/openssl-0.9.6"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/configure-fix-${PV}.patch
+}
+
+
+src_compile() {
+ local myconf=""
+
+ # SDL Support
+ use sdl && myconf="${myconf} --with-sdl=/usr"
+ # || myconf="${myconf} --without-sdl"
+
+ # Jpeg support
+ use jpeg && myconf="${myconf} --with-libjpeg=/usr"
+
+ # PNG Support
+ use png && myconf="${myconf} --with-libpng=/usr"
+
+ # ./configure points at the wrong mozilla directories and will fail
+ # with this enabled. (A simple patch should take care of this)
+ use mozilla && myconf="${myconf} --with-mozilla=/usr"
+
+ # TrueType support (For text objects)
+ use truetype && myconf="${myconf} --with-freetype2=/usr"
+
+ # Build Staticly
+ use static && myconf="${myconf} --enable-blenderstatic"
+
+ # Build the game engine
+ # use blender-game && myconf="${myconf} --enable-gameblender"
+
+ # Build the plugin (Will fail, requires gameblender)
+ # use blender-plugin && myconf="${myconf} --enable-blenderplugin"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+}