summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-08-05 07:28:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-08-05 07:28:46 +0000
commit311813dd4447c30e823ec27a59d28c1a24494c86 (patch)
treea0fa2d7fbc4472fcc9a051eef30c30bde9493ff3 /media-gfx/dpic
parentFix installation wrt #238613, thanks to Christophe LEFEBVRE. (diff)
downloadgentoo-2-311813dd4447c30e823ec27a59d28c1a24494c86.tar.gz
gentoo-2-311813dd4447c30e823ec27a59d28c1a24494c86.tar.bz2
gentoo-2-311813dd4447c30e823ec27a59d28c1a24494c86.zip
version bump, by Matthias Schwarzott <zzam@gentoo.org>, bug #280357
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/dpic')
-rw-r--r--media-gfx/dpic/ChangeLog7
-rw-r--r--media-gfx/dpic/dpic-20090713.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/media-gfx/dpic/ChangeLog b/media-gfx/dpic/ChangeLog
index 91dfec6b3ca6..d41a2443af99 100644
--- a/media-gfx/dpic/ChangeLog
+++ b/media-gfx/dpic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-gfx/dpic
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/dpic/ChangeLog,v 1.2 2009/04/18 22:18:52 zzam Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dpic/ChangeLog,v 1.3 2009/08/05 07:28:46 aballier Exp $
+
+*dpic-20090713 (05 Aug 2009)
+
+ 05 Aug 2009; Alexis Ballier <aballier@gentoo.org> +dpic-20090713.ebuild:
+ version bump, by Matthias Schwarzott <zzam@gentoo.org>, bug #280357
18 Apr 2009; Matthias Schwarzott <zzam@gentoo.org> dpic-20080511.ebuild:
Added ~x86 keyword.
diff --git a/media-gfx/dpic/dpic-20090713.ebuild b/media-gfx/dpic/dpic-20090713.ebuild
new file mode 100644
index 000000000000..210b98851768
--- /dev/null
+++ b/media-gfx/dpic/dpic-20090713.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/dpic/dpic-20090713.ebuild,v 1.1 2009/08/05 07:28:46 aballier Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Converts PIC plots into pstricks, PGF/TikZ, PostScript, MetaPost and TeX"
+HOMEPAGE="http://ece.uwaterloo.ca/~aplevich/dpic"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_compile () {
+ # Instead of patching the makefile, we just create a new one that will use
+ # cflags, ldflags & friends
+ echo "LDLIBS=-lm" > Makefile
+ echo "dpic: dpic.o dpic2.o p2clib.o" >> Makefile
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install () {
+ dobin dpic || die "installing dpic failed"
+ dodoc README doc/dpicdoc.pdf doc/gpic.ps.gz || die "installing docs failed"
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins doc/examples/README doc/examples/Examples.txt doc/examples/sources/* || die "installing examples failed"
+ fi
+}