summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-10-07 11:54:42 +0000
committerPacho Ramos <pacho@gentoo.org>2012-10-07 11:54:42 +0000
commit586fac054db7b4b4ba9eb7c8e03837785d21ef73 (patch)
tree7e6ce9034f2d7c06d60b1c811c5e7f3b08e1948d /media-gfx/engauge
parentsys-fs/aufs3: Pass raw ldflags if ld is called directly, #432398; use KV_OUT_... (diff)
downloadgentoo-2-586fac054db7b4b4ba9eb7c8e03837785d21ef73.tar.gz
gentoo-2-586fac054db7b4b4ba9eb7c8e03837785d21ef73.tar.bz2
gentoo-2-586fac054db7b4b4ba9eb7c8e03837785d21ef73.zip
Fix compilation problems with debian patches, bug #423009.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/engauge')
-rw-r--r--media-gfx/engauge/ChangeLog6
-rw-r--r--media-gfx/engauge/engauge-4.1-r1.ebuild13
-rw-r--r--media-gfx/engauge/files/engauge-5.1-gcc47.patch19
-rw-r--r--media-gfx/engauge/files/engauge-5.1-qreal-double.patch31
4 files changed, 63 insertions, 6 deletions
diff --git a/media-gfx/engauge/ChangeLog b/media-gfx/engauge/ChangeLog
index 1d23ac59fd76..04db8070a14c 100644
--- a/media-gfx/engauge/ChangeLog
+++ b/media-gfx/engauge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/engauge
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/ChangeLog,v 1.10 2012/07/29 16:48:00 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/ChangeLog,v 1.11 2012/10/07 11:54:41 pacho Exp $
+
+ 07 Oct 2012; Pacho Ramos <pacho@gentoo.org> +files/engauge-5.1-gcc47.patch,
+ +files/engauge-5.1-qreal-double.patch, engauge-4.1-r1.ebuild:
+ Fix compilation problems with debian patches, bug #423009.
29 Jul 2012; Michael Palimaka <kensington@gentoo.org> engauge-4.1-r1.ebuild:
Add missing slot dependencies on Qt.
diff --git a/media-gfx/engauge/engauge-4.1-r1.ebuild b/media-gfx/engauge/engauge-4.1-r1.ebuild
index 3a8cf804a229..0a47812814e7 100644
--- a/media-gfx/engauge/engauge-4.1-r1.ebuild
+++ b/media-gfx/engauge/engauge-4.1-r1.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/engauge-4.1-r1.ebuild,v 1.4 2012/07/29 16:48:00 kensington Exp $
-
-EAPI=3
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/engauge/engauge-4.1-r1.ebuild,v 1.5 2012/10/07 11:54:41 pacho Exp $
+EAPI=4
inherit versionator qt4-r2 eutils
DESCRIPTION="Convert an image file showing a graph or map into numbers"
@@ -26,6 +25,10 @@ S="${WORKDIR}/${PN}"
src_prepare() {
epatch "${DISTDIR}"/${P}_qt4.patch.xz
+ # Some Debian patches to fix compilation problems
+ epatch "${FILESDIR}/${PN}-5.1-gcc47.patch"
+ epatch "${FILESDIR}/${PN}-5.1-qreal-double.patch"
+
# Some patching and using the DEBIAN_PACKAGE ifdef is necessary to make sure the
# documentation is looked for in the proper directory
sed -i -e "s:/usr/share/doc/engauge-digitizer-doc:${ROOT}/usr/share/doc/${PF}:" \
@@ -44,9 +47,9 @@ src_install() {
make_desktop_entry engauge "Engauge Digitizer" ${PN} Graphics
insinto /usr/share/doc/${PF}
if use doc; then
- doins -r usermanual || die "install documentation failed"
+ doins -r usermanual
fi
if use examples; then
- doins -r samples || die "install examples failed"
+ doins -r samples
fi
}
diff --git a/media-gfx/engauge/files/engauge-5.1-gcc47.patch b/media-gfx/engauge/files/engauge-5.1-gcc47.patch
new file mode 100644
index 000000000000..411cea829ae9
--- /dev/null
+++ b/media-gfx/engauge/files/engauge-5.1-gcc47.patch
@@ -0,0 +1,19 @@
+Description: Add missing header include
+ In gcc 4.7, many of the standard C++ library include files have been
+ edited to no longer include <unistd.h> to remove namespace pollution.
+ The missing include is added to fix FTBFS with gcc 4.7.
+Author: Tobias Winchen <winchen@physik.rwth-aachen.de>
+Last-Update: 2012-05-17
+
+
+--- a/src/pointmatch.cpp
++++ b/src/pointmatch.cpp
+@@ -25,6 +25,7 @@
+
+ #include <math.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ #include "main.h"
+ #include "mmsubs.h"
+
diff --git a/media-gfx/engauge/files/engauge-5.1-qreal-double.patch b/media-gfx/engauge/files/engauge-5.1-qreal-double.patch
new file mode 100644
index 000000000000..73504559fe18
--- /dev/null
+++ b/media-gfx/engauge/files/engauge-5.1-qreal-double.patch
@@ -0,0 +1,31 @@
+Description: Fix issues with double VS qreal
+ The code was attempting to pass double* to a function expecting qreal*
+ resulting in compile errors on arm (where qreal is defined as float)
+ this patch changes a couple of variable definitions so the types match
+ up.
+Origin: http://bugs.debian.org/656943
+Author: Peter Green <plugwash@p10link.net>
+Reviewed-By: Tobias Winchen <winchen@physik.rwth-aachen.de>
+Last-Update: 2012-03-21
+
+
+--- engauge-digitizer-5.0.orig/src/digitview.cpp
++++ engauge-digitizer-5.0/src/digitview.cpp
+@@ -288,7 +288,7 @@ void DigitView::keyReleaseEvent(QKeyEven
+
+ QPoint DigitView::convertZoom(QPoint p, bool to)
+ {
+- double x, y;
++ qreal x, y;
+ if (to)
+ worldMatrix().map((double) p.x(), (double) p.y(), &x, &y);
+ else
+@@ -299,7 +299,7 @@ QPoint DigitView::convertZoom(QPoint p,
+
+ QRect DigitView::convertZoom(QRect r, bool to)
+ {
+- double xTL, yTL, xBR, yBR;
++ qreal xTL, yTL, xBR, yBR;
+ if (to)
+ {
+ worldMatrix().map((double) r.left(), (double) r.top(), &xTL, &yTL);