summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2009-07-15 13:31:09 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2009-07-15 13:31:09 +0000
commit21382bfad301ca387dbef30d78ed875dc711144a (patch)
tree732c2cb8eb42c84e020cb17ff6c3e8d301c22cfe /media-gfx/freepv/freepv-0.3.0-r1.ebuild
parentstable x86, bug 277798 (diff)
downloadgentoo-2-21382bfad301ca387dbef30d78ed875dc711144a.tar.gz
gentoo-2-21382bfad301ca387dbef30d78ed875dc711144a.tar.bz2
gentoo-2-21382bfad301ca387dbef30d78ed875dc711144a.zip
Make it work with xulrunner-1.9, update gcc 4.4 patch (use upstream commit)
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'media-gfx/freepv/freepv-0.3.0-r1.ebuild')
-rw-r--r--media-gfx/freepv/freepv-0.3.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/freepv/freepv-0.3.0-r1.ebuild b/media-gfx/freepv/freepv-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..c96c34370fd7
--- /dev/null
+++ b/media-gfx/freepv/freepv-0.3.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/freepv/freepv-0.3.0-r1.ebuild,v 1.1 2009/07/15 13:31:09 voyageur Exp $
+
+EAPI=2
+
+inherit cmake-utils nsplugins
+
+DESCRIPTION="Panorama viewer and browser plugin (Quicktime, PangeaVR, GLPanoView)"
+HOMEPAGE="http://freepv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freepv/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libxml2
+ media-libs/jpeg
+ media-libs/libpng
+ net-libs/xulrunner:1.9
+ virtual/glut
+ sys-libs/zlib
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_beta?/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ epatch "${FILESDIR}"/${P}-xulrunner-1.9.1.patch
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # Remove plugin and install it in the correct place
+ src_mv_plugins /usr/$(get_libdir)/mozilla/plugins
+}