summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2002-09-25 16:34:18 +0000
committerNick Hadaway <raker@gentoo.org>2002-09-25 16:34:18 +0000
commit7fcb6226439dc39c143e11fd65e7803d50097864 (patch)
treedb6cd38e9ebbede75851d6b1091a652da4d06acc /media-gfx/gimp-print
parentfixed URL of TLS patch (diff)
downloadgentoo-2-7fcb6226439dc39c143e11fd65e7803d50097864.tar.gz
gentoo-2-7fcb6226439dc39c143e11fd65e7803d50097864.tar.bz2
gentoo-2-7fcb6226439dc39c143e11fd65e7803d50097864.zip
Version bump. Lots of fixes. See...
http://sourceforge.net/project/shownotes.php?release_id=110475 for a complete list of changes.
Diffstat (limited to 'media-gfx/gimp-print')
-rw-r--r--media-gfx/gimp-print/ChangeLog10
-rw-r--r--media-gfx/gimp-print/files/digest-gimp-print-4.2.21
-rw-r--r--media-gfx/gimp-print/gimp-print-4.2.2.ebuild87
3 files changed, 97 insertions, 1 deletions
diff --git a/media-gfx/gimp-print/ChangeLog b/media-gfx/gimp-print/ChangeLog
index e0495f577227..af91f7310a20 100644
--- a/media-gfx/gimp-print/ChangeLog
+++ b/media-gfx/gimp-print/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for media-gfx/gimp-print
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.3 2002/04/28 23:47:28 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/ChangeLog,v 1.4 2002/09/25 16:34:18 raker Exp $
+
+*gimp-print-4.2.2 (25 Sep 2002)
+
+ 25 Sep 2002; Nick Hadaway <raker@gentoo.org> gimp-print-4.2.2.ebuild,
+ files/digest-gimp-pring-4.2.2 :
+ Version bump. Lots of fixes. See...
+ http://sourceforge.net/project/shownotes.php?release_id=110475
+ for a complete list of changes.
*gimp-print-4.2.1 (29 Apr 2002)
diff --git a/media-gfx/gimp-print/files/digest-gimp-print-4.2.2 b/media-gfx/gimp-print/files/digest-gimp-print-4.2.2
new file mode 100644
index 000000000000..3a73c1c9a23c
--- /dev/null
+++ b/media-gfx/gimp-print/files/digest-gimp-print-4.2.2
@@ -0,0 +1 @@
+MD5 5b95242674acd95511002795086b2ec3 gimp-print-4.2.2.tar.gz 4843433
diff --git a/media-gfx/gimp-print/gimp-print-4.2.2.ebuild b/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
new file mode 100644
index 000000000000..475f0660e2bf
--- /dev/null
+++ b/media-gfx/gimp-print/gimp-print-4.2.2.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp-print/gimp-print-4.2.2.ebuild,v 1.1 2002/09/25 16:34:18 raker Exp $
+
+inherit libtool
+
+MY_P=${P}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Gimp Plugin and Ghostscript driver for Gimp"
+SRC_URI="mirror://sourceforge/gimp-print/${MY_P}.tar.gz"
+HOMEPAGE="http://gimp-print.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+DEPEND=">=media-gfx/gimp-1.2.1
+ app-text/ghostscript
+ doc? ( app-text/texi2html )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ cups? ( >=net-print/cups-1.1.14 )"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+
+ elibtoolize
+ aclocal
+
+ local myconf
+
+ use cups && myconf="${myconf} --with-cups" \
+ || myconf="${myconf} --without-cups"
+
+ use nls && myconf="${myconf} --enable-nls" \
+ || myconf="${myconf} --disable-nls"
+
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ else
+ myconf="${myconf} --disable-debug"
+ fi
+
+ econf \
+ --with-ghost \
+ --sysconfdir=/etc/gimp/1.2/ \
+ --with-gimp-exec-prefix=/usr \
+ ${myconf} || die
+
+ cp src/gimp/Makefile src/gimp/Makefile.orig
+ sed -e 's:--install-admin-bin:--install-bin:g' \
+ src/gimp/Makefile.orig >src/gimp/Makefile
+
+ emake || die
+
+}
+
+src_install() {
+
+ dodir /usr/lib/gimp/1.2/.gimp-1.2/plug-ins
+
+ make prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc/gimp/1.2 \
+ libdir=${D}/usr/lib \
+ datadir=${D}/usr/share \
+ cups_conf_serverbin=${D}/usr/lib/cups \
+ cups_conf_datadir=${D}/usr/share/cups \
+ cups_conf_serverroot=${D}/etc/cups \
+ HOME=${D}/usr/lib/gimp/1.2 \
+ install || die
+
+ # NOTE: this build uses gimptool to install the plugin, so
+ # if we dont do it this way, it will install to / no
+ # matter what.
+ #
+ # NOTE to whoever commented this: Please DO NOT!
+ mv ${D}/usr/lib/gimp/1.2/.gimp-1.2/plug-ins/ \
+ ${D}/usr/lib/gimp/1.2/
+ rm -rf ${D}/usr/lib/gimp/1.2/.gimp-1.2/
+
+ dodoc AUTHORS ChangeLog COPYING NEWS README*
+ dohtml -r doc
+
+}