summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2013-09-15 19:02:17 +0000
committerSebastian Pipping <sping@gentoo.org>2013-09-15 19:02:17 +0000
commit96bc442ebf5ae3e78eec121505ab4a9e82fbe667 (patch)
tree12b4fd46b9a84f1166e265d47ff57947b589c3dd /media-gfx/gimp
parentFix unit files to not use forking and stop relying in /etc/conf.d files (diff)
downloadgentoo-2-96bc442ebf5ae3e78eec121505ab4a9e82fbe667.tar.gz
gentoo-2-96bc442ebf5ae3e78eec121505ab4a9e82fbe667.tar.bz2
gentoo-2-96bc442ebf5ae3e78eec121505ab4a9e82fbe667.zip
media-gfx/gimp: Add uclibc compile fix (bug #477794)
(Portage version: 2.1.12.5/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/ChangeLog6
-rw-r--r--media-gfx/gimp/files/gimp-2.8.6-uclibc.patch45
-rw-r--r--media-gfx/gimp/gimp-2.8.6.ebuild3
3 files changed, 52 insertions, 2 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index 21caf5c2d77a..cde7f143d50b 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-gfx/gimp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.411 2013/09/14 10:55:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.412 2013/09/15 19:02:17 sping Exp $
+
+ 15 Sep 2013; Sebastian Pipping <sping@gentoo.org> gimp-2.8.6.ebuild,
+ +files/gimp-2.8.6-uclibc.patch:
+ Add uclibc compile fix (bug #477794) straight to stable, seems adequate to me
14 Sep 2013; Agostino Sarubbo <ago@gentoo.org> gimp-2.8.6.ebuild:
Stable for alpha, wrt bug #481736
diff --git a/media-gfx/gimp/files/gimp-2.8.6-uclibc.patch b/media-gfx/gimp/files/gimp-2.8.6-uclibc.patch
new file mode 100644
index 000000000000..855e9872f4b4
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.8.6-uclibc.patch
@@ -0,0 +1,45 @@
+From 4fb7a436bca3e11abfda8bc23818af0f09714b9d Mon Sep 17 00:00:00 2001
+From: Michael Natterer <mitch@gimp.org>
+Date: Fri, 02 Aug 2013 14:50:00 +0000
+Subject: Bug 704980 - uclibc - base-utils.c: execinfo.h: No such file or directory
+
+Apply patch from Amadeusz Slawinski that checks for execinfo.h and
+builds the code that needs it conditionally.
+---
+diff --git a/app/base/base-utils.c b/app/base/base-utils.c
+index 757f58d..44a9e89 100644
+--- a/app/base/base-utils.c
++++ b/app/base/base-utils.c
+@@ -29,7 +29,7 @@
+ #include <process.h>
+ #endif
+
+-#ifdef G_OS_UNIX
++#if defined(G_OS_UNIX) && defined(HAVE_EXECINFO_H)
+ /* For get_backtrace() */
+ #include <stdlib.h>
+ #include <string.h>
+@@ -112,7 +112,7 @@ get_physical_memory_size (void)
+ char *
+ get_backtrace (void)
+ {
+-#ifdef G_OS_UNIX
++#if defined(G_OS_UNIX) && defined(HAVE_EXECINFO_H)
+ void *functions[MAX_FUNC];
+ char **function_names;
+ int n_functions;
+diff --git a/configure.ac b/configure.ac
+index 0bbcbc7..15c7cc6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -416,7 +416,7 @@ AC_HEADER_STDC
+ AC_HEADER_SYS_WAIT
+ AC_HEADER_TIME
+
+-AC_CHECK_HEADERS(sys/param.h sys/time.h sys/times.h sys/wait.h unistd.h)
++AC_CHECK_HEADERS(execinfo.h sys/param.h sys/time.h sys/times.h sys/wait.h unistd.h)
+
+ AC_TYPE_PID_T
+ AC_FUNC_VPRINTF
+--
+cgit v0.9.2
diff --git a/media-gfx/gimp/gimp-2.8.6.ebuild b/media-gfx/gimp/gimp-2.8.6.ebuild
index 8b0378fa44c4..23e234b3019c 100644
--- a/media-gfx/gimp/gimp-2.8.6.ebuild
+++ b/media-gfx/gimp/gimp-2.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.8.6.ebuild,v 1.7 2013/09/14 10:55:18 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-2.8.6.ebuild,v 1.8 2013/09/15 19:02:17 sping Exp $
EAPI="3"
PYTHON_DEPEND="python? 2:2.5"
@@ -112,6 +112,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PN}-2.7.4-no-deprecation.patch # bug 395695, comment 9 and 16
+ epatch "${FILESDIR}"/${P}-uclibc.patch # bug 477794
eautoreconf # If you remove this: remove dev-util/gtk-doc-am from DEPEND, too
echo '#!/bin/sh' > py-compile