summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-06-02 01:19:32 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-06-02 01:19:32 +0000
commitdbc8eaaf95ff2caf4bcb76e000d71560f90760a1 (patch)
tree91da9bc4cb589b8b26e0eeb6cc9bf7d9b40a8e2a /media-gfx/gimp
parentmissed the digest at some point (diff)
downloadgentoo-2-dbc8eaaf95ff2caf4bcb76e000d71560f90760a1.tar.gz
gentoo-2-dbc8eaaf95ff2caf4bcb76e000d71560f90760a1.tar.bz2
gentoo-2-dbc8eaaf95ff2caf4bcb76e000d71560f90760a1.zip
new dev version of gimp
Diffstat (limited to 'media-gfx/gimp')
-rw-r--r--media-gfx/gimp/ChangeLog6
-rw-r--r--media-gfx/gimp/files/digest-gimp-1.3.71
-rw-r--r--media-gfx/gimp/gimp-1.3.7.ebuild68
3 files changed, 74 insertions, 1 deletions
diff --git a/media-gfx/gimp/ChangeLog b/media-gfx/gimp/ChangeLog
index 8a490f1dacb4..d0947ddc4075 100644
--- a/media-gfx/gimp/ChangeLog
+++ b/media-gfx/gimp/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for media-gfx/gimp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.5 2002/05/23 00:02:19 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/ChangeLog,v 1.6 2002/06/02 01:19:32 spider Exp $
+*gimp-1.3.7 (01 Jun 2002)
+ 01 Jun 2002; Spider <spider@gentoo.org> gimp-1.3.7.ebuild:
+ new version out
+
*gimp-1.3.5 (22 May 2002)
22 May 2002; Spider <spider@gentoo.org> gimp-1.3.5.ebuild:
in the big gnome2 move I'm adding this beta..
diff --git a/media-gfx/gimp/files/digest-gimp-1.3.7 b/media-gfx/gimp/files/digest-gimp-1.3.7
new file mode 100644
index 000000000000..2e8fdb87fc6d
--- /dev/null
+++ b/media-gfx/gimp/files/digest-gimp-1.3.7
@@ -0,0 +1 @@
+MD5 1c4e7c0a0a09125c1d8b518eb1f1beef gimp-1.3.7.tar.bz2 9640060
diff --git a/media-gfx/gimp/gimp-1.3.7.ebuild b/media-gfx/gimp/gimp-1.3.7.ebuild
new file mode 100644
index 000000000000..ab690fb68af5
--- /dev/null
+++ b/media-gfx/gimp/gimp-1.3.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/gimp/gimp-1.3.7.ebuild,v 1.1 2002/06/02 01:19:32 spider Exp $
+
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Development series of Gimp"
+SRC_URI="ftp://ftp.gimp.org/pub/gimp/v1.3/v${PV}/${P}.tar.bz2"
+HOMEPAGE="http://www.gimp.org/"
+SLOT="1.4"
+
+#libglade
+RDEPEND=">=x11-libs/gtk+-2.0.0
+ >=x11-libs/pango-1.0.0
+ >=dev-libs/glib-2.0.0
+ >=media-libs/libpng-1.2.1
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.7
+ >=media-libs/libart_lgpl-2.3.8-r1
+ sys-devel/gettext
+ cups? ( media-gfx/gimp-print )
+ "
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )"
+
+src_compile() {
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use cups && myconf="${myconf} --enable-print" || myconf="${myconf} --disable-print"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --localstatedir=/var/lib \
+ --disable-perl ${myconf} \
+ --without-gnome-desktop \
+ || die
+ # disable gnome-desktop since it breaks sandboxing
+
+# hack for odd make break
+ touch plug-ins/common/${P}.tar.bz2
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ localstatedir=/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeL* HACKING INSTALL MAINTAINERS NEWS PLUGIN_MAINTAINERS README* TODO*
+
+}
+
+